15 matches found
CVE-2026-47831
Use of a cryptographically weak random number generator in the GenerateRandomPassword function in bosh-windows-stemcell-builder allows a remote attacker to brute-force the resulting SSH login via TCP/22. Affected versions: bosh-windows-stemcell-builder versions prior to v2019.98...
PT-2026-56708
Use of a cryptographically weak random number generator in the GenerateRandomPassword function in bosh-windows-stemcell-builder allows a remote attacker to brute-force the resulting SSH login via TCP/22. Affected versions: bosh-windows-stemcell-builder versions prior to v2019.98...
WS-2019-0002
Affected versions of generate-password before 1.4.1 generate random values that are biased towards certain characters depending on the chosen character sets. This may result in guessable passwords...
@troveng/trov-web-config (1.0.5), @zce/ghost-cli (>=1.9.7, <=1.9.8) +13 more potentially affected by unknown CVE via generate-password (>=1.3.0, <=1.4.0)
generate-password NPM version =1.3.0, =1.9.7, =1.0.2, =1.16.0, =0.1.4, =0.1.11, =1.4.0, =0.6.0, =0.9.11, =0.0.2, =1.6.0, =4.20.9, =0.9.0, =1.0.79, =1.4.0, =1.11.0 Source cves: unknown CVE Source advisory: MEND:WS-2019-0002...
CVE-2025-67504 WBCE CMS has Weak Random Number Generator in Password Generation Function
WBCE CMS is a content management system. Versions 1.6.4 and below use function GenerateRandomPassword to create passwords using PHP's rand. rand is not cryptographically secure, which allows password sequences to be predicted or brute-forced. This can lead to user account compromise or privilege...
CVE-2025-6931 D-Link DCS-6517/DCS-7517 Root Password Generation httpd generate_pass_from_mac entropy
A vulnerability classified as problematic was found in D-Link DCS-6517 and DCS-7517 up to 2.02.0. Affected by this vulnerability is the function generatepassfrommac of the file /bin/httpd of the component Root Password Generation Handler. The manipulation leads to insufficient entropy. The attack...
@troveng/trov-web-config (1.0.5), @zce/ghost-cli (>=1.9.7, <=1.9.8) +13 more potentially affected by unknown CVE via generate-password (>=1.3.0, <=1.4.0)
generate-password NPM version =1.3.0, =1.9.7, =1.0.2, =1.16.0, =0.1.4, =0.1.11, =1.4.0, =0.6.0, =0.9.11, =0.0.2, =1.6.0, =4.20.9, =0.9.0, =1.0.79, =1.4.0, =1.11.0 Source cves: unknown CVE Source advisory: OSV:GHSA-6QQF-VVCR-7QRV...
GHSA-6QQF-VVCR-7QRV Cryptographically Weak PRNG in generate-password
Affected versions of generate-password generate random values that are biased towards certain characters depending on the chosen character sets. This may result in guessable passwords. Recommendation Update to version 1.4.1 or later...
@troveng/trov-web-config (1.0.5), @zce/ghost-cli (>=1.9.7, <=1.9.8) +13 more potentially affected by unknown CVE via generate-password (>=1.3.0, <=1.4.0)
generate-password NPM version =1.3.0, =1.9.7, =1.0.2, =1.16.0, =0.1.4, =0.1.11, =1.4.0, =0.6.0, =0.9.11, =0.0.2, =1.6.0, =4.20.9, =0.9.0, =1.0.79, =1.4.0, =1.11.0 Source cves: unknown CVE Source advisory: GHSA-6QQF-VVCR-7QRV...
PT-2019-20015
Name of the Vulnerable Software and Affected Versions generate-password versions prior to 1.4.1 Description The issue affects the generation of random passwords, causing them to be biased towards certain characters based on the chosen character sets. This bias can result in passwords that are mor...
Cryptographically Weak PRNG
Overview Affected versions of generate-password generate random values that are biased towards certain characters depending on the chosen character sets. This may result in guessable passwords. Recommendation Update to version 1.4.1 or later. References - GitHub Pull - GitHub Advisory...
CVE-2017-18032
The download-manager plugin before 2.9.52 for WordPress has XSS via the id parameter in a wpdmgeneratepassword action to wp-admin/admin-ajax.php...
PT-2018-6624
Name of the Vulnerable Software and Affected Versions: WordPress download-manager plugin versions prior to 2.9.52 Description: The issue concerns a security problem where an attacker can exploit the id parameter in a wpdm generate password action to wp-admin/admin-ajax.php API endpoint, leading t...
PT-2014-8311
Name of the Vulnerable Software and Affected Versions Moodle versions 2.4.11 and earlier, 2.5.x before 2.5.9, 2.6.x before 2.6.6, 2.7.x before 2.7.3 Description The issue concerns the generate password function, which does not provide a sufficient number of possible temporary passwords. This allo...
PT-2010-5570 · Ibm · Ibm Tivoli Storage Manager
Name of the Vulnerable Software and Affected Versions: IBM Tivoli Storage Manager TSM versions 5.3.x through 5.3.6.9 IBM Tivoli Storage Manager TSM versions 5.4.x through 5.4.3.3 IBM Tivoli Storage Manager TSM versions 5.5.x through 5.5.2.9 IBM Tivoli Storage Manager TSM versions 6.1.x through...