Lucene search
+L

17 matches found

osv_clsa
osv_clsa
•added 2026/10/25 2:30 p.m.•18 views

CLSA-2026-1792938613 TuxCare security update for gatsby-plugin-sharp (1 CVE)

TuxCare rebuilt gatsby-plugin-sharp to address 1 CVE. Fixed in 2.14.4-tuxcare.1...

4.3CVSS5.4AI score0.00882EPSS
SaveExploits1
RedhatCVE
RedhatCVE
•added 2025/05/23 2:09 a.m.•25 views

CVE-2023-30548

gatsby-plugin-sharp is a plugin for the gatsby framework which exposes functions built on the Sharp image processing library. The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server gatsby develop. It...

4.3CVSS5.2AI score0.00882EPSS
SaveExploits1References1
vulnersOsv
vulnersOsv
•added 2023/04/20 7:05 p.m.•8 views

@boomerang-io/gatsby-theme-boomerang (>=1.5.0-beta.0, <=1.6.2), @sonarsource/gatsby-theme-marketing (>=3.1.0, <=3.5.0) potentially affected by CVE-2023-30548 via gatsby-plugin-sharp (>=5.0.0, <=5.6.0)

gatsby-plugin-sharp NPM version =5.0.0, =1.5.0-beta.0, =3.1.0, =3.5.0 Source cves: CVE-2023-30548 Source advisory: OSV:GHSA-H2PM-378C-PCXX...

4.3CVSS5AI score0.00882EPSS
SaveExploits1
osv_ghsa
osv_ghsa
•added 2023/04/20 7:05 p.m.•100 views

GHSA-H2PM-378C-PCXX Path traversal vulnerability in gatsby-plugin-sharp

Impact The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server gatsby develop. The following steps can be used to reproduce the vulnerability: Create a new Gatsby project, and install...

4.3CVSS5.8AI score0.00882EPSS
SaveExploits1References5
vulnersOsv
vulnersOsv
•added 2023/04/20 7:05 p.m.•6 views

@adobe/gatsby-theme-aio (>=4.5.7, <=4.7.5), @adobe/gatsby-theme-commerce (0.0.2) +19 more potentially affected by CVE-2023-30548 via gatsby-plugin-sharp (>=4.0.0-alpha-9689ff.4, <=4.25.0)

gatsby-plugin-sharp NPM version =4.0.0-alpha-9689ff.4, =4.5.7, =0.3.0-beta.0, =3.0.0, =4.0.0, =0.0.0-canary-20211022203039, =1.18.5, =1.0.2, =5.0.8, =0.0.1, =2.0.4, =1.0.0, =1.0.12 - fullstack-gatsby-theme-bch-wallet-v1 1.0.12 and more Source cves: CVE-2023-30548 Source advisory:...

4.3CVSS0.00882EPSS
SaveExploits1
vulnersOsv
vulnersOsv
•added 2023/04/20 7:05 p.m.•5 views

@adobe/gatsby-theme-aio (>=4.5.7, <=4.7.5), @adobe/gatsby-theme-commerce (0.0.2) +19 more potentially affected by CVE-2023-30548 via gatsby-plugin-sharp (>=4.0.0-alpha-9689ff.4, <=4.25.0)

gatsby-plugin-sharp NPM version =4.0.0-alpha-9689ff.4, =4.5.7, =0.3.0-beta.0, =3.0.0, =4.0.0, =0.0.0-canary-20211022203039, =1.18.5, =1.0.2, =5.0.8, =0.0.1, =2.0.4, =1.0.0, =1.0.12 - fullstack-gatsby-theme-bch-wallet-v1 1.0.12 and more Source cves: CVE-2023-30548 Source advisory: GHSA-H2PM-378C-P...

4.3CVSS0.00882EPSS
SaveExploits1
Github Security Blog
Github Security Blog
•added 2023/04/20 7:05 p.m.•47 views

Path traversal vulnerability in gatsby-plugin-sharp

Impact The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server gatsby develop. The following steps can be used to reproduce the vulnerability: Create a new Gatsby project, and install...

4.3CVSS5.5AI score0.00882EPSS
SaveExploits1References5Affected Software1
vulnersOsv
vulnersOsv
•added 2023/04/20 7:05 p.m.•6 views

@boomerang-io/gatsby-theme-boomerang (>=1.5.0-beta.0, <=1.6.2), @sonarsource/gatsby-theme-marketing (>=3.1.0, <=3.5.0) potentially affected by CVE-2023-30548 via gatsby-plugin-sharp (>=5.0.0, <=5.6.0)

gatsby-plugin-sharp NPM version =5.0.0, =1.5.0-beta.0, =3.1.0, =3.5.0 Source cves: CVE-2023-30548 Source advisory: GHSA-H2PM-378C-PCXX...

4.3CVSS0.00882EPSS
SaveExploits1
Prion
Prion
•added 2023/04/17 9:15 p.m.•31 views

Path traversal

gatsby-plugin-sharp is a plugin for the gatsby framework which exposes functions built on the Sharp image processing library. The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server gatsby develop. It...

4CVSS4.4AI score0.00882EPSS
SaveExploits1References3Affected Software1
Vulnrichment
Vulnrichment
•added 2023/04/17 8:43 p.m.•17 views

CVE-2023-30548 Path traversal vulnerability in gatsby-plugin-sharp

gatsby-plugin-sharp is a plugin for the gatsby framework which exposes functions built on the Sharp image processing library. The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server gatsby develop. It...

4.3CVSS4.5AI score0.00882EPSS
SaveExploits1References3
vulnersOsv
vulnersOsv
•added 2023/04/17 8:43 p.m.•6 views

@boomerang-io/gatsby-theme-boomerang (>=1.5.0-beta.0, <=1.6.2), @sonarsource/gatsby-theme-marketing (>=3.1.0, <=3.5.0) potentially affected by CVE-2023-30548 via gatsby-plugin-sharp (>=5.0.0, <=5.6.0)

gatsby-plugin-sharp NPM version =5.0.0, =1.5.0-beta.0, =3.1.0, =3.5.0 Source cves: CVE-2023-30548 Source advisory: MEND:CVE-2023-30548...

4.3CVSS0.00882EPSS
SaveExploits1
Cvelist
Cvelist
•added 2023/04/17 8:43 p.m.•65 views

CVE-2023-30548 Path traversal vulnerability in gatsby-plugin-sharp

gatsby-plugin-sharp is a plugin for the gatsby framework which exposes functions built on the Sharp image processing library. The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server gatsby develop. It...

4.3CVSS4.8AI score0.00882EPSS
SaveExploits1References3
vulnersOsv
vulnersOsv
•added 2023/04/17 8:43 p.m.•7 views

10secondsofcode-custom (1.0.0), 1kohei1 (>=1.0.0, <=1.0.1) +947 more potentially affected by CVE-2023-30548 via gatsby-plugin-sharp (>=1.6.7, <=4.25.0)

gatsby-plugin-sharp NPM version =1.6.7, =1.0.0, =1.0.1, =1.0.0, =0.1.13, =0.48.0, =1.0.0, =1.0.0, =1.0.10, =3.0.0, =4.7.5 - @adobe/gatsby-theme-commerce 0.0.2 and more Source cves: CVE-2023-30548 Source advisory: MEND:CVE-2023-30548...

4.3CVSS0.00882EPSS
SaveExploits1
Mend
Mend
•added 2023/04/17 8:43 p.m.•13 views

CVE-2023-30548

gatsby-plugin-sharp is a plugin for the gatsby framework which exposes functions built on the Sharp image processing library. The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server gatsby develop. It...

5.3CVSS0.00882EPSS
SaveExploits1References6
CVE
CVE
•added 2023/04/17 8:43 p.m.•96 views

CVE-2023-30548

The CVE-2023-30548 issue affects gatsby-plugin-sharp prior to versions 5.8.1 and 4.25.1, introducing a path traversal vulnerability when running the Gatsby develop server. By default, develop is bound to localhost, but if exposed (e.g., via --host 0.0.0.0, -H 0.0.0.0, or GATSBY_HOST=0.0.0.0), an ...

4.3CVSS5.4AI score0.00882EPSS
SaveExploits1References3Affected Software1
Positive Technologies
Positive Technologies
•added 2023/04/17 12:00 a.m.•27 views

PT-2023-22774

Name of the Vulnerable Software and Affected Versions gatsby-plugin-sharp versions prior to 5.8.1 and 4.25.1 Description The gatsby-plugin-sharp plugin contains a path traversal vulnerability exposed when running the Gatsby develop server gatsby develop. By default, gatsby develop is only...

4.3CVSS4.3AI score0.00882EPSS
SaveExploits1References12
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2023/04/17 12:00 a.m.•8 views

CVE-2023-30548: Improper Limitation of a Pathname to a Restricted Directory

gatsby-plugin-sharp is a plugin for the gatsby framework which exposes functions built on the Sharp image processing library. The gatsby-plugin-sharp plugin prior to versions 5.8.1 and 4.25.1 contains a path traversal vulnerability exposed when running the Gatsby develop server gatsby develop. It...

4.3CVSS5.7AI score0.00882EPSS
SaveExploits1References8
Rows per page
Query Builder