20 matches found
Moodle Allows Modification of Constants
The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant...
GHSA-JCRJ-GMR6-P5J8 Moodle Allows Modification of Constants
The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant...
CVE-2013-2083
The MoodleQuickForm class in lib/formslib.php in Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not properly handle a certain array-element syntax, which allows remote attackers to bypass intended form-data filtering via a crafted request...
Cross site request forgery (csrf)
The MoodleQuickForm class in lib/formslib.php in Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not properly handle a certain array-element syntax, which allows remote attackers to bypass intended form-data filtering via a crafted request...
CVE-2013-2083
The MoodleQuickForm class in lib/formslib.php in Moodle through 2.1.10, 2.2.x before 2.2.10, 2.3.x before 2.3.7, and 2.4.x before 2.4.4 does not properly handle a certain array-element syntax, which allows remote attackers to bypass intended form-data filtering via a crafted request...
PT-2013-3537
Name of the Vulnerable Software and Affected Versions Moodle versions prior to 2.1.11 Moodle versions 2.2.x prior to 2.2.10 Moodle versions 2.3.x prior to 2.3.7 Moodle versions 2.4.x prior to 2.4.4 Description The issue arises from the improper handling of a certain array-element syntax by the...
Design/Logic Flaw
lib/formslib.php in Moodle 2.2.x before 2.2.6 and 2.3.x before 2.3.3 allows remote authenticated users to bypass intended access restrictions via a modified value of a frozen form field...
CVE-2012-5472
lib/formslib.php in Moodle 2.2.x before 2.2.6 and 2.3.x before 2.3.3 allows remote authenticated users to bypass intended access restrictions via a modified value of a frozen form field...
CVE-2012-5472
lib/formslib.php in Moodle 2.2.x before 2.2.6 and 2.3.x before 2.3.3 allows remote authenticated users to bypass intended access restrictions via a modified value of a frozen form field...
CVE-2012-5472
CVE-2012-5472 affects Moodle 2.2.x before 2.2.6 and 2.3.x before 2.3.3. The vulnerability arises in lib/formslib.php where a frozen form field can be manipulated by a remote authenticated user to bypass intended access restrictions. Root cause is improper handling of frozen form elements, allowin...
PT-2012-5988
Name of the Vulnerable Software and Affected Versions Moodle versions 2.2.x through 2.2.5 Moodle versions 2.3.x through 2.3.2 Description The issue allows remote authenticated users to bypass intended access restrictions. This is achieved by modifying the value of a frozen form field in...
CVE-2012-5472: Undefined Security Weakness
lib/formslib.php in Moodle 2.2.x before 2.2.6 and 2.3.x before 2.3.3 allows remote authenticated users to bypass intended access restrictions via a modified value of a frozen form field...
CVE-2012-0801
lib/formslib.php in Moodle 2.1.x before 2.1.4 and 2.2.x before 2.2.1 does not properly handle multiple instances of a form element, which has unspecified impact and remote attack vectors...
CVE-2012-0801
lib/formslib.php in Moodle 2.1.x before 2.1.4 and 2.2.x before 2.2.1 does not properly handle multiple instances of a form element, which has unspecified impact and remote attack vectors...
CVE-2012-0801
lib/formslib.php in Moodle 2.1.x before 2.1.4 and 2.2.x before 2.2.1 does not properly handle multiple instances of a form element, which has unspecified impact and remote attack vectors...
CVE-2012-0801
CVE-2012-0801 affects Moodle’s lib/formslib.php. Vulnerable in Moodle 2.1.x before 2.1.4 and 2.2.x before 2.2.1 due to improper handling of multiple form element instances. Impact is unspecified in the provided sources. Remediate by upgrading Moodle to 2.1.4 or later, or 2.2.1 or later. Exploit d...
CVE-2012-0801
lib/formslib.php in Moodle 2.1.x before 2.1.4 and 2.2.x before 2.2.1 does not properly handle multiple instances of a form element, which has unspecified impact and remote attack vectors...
CVE-2012-0801: Improper Input Validation
lib/formslib.php in Moodle 2.1.x before 2.1.4 and 2.2.x before 2.2.1 does not properly handle multiple instances of a form element, which has unspecified impact and remote attack vectors...
CVE-2011-4301
The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant...
CVE-2011-4301: Undefined Security Weakness
The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant...