27960 matches found
@automatedtf/catalog (>=0.0.1, <=0.0.27), @automatedtf/reactor (>=0.0.1, <=0.0.9) +3 more potentially affected by CVE-2024-41655 via tf2-item-format (4.3.5)
tf2-item-format NPM version 4.3.5 is affected by a known vulnerability. The following packages have a transitive dependency on tf2-item-format and may be impacted: - @automatedtf/catalog =0.0.1, =0.0.1, =0.0.1, =0.0.1, =0.0.25 - @vendortf/catalog 0.0.27 Source cves: CVE-2024-41655 Source advisory...
(ReDoS) Regular Expression Denial of Service in tf2-item-format
Summary Versions of tf2-item-format since at least 4.2.6 are vulnerable to a Regular Expression Denial of Service ReDoS attack when parsing crafted user input. Tested Versions - 5.9.13 - 5.8.10 - 5.7.0 - 5.6.17 - 4.3.5 - 4.2.6 v5 Upgrade package to ^5.9.14 v4 No patch exists. Please consult the v...
@automatedtf/catalog (>=0.0.1, <=0.0.27), @automatedtf/reactor (>=0.0.1, <=0.0.9) +3 more potentially affected by CVE-2024-41655 via tf2-item-format (4.3.5)
tf2-item-format NPM version 4.3.5 is affected by a known vulnerability. The following packages have a transitive dependency on tf2-item-format and may be impacted: - @automatedtf/catalog =0.0.1, =0.0.1, =0.0.1, =0.0.1, =0.0.25 - @vendortf/catalog 0.0.27 Source cves: CVE-2024-41655 Source advisory...
GHSA-8H55-Q5QQ-P685 (ReDoS) Regular Expression Denial of Service in tf2-item-format
Summary Versions of tf2-item-format since at least 4.2.6 are vulnerable to a Regular Expression Denial of Service ReDoS attack when parsing crafted user input. Tested Versions - 5.9.13 - 5.8.10 - 5.7.0 - 5.6.17 - 4.3.5 - 4.2.6 v5 Upgrade package to ^5.9.14 v4 No patch exists. Please consult the v...
PT-2024-29484
Name of the Vulnerable Software and Affected Versions tf2-item-format versions 4.2.6 through 5.9.13 Description The issue is related to a Regular Expression Denial of Service ReDoS attack when parsing crafted user input. This can be exploited by an attacker to perform DoS attacks on any service...
PT-2024-7808 · Jt2Go · Jt2Go
Name of the Vulnerable Software and Affected Versions: JT2Go versions prior to V2406.0003 Description: A stack-based buffer overflow issue has been identified in the affected application. This issue could be triggered while parsing specially crafted PDF files, potentially allowing an attacker to...
TF2 Item Format Security Vulnerability
TF2 Item Format is a library for GlenCoco individual developers. It helps users to set the format of TF2 items as a community standard. A security vulnerability existed in TF2 Item Format prior to version 5.9.14, which stemmed from the vulnerability of the tf2-item-format function to regular...
Ubuntu 20.04 LTS / 22.04 LTS / 24.04 LTS : Nova vulnerability (USN-6911-1)
The remote Ubuntu 20.04 LTS / 22.04 LTS / 24.04 LTS host has packages installed that are affected by a vulnerability as referenced in the USN-6911-1 advisory. Arnaud Morin discovered that Nova incorrectly handled certain raw format images. An authenticated user could use this issue to access...
ALSA-2024:4762 Important: runc security update
The runC tool is a lightweight, portable implementation of the Open Container Format OCF that provides container runtime. Security Fixes: golang-fips/openssl: Memory leaks in code encrypting and decrypting RSA payloads CVE-2024-1394 For more details about the security issues, including the impact...
PT-2024-33734
Name of the Vulnerable Software and Affected Versions: Linux kernel versions prior to 6.6.58 Description: The issue is related to an index out of bounds problem in the cm helper translate curve to degamma hw format function, which could occur when the index 'i' exceeds the number of transfer...
PT-2024-33735
Name of the Vulnerable Software and Affected Versions: Linux kernel versions prior to 6.6.58 Description: The issue is related to a potential index out of bounds problem in the cm3 helper translate curve to degamma hw format function within the DCN30 color management module. This could occur when...
CVE-2024-41655: Executable Regular Expression Error
TF2 Item Format helps users format TF2 items to the community standards. Versions of tf2-item-format since at least 4.2.6 and prior to 5.9.14 are vulnerable to a Regular Expression Denial of Service ReDoS attack when parsing crafted user input. This vulnerability can be exploited by an attacker t...
Important: runc security update
The runC tool is a lightweight, portable implementation of the Open Container Format OCF that provides container runtime. Security Fixes: golang-fips/openssl: Memory leaks in code encrypting and decrypting RSA payloads CVE-2024-1394 For more details about the security issues, including the impact...
Heap Based Buffer Overflow
Assimp is vulnerable to heap-based buffer overflow. The vulnerability is due to improper handling of crafted Polygon File Format ply files within PlyLoader.cpp, which allows a local attacker to execute arbitrary code...
PT-2024-37767 · National Instruments · Labview
Name of the Vulnerable Software and Affected Versions: LabVIEW versions prior to 2024 Q1 Description: The issue is caused by an integer overflow due to improper input validation when reading TDMS files, potentially leading to an infinite loop. To exploit this, an attacker would need to provide a...
PT-2024-28174 · Unknown · Seraphinite Post .Docx Source
Name of the Vulnerable Software and Affected Versions: Seraphinite Post .DOCX Source versions n/a through 2.16.9 Description: The issue is a Server-Side Request Forgery SSRF vulnerability. This means that an attacker could potentially force the server to make requests to arbitrary domains, which...
Ghostscript Command Execution / Format String Exploit
This Metasploit module exploits a format string vulnerability in Ghostscript versions before 10.03.1 to achieve a SAFER sandbox bypass and execute arbitrary commands. This vulnerability is reachable via libraries such as ImageMagick. This exploit only works against Ghostscript versions 10.03.0 an...
Ghostscript Command Execution / Format String
This module requires Metasploit: https://metasploit.com/download Current source: https://github.com/rapid7/metasploit-framework class MetasploitModule 'Ghostscript Command Execution via Format String', 'Description' = %q This module exploits a format string vulnerability in Ghostscript versions...
CVE-2024-6961 XXE in Guardrails AI when consuming RAIL documents
RAIL documents are an XML-based format invented by Guardrails AI to enforce formatting checks on LLM outputs. Guardrails users that consume RAIL documents from external sources are vulnerable to XXE, which may cause leakage of internal file data via the SYSTEM entity...
CVE-2024-6961
CVE-2024-6961 describes an XML External Entity (XXE) vulnerability in Guardrails AI when consuming RAIL documents from external sources, potentially allowing leakage of internal file data via the SYSTEM entity. The affected component is Guardrails AI and its RAIL document handling; the underlying...