32 matches found
CVE-2026-86463
A flaw was found in the Apache CXF Feed Item Query Language FIQL query parser, which can lead to a Denial of Service DoS. When evaluating query expressions, the parser attempts excessive combinations upon encountering long input strings lacking operators. A remote attacker can exploit this...
CLEANSTART-2026-XT41659 Apache CXF's FIQL query parser has a vulnerability in how it searches for operators in query expressions
Security vulnerability affects the wildfly package. Apache CXF's FIQL query parser has a vulnerability in how it searches for operators in query expressions...
CVE-2026-86463
Apache CXF's FIQL query parser has a vulnerability in how it searches for operators in query expressions. The search pattern can get stuck trying many combinations when it encounters a long string without an operator, causing the parser to consume excessive CPU time. An attacker can send a crafte...
EUVD-2026-95698
Apache CXF's FIQL query parser has a vulnerability in how it searches for operators in query expressions. The search pattern can get stuck trying many combinations when it encounters a long string without an operator, causing the parser to consume excessive CPU time. An attacker can send a crafte...
CVE-2026-86463 Apache CXF: FIQL Query Parser Denial of Service
Apache CXF's FIQL query parser has a vulnerability in how it searches for operators in query expressions. The search pattern can get stuck trying many combinations when it encounters a long string without an operator, causing the parser to consume excessive CPU time. An attacker can send a crafte...
CVE-2026-86463 Apache CXF: FIQL Query Parser Denial of Service
Apache CXF's FIQL query parser has a vulnerability in how it searches for operators in query expressions. The search pattern can get stuck trying many combinations when it encounters a long string without an operator, causing the parser to consume excessive CPU time. An attacker can send a crafte...
CVE-2026-86463 Apache CXF: FIQL Query Parser Denial of Service
Apache CXF's FIQL query parser has a vulnerability in how it searches for operators in query expressions. The search pattern can get stuck trying many combinations when it encounters a long string without an operator, causing the parser to consume excessive CPU time. An attacker can send a crafte...
CVE-2026-86463
Apache CXF's FIQL query parser has a vulnerability in how it searches for operators in query expressions. The search pattern can get stuck trying many combinations when it encounters a long string without an operator, causing the parser to consume excessive CPU time. An attacker can send a crafte...
CVE-2026-86463
The Apache CXF FIQL query parser contains a vulnerability where the search pattern for operators can become stuck when processing long strings without an operator. This flaw causes the parser to consume excessive CPU time , potentially leading to a Denial of Service (DoS) or significant performan...
PT-2026-108818
Name of the Vulnerable Software and Affected Versions Apache CXF versions prior to 4.2.4 Apache CXF versions prior to 4.1.9 Apache CXF versions prior to 3.6.13 Description The FIQL query parser contains a flaw in its operator search mechanism. When processing a long string that lacks an operator,...
CVE-2026-86463: Uncontrolled Resource Consumption
Apache CXF's FIQL query parser has a vulnerability in how it searches for operators in query expressions. The search pattern can get stuck trying many combinations when it encounters a long string without an operator, causing the parser to consume excessive CPU time. An attacker can send a crafte...
SQL Injection
Overview Affected versions of this package are vulnerable to SQL Injection via the Neo4j persistence layer when processing FIQL search conditions. An attacker can execute arbitrary Cypher queries by crafting malicious FIQL search inputs. Remediation Upgrade...
CVE-2026-86460
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
CVE-2026-86460
A Cypher injection vulnerability exists in the Neo4j persistence layer of Apache Syncope when processing certain FIQL search conditions . This flaw affects versions 3.0.0-M0 through 3.0.16 , 4.0.0-M0 through 4.0.7 , and 4.1.0-M0 through 4.1.2 . Impacting the persistence layer, the vulnerability c...
CVE-2026-86460 Apache Syncope: Cypher Injection via FIQL Search on Neo4j Persistence
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
CVE-2026-86460
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
EUVD-2026-77375
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
CVE-2026-86460 Apache Syncope: Cypher Injection via FIQL Search on Neo4j Persistence
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
CVE-2026-86460: Improper Neutralization of Special Elements used in an SQL Command
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
PT-2026-91150
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...