22 matches found
[SECURITY] Fedora 45 Update: ocaml-extlib-1.8.0-10.fc45
ExtLib is a project aiming at providing a complete - yet small - standard library for the OCaml programming language. The purpose of this library is to add new functions to OCaml Standard Library modules, to modify some functions in order to get better performances or more safety tail-recursive b...
EUVD-2017-0204
Malware in sbrugna...
OPENSUSE-SU-2024:10188-1 ruby2.2-rubygem-extlib-0.9.16-7.4 on GA media
These are all security issues fixed in the ruby2.2-rubygem-extlib-0.9.16-7.4 package on the GA media of openSUSE Tumbleweed...
SUSE CVE-2013-1802
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service memory and CPU consumption by leveraging Action Pack support for 1 YAML typ...
PT-2021-17995
Name of the Vulnerable Software and Affected Versions: MagpieRSS version 0.72 Description: The issue arises from a lack of validation on a curl command in the /extlib/Snoopy.class.inc file. This allows an attacker to request any internal page when sending a request to the /scripts/magpie debug.ph...
MagpieRSS security vulnerabilities
A security vulnerability exists in MagpieRSS in 0.72, which originates from a command escape error in /extlib/Snoopy.class.inc and can be exploited by an attacker to execute arbitrary commands...
SOURCEFORGE MagpieRSS code-related vulnerabilities
SOURCEFORGE MagpieRSS is SOURCEFORGE open source an application . Used to parse RSS 1.0 and earlier versions of a simple , practical PHP interface . MagpieRSS 0.72 has a security vulnerability where the curl command in /extlib/Snoopy.class.inc is not validated...
GHSA-9H36-4JF2-HX53 extlib does not properly restrict casts of string values
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service memory and CPU consumption by leveraging Action Pack support for 1 YAML typ...
extlib does not properly restrict casts of string values
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service memory and CPU consumption by leveraging Action Pack support for 1 YAML typ...
CVE-2013-1802
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service memory and CPU consumption by leveraging Action Pack support for 1 YAML typ...
DEBIAN-CVE-2013-1802
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service memory and CPU consumption by leveraging Action Pack support for 1 YAML typ...
CVE-2013-1802
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service memory and CPU consumption by leveraging Action Pack support for 1 YAML typ...
CVE-2013-1802
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service memory and CPU consumption by leveraging Action Pack support for 1 YAML typ...
UBUNTU-CVE-2013-1802
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service memory and CPU consumption by leveraging Action Pack support for 1 YAML typ...
Type confusion
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service memory and CPU consumption by leveraging Action Pack support for 1 YAML typ...
CVE-2013-1802
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service memory and CPU consumption by leveraging Action Pack support for 1 YAML typ...
CVE-2013-1802
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service memory and CPU consumption by leveraging Action Pack support for 1 YAML typ...
CVE-2013-1802
CVE-2013-1802 concerns the extlib gem for Ruby (0.9.15 and earlier). The vulnerability arises from improper restriction of casts of string values, allowing object-injection and potentially arbitrary code execution or denial of service via YAML type conversion or Symbol type conversion, similar to...
CVE-2013-1802
The extlib gem 0.9.15 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service memory and CPU consumption by leveraging Action Pack support for 1 YAML typ...
PT-2013-3401
Name of the Vulnerable Software and Affected Versions extlib gem versions 0.9.15 and earlier Description The issue is related to the improper restriction of casts of string values, which could allow remote attackers to conduct object-injection attacks, execute arbitrary code, or cause a denial of...