378 matches found
Astra Linux – vulnerability in exim4
In Exim versions prior to 4.99.2, when utf8 operators are enabled, there is a read beyond the bounds of memory if large UTF-8 trailing characters are present malformed UTF-8 header data. This information may be disclosed within an error message generated when processing an unrelated e-mail messag...
Astra Linux – Vulnerability in exim4
Exim 4 before 4.94.2 allows Heap-based Buffer Overflows because it mishandles the "-F’.‘” syntax on the command line. This may allow privilege escalation from any user to root. This issue occurs due to the incorrect interpretation of negative sizes in the strncpy function...
Astra Linux – Vulnerability in exim4
Exim 4 before 4.94.2 has an improper neutralization of line delimiters. Local users can alter the behavior of root processes because a recipient address may contain a newline character...
Astra Linux – Vulnerability in exim4
Exim 4 before 4.94.2 has an improper restriction on write operations within the bounds of a memory buffer. This occurs when processing name=value pairs within MAIL FROM and RCPT TO commands...
Astra Linux – Vulnerability in exim4
Exim 4 before 4.94.2 allowed out-of-bounds read vulnerabilities. The smtpsetupmsg function may disclose sensitive information from the process memory to an unauthenticated SMTP client...
Astra Linux – Vulnerability in exim4
Exim 4 before 4.94.2 allows Out-of-bounds Read because pdkimfinishbodyhash does not validate the relationship between sig-bodyhash.len and b-bh.len; thus, a crafted DKIM-Signature header might lead to the leakage of sensitive information from process memory...
Astra Linux – Vulnerability in exim4
Exim before version 4.95 has a heap-based buffer overflow for the alias list in hostnamelookup in host.c when senderhostname is set...
Astra Linux – Vulnerability in exim4
Exim 4.98 before 4.98.1 allowed remote SQL injection when SQLite hints and ETRN serialization were used. Resolving SQL injection requires an update to 4.99.1 in certain non-default rate-limit configurations...
Astra Linux – Vulnerability in exim4
Exim 4 before 4.94.2 allowed Buffer Underwrite, which could allow unauthenticated remote attackers to execute arbitrary commands. This is because smtpungetc was only intended for pushing back characters, but it can actually be used to push back non-character error codes, such as EOF...
Astra Linux – vulnerability in exim4
Exim 4 prior to version 4.94.2 suffers from improper neutralization of line delimiters; this issue is relevant in non-default configurations that enable Delivery Status Notification DSN. Certain usage patterns involving ORCPT= can insert a newline into a spool header file, thereby indirectly...
Astra Linux – vulnerability in exim4
Exim versions prior to 4.97.1 allow SMTP smuggling in certain PIPELINING/CHUNKING configurations. Remote attackers can exploit a published exploitation technique to inject email messages containing a spoofed MAIL FROM address, thereby bypassing an SPF protection mechanism. This happens because Ex...
Astra Linux – Vulnerability in exim4
Exim 4 before 4.94.2 allowed execution with unnecessary privileges. Since Exim operates as root in the log directory which is owned by a non-root user, a symlink or hard link attack could allow overwriting of critical root-owned files anywhere in the filesystem...
Astra Linux – Vulnerability in exim4
Exim 4 before 4.94.2 allowed integer overflow to lead to a buffer overflow in the receiveaddrecipient function, through an email message with fifty million recipients. NOTE: Remote exploitation might be difficult due to resource consumption...
Astra Linux – Vulnerability in exim4
In Exim versions before 4.99.2, when the SPA authentication driver is used with an adversarial SPA resource, there can be a vulnerability where an out-of-bounds write could cause the connection instance to crash, or erroneous data processing could lead to data being leaked from uninitialized heap...
Astra Linux – Vulnerability in exim4
Exim 4 before 4.94.2 has an improper initialization issue that can lead to recursive stack consumption or other consequences. This occurs because the use of certain getc functions is handled incorrectly when a client uses BDAT instead of DATA...
Astra Linux – Vulnerability in exim4
In versions of Exim up to 4.97.1, Misparse processes multi-line RFC 2231 header filenames. As a result, remote attackers can bypass the protection mechanism that blocks $mimefilename extensions, and potentially deliver executable attachments to the mailboxes of end users...
Astra Linux – Vulnerability in exim4
A vulnerability was discovered in Exim and has been classified as problematic. This issue affects certain aspects of the component Regex Handler’s processing. The vulnerability results in memory leaks after the component is freed from memory. The name of the patch is...
Astra Linux – Vulnerability in exim4
Exim 4 before 4.94.2 allowed a heap-based buffer overflow in the queuerun function, through two sender options: -R and -S. This could lead to privilege escalation from the exim user to the root user...