271 matches found
CVE-2026-103257
n8n versions before 1.123.80, from 2.0.0 before 2.39.6, and from 2.40.0 before 2.40.1 contain a path traversal vulnerability in the n8n node that fails to validate resource identifiers. Attackers can craft malicious resource IDs to redirect API calls to unintended resources, allowing unauthorized...
CVE-2026-103260
The n8n workflow automation tool (versions before 2.39.6 and 2.40.x before 2.40.1 ) is vulnerable to an approval bypass in the Send and Wait node's Approve Within Chat mode. The root cause is a lack of verification regarding the identity or approval permissions of the requester. Consequently, una...
CVE-2026-63137
Incorrect Authorization CWE-863 in Kibana can lead to privilege escalation via Exploiting Incorrectly Configured Access Control Security Levels CAPEC-180. A user holding workflow edit permissions could cause scheduled workflow executions to run with the privileges of a different, higher-privilege...
CVE-2026-63137 Incorrect Authorization in Kibana Leading to Privilege Escalation
Incorrect Authorization CWE-863 in Kibana can lead to privilege escalation via Exploiting Incorrectly Configured Access Control Security Levels CAPEC-180. A user holding workflow edit permissions could cause scheduled workflow executions to run with the privileges of a different, higher-privilege...
CVE-2026-70475
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, the PUT /api/v1/executions/:id endpoint in packages/server/src/routes/executions/index.ts lacks the checkAnyPermission middleware that protects other execution endpoints. Any authenticated use...
CVE-2026-70475
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, the PUT /api/v1/executions/:id endpoint in packages/server/src/routes/executions/index.ts lacks the checkAnyPermission middleware that protects other execution endpoints. Any authenticated use...
EUVD-2026-52871
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, the PUT /api/v1/executions/:id endpoint in packages/server/src/routes/executions/index.ts lacks the checkAnyPermission middleware that protects other execution endpoints. Any authenticated use...
CVE-2026-70475 Flowise: Missing Authorization on Execution Update Endpoint
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, the PUT /api/v1/executions/:id endpoint in packages/server/src/routes/executions/index.ts lacks the checkAnyPermission middleware that protects other execution endpoints. Any authenticated use...
PT-2026-67821
Name of the Vulnerable Software and Affected Versions Flowise versions prior to 3.1.3 Description An authorization flaw exists where the 'PUT /api/v1/executions/:id' endpoint lacks the checkAnyPermission middleware used to protect other execution endpoints. This allows any authenticated user,...
PT-2026-67919
Flowise Security Audit Report Date: 2026-03-17 Researcher: Dimpal Jadhav [email protected] GitHub: https://github.com/Dimpyj1604 Target: FlowiseAI/Flowise latest main branch Version: [email protected] FINDING 1: Missing Authorization on Execution Update Endpoint Severity: HIGH CVSS 7.5...
CVE-2026-70475: Missing Authorization
Flowise is a drag & drop user interface to build a customized large language model flow. Prior to 3.1.3, the PUT /api/v1/executions/:id endpoint in packages/server/src/routes/executions/index.ts lacks the checkAnyPermission middleware that protects other execution endpoints. Any authenticated use...
CVE-2026-53577
Kestra is an open-source, event-driven orchestration platform. Prior to 1.0.45 and 1.3.21, the previewFileFromExecution endpoint GET /api/v1/tenant/executions/executionId/file/preview contains an access control bypass that allows any authenticated user to read output files from any other executio...
PT-2026-53032
Impact The Public API endpoint for retrying executions authorized access using workflow:read rather than workflow:execute. An authenticated user with read-only access to a shared workflow could use the Public API to retry executions of that workflow, bypassing the intended permission boundary...
com.coravy.hudson.plugins.github:github (>=1.9, <=1.9.1), org.jenkins-ci.main:jenkins-test-harness (1.448) +10 more potentially affected by CVE-2026-53439 via org.jenkins-ci.main:jenkins-core (1.448)
org.jenkins-ci.main:jenkins-core MAVEN version 1.448 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.coravy.hudson.plugins.github:github =1.9, =1.3.0, =1.0.5, =2.6, =2.17 -...
org.jenkins-ci.main:jenkins-test-harness (1.414), org.jenkins-ci.main:jenkins-war (1.414) +5 more potentially affected by CVE-2026-53435 via org.jenkins-ci.main:jenkins-core (1.414)
org.jenkins-ci.main:jenkins-core MAVEN version 1.414 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - org.jenkins-ci.main:jenkins-test-harness 1.414 - org.jenkins-ci.main:jenkins-war 1.414 -...
org.jenkins-ci.main:jenkins-test-harness (1.580.2), org.jenkins-ci.main:jenkins-war (1.580.2) +3 more potentially affected by CVE-2026-53438 via org.jenkins-ci.main:jenkins-core (1.580.2)
org.jenkins-ci.main:jenkins-core MAVEN version 1.580.2 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - org.jenkins-ci.main:jenkins-test-harness 1.580.2 - org.jenkins-ci.main:jenkins-war 1.580.2 -...
org.jenkins-ci.main:jenkins-test-harness (1.580.2), org.jenkins-ci.main:jenkins-war (1.580.2) +3 more potentially affected by CVE-2026-53440 via org.jenkins-ci.main:jenkins-core (1.580.2)
org.jenkins-ci.main:jenkins-core MAVEN version 1.580.2 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - org.jenkins-ci.main:jenkins-test-harness 1.580.2 - org.jenkins-ci.main:jenkins-war 1.580.2 -...
org.jenkins-ci.main:jenkins-test-harness (1.580.2), org.jenkins-ci.main:jenkins-war (1.580.2) +3 more potentially affected by CVE-2026-53435 via org.jenkins-ci.main:jenkins-core (1.580.2)
org.jenkins-ci.main:jenkins-core MAVEN version 1.580.2 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - org.jenkins-ci.main:jenkins-test-harness 1.580.2 - org.jenkins-ci.main:jenkins-war 1.580.2 -...
org.jenkins-ci.main:jenkins-test-harness (1.580.2), org.jenkins-ci.main:jenkins-war (1.580.2) +3 more potentially affected by CVE-2026-53439 via org.jenkins-ci.main:jenkins-core (1.580.2)
org.jenkins-ci.main:jenkins-core MAVEN version 1.580.2 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - org.jenkins-ci.main:jenkins-test-harness 1.580.2 - org.jenkins-ci.main:jenkins-war 1.580.2 -...
org.jenkins-ci.main:jenkins-test-harness (1.580.2), org.jenkins-ci.main:jenkins-war (1.580.2) +3 more potentially affected by CVE-2026-53442 via org.jenkins-ci.main:jenkins-core (1.580.2)
org.jenkins-ci.main:jenkins-core MAVEN version 1.580.2 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - org.jenkins-ci.main:jenkins-test-harness 1.580.2 - org.jenkins-ci.main:jenkins-war 1.580.2 -...