774497 matches found
CVE-2026-76070
CVE-2026-76070: Unauthenticated Pre-Auth Stack Buffer Overflow via Base64-Decoded Password in Netis NC63 login.cgi Leading to RCE Researcher: Özcan Ersan @ozcanpng Disclosure status CVE: CVE-2026-76070 Vendor: Netis Systems Co., Ltd. Product: Netis NC63 Wireless AC1200 Router Tested firmware:...
CVE-2025-50472
CVE-2025-50472 ModelScope Ms-Swift ModelFileSystemCache Deserialization of Untrusted Data Remote Code Execution Vulnerability RCE PoC I uploaded a code repository containing a malicious .mdl file to ModelScope for testing purposes. It can be used directly during testing. The link is:...
cve-2021-26084-confluence
This is a quick and dirty poc, tuned for a specifc confluence instance as none of the existing off the shelf pocs worked. Obviously it's almost entirely based on the work of https://github.com/httpvoid/writeups/blob/main/Confluence-RCE.md and https://github.com/alt3kx/CVE-2021-26084PoC You'll nee...
CVE-2024-4577
Just for researching Poc For Default XAMPP curl -v -d "" http://127.0.0.1/php-cgi/php-cgi.exe/?%add+allowurlinclude%3Don+-d+autoprependfile%3Dphp%3A//input+-d+cgi.forceredirect%3D0...
0-click-RCE-Exploit-for-CVE-2024-51793
CVE-2024-51793 / 0-Click RCE Exploit Author: Joshua Provoste https://x.com/JoshuaProvoste/status/1858668072279626138 This repository contains a proof-of-concept exploit for CVE-2024-51793, an unauthenticated arbitrary file upload vulnerability in a vulnerable WordPress plugin, leading to remote...
CVE-2021-40514
CVE-2021-40514 OSCAR McMaster 19.401235 Stored Cross Site Scripting Vulnerability A stored Cross Site Scripting vulnerability exists in multiple pages in version 19.401235 of the OSCAR McMaster application that allows for arbitrary execution of JavaScript commands. Placeholder for CVE mitre...
CVE-2024-36401
CVE-2024-36401: GeoServer Unauthenticated Remote Code Execution Exploiter a Vulnerability detection and Exploitation tool for GeoServer Unauthenticated Remote Code Execution CVE-2024-36401. Installation git clone https://github.com/RevoltSecurities/CVE-2024-36401.git cd CVE-2024-34102 pip install...
CVE-2026-116014 open62541 1.5.0 before 1.5.7 Integer Overflow Heap Buffer Overflow via Custom DataType
open62541 1.5.0 before 1.5.7 contains an integer overflow in UADataTypefromStructureDescription that wraps the 16-bit memSize field for large custom structure definitions. A malicious OPC UA server can supply DataType definitions via UAClientgetRemoteDataTypes, causing decodeBinaryStructure to...
EUVD-2026-109272
open62541 1.5.0 before 1.5.7 contains an integer overflow in UADataTypefromStructureDescription that wraps the 16-bit memSize field for large custom structure definitions. A malicious OPC UA server can supply DataType definitions via UAClientgetRemoteDataTypes, causing decodeBinaryStructure to...
CVE-2026-116014
The open62541 library (versions 1.5.0 before 1.5.7 ) is vulnerable to an integer overflow within the UA_DataType_fromStructureDescription() function. The flaw occurs when the 16-bit memSize field is wrapped during the processing of large custom structure definitions. A malicious OPC UA server can...
Log4Shell-PoC
██╗ ██████╗ ██████╗ ██╗ ██╗███████╗██╗ ██╗███████╗██╗ ██╗ ██║ ██╔═══██╗██╔════╝ ██║ ██║██╔════╝██║ ██║██╔════╝██║ ██║ ██║ ██║ ██║██║ ███╗███████║███████╗███████║█████╗ ██║ ██║ ██║ ██║ ██║██║ ██║╚════██║╚════██║██╔══██║██╔══╝ ██║ ██║ ███████╗╚██████╔╝╚██████╔╝ ██║███████║██║...
cve-2021-44228--spring-hibernate
CVE-2021-44228 POC - Spring / Hibernate This POC uses Spring / Hibernate, however a similar approach of rmi - deserialization could be used to trigger any deserialization vulnerability TL;DR $ docker-compose up $ curl -X POST -H 'Content-Type: text/plain' localhost:8080 --data-binary...
CVE-2024-53900
CVE-2024-53900 - Mongoose populate.match $where RCE This repository provides a reproducible vulnerable environment and PoC for CVE-2024-53900 , a critical Remote Code Execution RCE vulnerability in Mongoose 8.8.3. 📌 Vulnerability Details CVE : CVE-2024-53900 Affected : Mongoose 8.8.3 Severity :...
CVE-2025-8088-WinRAR-PathTraversal-PoC
CVE-2025-8088 WinRAR Path Traversal Exploit PoC A Proof-of-Concept exploit demonstrating the WinRAR path traversal vulnerability CVE-2025-8088 affecting versions ≤ 7.12. Vulnerability Details CVE ID : CVE-2025-8088 CVSS Score : 8.4 High Affected Versions : WinRAR ≤ 7.12 Patch Version : Fixed in...
CVE-2021-35211
Serv-U CVE-2021-35211 Exploit Potential for DoS - check your rules of engagement The exploit doesn't work every time, but it works enough that it will run shellcode in roughly 1 in every 5 or 6 runs. However, sometimes a failed exploit will crash the Serv-U server. Please ensure that your rules o...
cve-2025-55182-scanner
CVE-2025-55182 / CVE-2025-66478 Vulnerability Scanner React Server Components Flight Protocol Remote Code Execution Detection Tool Executive Summary This scanner identifies systems potentially vulnerable to CVE-2025-55182 React and CVE-2025-66478 Next.js, critical unauthenticated remote code...
CVE-2024-4577
CVE-2024-4577 Environment Setup Files and PHP Files --poc-- Invoke-WebRequest -Method POST -Headers @"Content-Type" = "application/x-www-form-urlencoded" -Body "" -Uri "http://localhost/test.php?%ADd+allowurlinclude%3D1+%ADd+autoprepend file%3Dphp://input"...
CVE-2026-92229
CVE-2026-92229 — Forminator Unauthenticated Arbitrary Shortcode Execution Python 3 PoC scanner/exploit for CVE-2026-92229 in Forminator WPMU DEV. | ---|--- Plugin| forminator Affected| ≤ 1.57.2 Fixed in| 1.57.3+ CVSS| 9.1 Critical Auth| Unauthenticated Vector| POST parameter currenturl quiz AJAX...
CVE-2025-55182-poc
CVE-2025-55182 Proof of Concept Critical Pre-Authentication Remote Code Execution in React Server Components A complete proof-of-concept demonstrating CVE-2025-55182, a critical vulnerability in [email protected] that allows unauthenticated attackers to execute arbitrary code via prototype...
CVE-2024-9707
CVE-2024-9707 Hunk Companion = 1.8.4 - Missing Authorization to Unauthenticated Arbitrary Plugin Installation/Activation Description The Hunk Companion plugin for WordPress is vulnerable to unauthorized plugin installation/activation due to a missing capability check on the...