3028873 matches found
metame
metame metame is a simple metamorphic code engine for arbitrary executables. From Wikipedia: Metamorphic code is code that when run outputs a logically equivalent version of its own code under some interpretation. This is used by computer viruses to avoid the pattern recognition of anti-virus...
CloudFlair
CloudFlair Important note: As of late 2024, Censys does not provide API access to free accounts anymore. This means CloudFlair does not work with free Censys accounts anymore. CloudFlair is a tool to find origin servers of websites protected by CloudFlare or CloudFront which are publicly exposed...
booster
Booster - fast, secure, modern initramfs for Linux Booster makes early boot feel lighter, faster, and more dependable. It builds compact initramfs images that move your Linux system from firmware to the real root filesystem with minimal fuss and strong encrypted-boot support. Instead of packing a...
ghauri
Like Ghauri, consider supporting the developer Ghauri An advanced cross-platform tool that automates the process of detecting and exploiting SQL injection security flaws. Requirements Python 3 Python pip3 Installation cd to ghauri directory. install requirements: python3 -m pip install --upgrade ...
365Inspect
Purpose Further the state of Microsoft 365 security by authoring a PowerShell script that automates the security assessment of Microsoft 365 environments. Soteria Inspect Soteria Inspect is born from the 365Inspect project and is Soteria's SaaS solution to aid in assessing the security of a...
PurplePanda
PurplePanda This tool fetches resources from different cloud/saas applications focusing on permissions in order to identify privilege escalation paths and dangerous permissions in the cloud/saas configurations. Note that PurplePanda searches both privileges escalation paths within a platform and...
regipy
regipy β οΈ Breaking Changes in v6.0.0 Version 6.0.0 includes significant modernization changes: Python 3.9+ required - Dropped support for Python 3.6, 3.7, and 3.8 attrs library removed - Data classes now use Python's built-in dataclasses module If your code imports internal classes Cell,...
DSCourier_BOF
DSCourier BOF This is a BOF implementation of Dylan Davis and Matthew Schramm's DSCourier project. It uses WinGet's COM interface to execute arbitrary powershell code in a Microsoft signed and trusted process. Their full research blog can be found here. Unlike most projects I release, this is NOT...
dexfinder
dexfinder English | δΈζ | Website Website : junelegency.github.io/dexfinder Cross-platform APK/DEX method & field reference finder with call chain tracing, ProGuard/R8 deobfuscation, and Android hidden API detection. Inspired by Android's veridex tool, reimplemented in Go with enhanced capabilitie...
http-desync-guardian
Overview HTTP/1.1 went through a long evolution since 1991 to 2014: HTTP/0.9 β 1991 HTTP/1.0 β 1996 HTTP/1.1 RFC 2068 β 1997 RFC 2616 - 1999 RFC 7230 - 2014 This means there is a variety of servers and clients, which might have different views on request boundaries, creating opportunities for...
RedDrop
RedDrop Exfil Server Check out the accompanying MaverisLabs Blog Post Here! RedDrop Exfil Server is a Python Flask Web Server for Penetration Testers, Red Teamers, and Security Professionals which features: File Upload Automatic Payload Processing Automatic Archive Extraction JSON Logging...
krane
Krane Kubernetes RBAC Analysis made Easy Krane is a simple Kubernetes RBAC static analysis tool. It identifies potential security risks in K8s RBAC design and makes suggestions on how to mitigate them. Krane dashboard presents current RBAC security posture and lets you navigate through its...
kernagent
| | | | | |/ / \ '| ' \ / |/ |/ \ ' | | | / | | | | | | | | | / | | | | ||\|| || ||,|, ||| ||| |/ π kernagent Turn binaries into conversations β deterministic, auditable, offline-capable. kernagent converts a binary into a portable static snapshot and lets an LLM or your scripts answer...
PHP-Fuzzer
PHP Fuzzer This library implements a fuzzer for PHP, which can be used to find bugs in libraries particularly parsing libraries by feeding them "random" inputs. Feedback from edge coverage instrumentation is used to guide the choice of "random" inputs, such that new code paths are visited...
Router-Exploit-Shovel
Router Exploit Shovel Automated Application Generation for Stack Overflow Types on Wireless Routers Router exploits shovel is an automated application generation tool for stack overflow types on wireless routers. The tool implements the key functions of exploits, it can adapt to the length of the...
Loki
I wrote a new Open Source YARA scanner called LOKI RS Rust. LOKI Python is now officially deprecated. Important Note This project is now in inactive maintenance mode. This means that while I merge pull requests for bug fixes and straightforward issues, I currently lack the time to add new feature...
fetchfox
FetchFox FetchFox is an AI powered scraping, automation, and data extraction library. It can scrape data from any webpage using just plain English. It is made by the developers of the FetchFox AI scraper. Getting started Install the package and playwright: npm i fetchfox npx playwright install-de...
tetsuo-pulse
Socket Library Maturity Notice : This library is functional and well-tested but newly released. It is appropriate for development, internal tooling, and controlled environments. Production deployment with untrusted network input should wait until the codebase has accumulated several months of...
sonarcloud-scan
Bitbucket Pipelines Pipe: SonarQube Cloud scan Scan your code with SonarQube Cloud to detects bugs, vulnerabilities and code smells in more than 25 programming languages. Your SonarCloud account must first be associated to your Bitbucket team or user account. SonarQube Cloud is totally free for...
m3
m3 A simple and scalable Android bot emulation framework. A detailed explanation can be found here. This project was first published at Black Hat Europe 2021's Arsenal. Aside from the documentation in the code both in-line and as JavaDoc, one can learn more about extending the framework here. The...