18 matches found
Astra Linux – Vulnerability in Linux
In the Linux kernel, the following vulnerability has been resolved: net: qrtr: fix OOB Read in qrtrendpointpost Syzbot reported a slab-out-of-bounds Read in qrtrendpointpost. The problem was with the wrong sizetype: if len != ALIGNsize, 4 + hdrlen goto err; If the size from qrtrhdr is 4294967293...
CVE-2026-11430 Grav CMS Scheduler Webhook Authentication Bypass via Null Short-Circuit
Grav CMS's scheduler-webhook plugin contains an authentication bypass in the webhook token check. When the webhook feature is enabled but no webhookToken is configured, a compound conditional short-circuits and skips token validation, so an unauthenticated remote attacker who can reach POST...
CVE-2026-6119 AstrBotDevs AstrBot API Endpoint post_data.get server-side request forgery
A vulnerability was identified in AstrBotDevs AstrBot up to 4.22.1. The affected element is the function postdata.get of the component API Endpoint. Such manipulation leads to server-side request forgery. The attack may be performed from remote. The exploit is publicly available and might be used...
Unity Linux 20.1050a / 20.1060a / 20.1070a Security Update: kernel (UTSA-2026-007059)
"The Unity Linux 20 host has a package installed that is affected by a vulnerability as referenced in the UTSA-2026-007059 advisory. In the Linux kernel, the following vulnerability has been resolved: net: qrtr: fix OOB Read in qrtrendpointpost Syzbot reported slab-out-of-bounds Read in...
net qrtr Heap Buffer Overflow DoS
The vulnerability of the qrtrendpointpost function in the net/qrtr/afqrtr.c module, which is part of the Qualcomm IPC kernel for Linux operating systems, is related to the use of an uninitialized variable. Exploiting this vulnerability could allow a attacker to cause a service failure...
Unity Linux 20.1070a Security Update: kernel (UTSA-2025-989577)
"The Unity Linux 20 host has a package installed that is affected by a vulnerability as referenced in the UTSA-2025-989577 advisory. In the Linux kernel, the following vulnerability has been resolved: net: qrtr: fix OOB Read in qrtrendpointpost Syzbot reported slab-out-of-bounds Read in...
Unity Linux 20.1070e Security Update: kernel (UTSA-2025-987006)
"The Unity Linux 20 host has a package installed that is affected by a vulnerability as referenced in the UTSA-2025-987006 advisory. In the Linux kernel, the following vulnerability has been resolved: net: qrtr: fix OOB Read in qrtrendpointpost Syzbot reported slab-out-of-bounds Read in...
CVE-2025-8976 givanz Vvveb Endpoint post cross site scripting
A vulnerability has been found in givanz Vvveb up to 1.0.5. This vulnerability affects unknown code of the file /vadmin123/index.php?module=content/post&type=post of the component Endpoint. The manipulation leads to cross site scripting. The attack can be initiated remotely. The exploit has been...
qrtr Net Kernel DoS
The vulnerability of the qtrrendpointpost function in the net/qrtr/qrtr.c module is related to buffer out-of-bounds reading. Exploiting this vulnerability could allow an attacker to cause a service failure...
DEBIAN-CVE-2021-47240
In the Linux kernel, the following vulnerability has been resolved: net: qrtr: fix OOB Read in qrtrendpointpost Syzbot reported slab-out-of-bounds Read in qrtrendpointpost. The problem was in wrong size type: if len != ALIGNsize, 4 + hdrlen goto err; If size from qrtrhdr is 4294967293 0xfffffffd,...
Linux Kernel Buffer Error Vulnerability
Linux kernel is the kernel used by the Linux Foundation's open-source operating system Linux. Linux kernel is vulnerable due to a security flaw in qrtrendpointpost that forces the Linux kernel to read invalid memory addresses. An attacker could use this vulnerability to trigger a denial of servic...
PT-2021-25537
Name of the Vulnerable Software and Affected Versions: Linux Kernel versions v4.15 through v5.12.12 Description: The issue concerns an out-of-bounds read in the qrtr endpoint post function. This problem was introduced in version v4.15 and is fixed in Linux Kernel version v5.12.13. Recommendations...
PT-2021-29531
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v5.12.13 Description The issue concerns an out-of-bounds read in the qrtr endpoint post function. This problem was introduced in version v4.15 and is fixed in Linux Kernel version v5.12.13. The actual impact and...
PT-2021-29386
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v5.4.128 Description The issue concerns an out-of-bounds read in the qrtr endpoint post function. This problem was introduced in version v4.15 and is fixed in Linux Kernel version v5.4.128. The actual impact and...
PT-2021-25456
Name of the Vulnerable Software and Affected Versions: Linux Kernel versions 4.15 through 5.10.45 Description: The issue concerns an out-of-bounds read in the qrtr endpoint post function. This problem was introduced in version v4.15 and is fixed in Linux Kernel version v5.10.46. Recommendations:...
PT-2021-29450
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v5.10.46 Description The issue concerns an out-of-bounds read in the qrtr endpoint post function. It was introduced in version v4.15 and fixed in version v5.10.46. The actual impact and attack plausibility have n...
PT-2021-25392
Name of the Vulnerable Software and Affected Versions: Linux Kernel versions prior to v5.4.128 Description: The issue concerns an out-of-bounds read in the qrtr endpoint post function. It was introduced in version v4.15 and fixed in version v5.4.128. The actual impact and attack plausibility have...
PT-2024-11248
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description The issue is related to a slab-out-of-bounds read in the qrtr endpoint post function. The problem occurs when the size from qrtr hdr is set to 4294967293 0xfffffffd, causing the ALIGNsiz...