30116 matches found
CVE-2025-45764
jsrsasign v11.1.0 was discovered to contain weak encryption. NOTE: this issue has been disputed by a third party who believes that CVE IDs can be assigned for key lengths in specific applications that use a library, and should not be assigned to the default key lengths in a library. This dispute ...
CVE-2025-45766
poco v1.14.1-release was discovered to contain weak encryption. NOTE: this issue has been disputed on the basis that key lengths are expected to be set by an application, not by this library. This dispute is subject to review under CNA rules 4.1.4, 4.1.14, and other rules; the dispute tagging is...
CVE-2025-45764
CVE-2025-45764 relates to jsrsasign v11.1.0, where the vulnerability described is a weakness due to weak encryption/cryptographic primitives. Multiple sources (NVD, CVE lists, RH advisory, PT-Security entry) confirm the issue but do not provide a confirmed fix version. The Red Hat entry notes mit...
PT-2025-32204 · Jsrsasign · Jsrsasign
Name of the Vulnerable Software and Affected Versions: jsrsasign version 11.1.0 Description: jsrsasign version 11.1.0 contains weak encryption. Recommendations: At the moment, there is no information about a newer version that contains a fix for this vulnerability...
SenseCrypt: Sensitivity-Guided Selective Homomorphic Encryption for Joint Federated Learning in Cross-Device Scenarios
Homomorphic Encryption HE prevails in securing Federated Learning FL, but suffers from high overhead and adaptation cost. Selective HE methods, which partially encrypt model parameters by a global mask, are expected to protect privacy with reduced overhead and easy adaptation. However, in...
SelectiveShield: Lightweight Hybrid Defense against Gradient Leakage in Federated Learning
Federated Learning FL enables collaborative model training on decentralized data but remains vulnerable to gradient leakage attacks that can reconstruct sensitive user information. Existing defense mechanisms, such as differential privacy DP and homomorphic encryption HE, often introduce a...
POCO security vulnerabilities
POCO is a cross-platform C++ library open-sourced by POCO. It is used to build web and internet based applications that run on desktop, server, mobile, IoT and embedded systems. A security vulnerability exists in POCO v1.14.1-release that stems from a weak encryption issue...
CVE-2025-45766: Use of a Broken or Risky Cryptographic Algorithm
poco v1.14.1-release was discovered to contain weak encryption. NOTE: this issue has been disputed on the basis that key lengths are expected to be set by an application, not by this library. This dispute is subject to review under CNA rules 4.1.4, 4.1.14, and other rules; the dispute tagging is...
CVE-2025-45766
poco v1.14.1-release was discovered to contain weak encryption. NOTE: this issue has been disputed on the basis that key lengths are expected to be set by an application, not by this library. This dispute is subject to review under CNA rules 4.1.4, 4.1.14, and other rules; the dispute tagging is...
CVE-2025-45764: Inadequate Encryption Strength
jsrsasign v11.1.0 was discovered to contain weak encryption. NOTE: this issue has been disputed by a third party who believes that CVE IDs can be assigned for key lengths in specific applications that use a library, and should not be assigned to the default key lengths in a library. This dispute ...
PT-2025-32202 · Poco +1 · Poco +1
Name of the Vulnerable Software and Affected Versions: poco version 1.14.1-release Description: poco version 1.14.1-release was discovered to contain weak encryption. There is a dispute regarding this issue, with some arguing that key lengths are expected to be set by the application using the...
CVE-2025-45766
The poco v1.14.1-release library was discovered to contain weak encryption . However, this issue is currently under dispute because some argue that key lengths are expected to be set by the application rather than the library itself. This dispute is subject to review under CNA rules. There is cur...
CVE-2025-45766
poco v1.14.1-release was discovered to contain weak encryption. NOTE: this issue has been disputed on the basis that key lengths are expected to be set by an application, not by this library. This dispute is subject to review under CNA rules 4.1.4, 4.1.14, and other rules; the dispute tagging is...
CVE-2025-45764
jsrsasign v11.1.0 was discovered to contain weak encryption. NOTE: this issue has been disputed by a third party who believes that CVE IDs can be assigned for key lengths in specific applications that use a library, and should not be assigned to the default key lengths in a library. This dispute ...
Evaluating Selective Encryption against Gradient Inversion Attacks
Gradient inversion attacks pose significant privacy threats to distributed training frameworks such as federated learning, enabling malicious parties to reconstruct sensitive local training data from gradient communications between clients and an aggregation server during the aggregation process...
JSRSASIGN encryption issue vulnerability
jsrsasign is a signature verification library by the individual developer Kenji Urushima. A cryptographic issue vulnerability exists in jsrsasign version v11.1.0, which stems from a weak encryption issue...
Linux Distros Unpatched Vulnerability : CVE-2022-50171
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - crypto: hisilicon/sec - don't sleep when in softirq When kunpeng920 encryption driver is used to deencrypt and decrypt packets during the softirq, it is not...
CVE-2025-45764
jsrsasign v11.1.0 was discovered to contain weak encryption. NOTE: this issue has been disputed by a third party who believes that CVE IDs can be assigned for key lengths in specific applications that use a library, and should not be assigned to the default key lengths in a library. This dispute ...
kernel: net/tipc: fix slab-use-after-free Read in tipc_aead_encrypt_done
A vulnerability was found in the Linux kernel's management of network namespaces. By manipulating the lifecycle of network namespaces, an attacker could exploit this vulnerability to cause a system crash or leak sensitive system memory. Exploitation of this vulnerability requires that a user has...
CVE-2025-54870
VTun-ng is a Virtual Tunnel over TCP/IP network. In versions 3.0.17 and below, failure to initialize encryption modules might cause reversion to plaintext due to insufficient error handling. The bug was first introduced in VTun-ng version 3.0.12. This is fixed in version 3.0.18. To workaround thi...