Lucene search
+L

76 matches found

Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2024/01/21 12:00 a.m.•5 views

CVE-2024-23732: Inefficient Regular Expression Complexity

The JSON loader in Embedchain before 0.1.57 allows a ReDoS regular expression denial of service via a long string to json.py...

7.5CVSS7.3AI score0.00775EPSS
SaveExploits0References3
CNNVD
CNNVD
•added 2024/01/21 12:00 a.m.•25 views

Embedchain Security Breach

Embedchain is an open source RAG framework from Embedchain Open Source. A security vulnerability exists in Embedchain versions prior to 0.1.57. An attacker can exploit this vulnerability to execute arbitrary code related to the parameters of the openapi.py yaml.load function...

9.8CVSS7.6AI score0.01059EPSS
SaveExploits0References3
Positive Technologies
Positive Technologies
•added 2024/01/21 12:00 a.m.•6 views

PT-2024-20041

Name of the Vulnerable Software and Affected Versions Embedchain versions prior to 0.1.57 Description The issue allows attackers to execute arbitrary code, related to the yaml.load function argument in the openapi.py file. Recommendations For versions prior to 0.1.57, update to version 0.1.57 or...

9.8CVSS6.3AI score0.01059EPSS
SaveExploits0References13
Cvelist
Cvelist
•added 2024/01/21 12:00 a.m.•72 views

CVE-2024-23731

The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument...

9.9AI score0.01059EPSS
SaveExploits0References2
CNNVD
CNNVD
•added 2024/01/21 12:00 a.m.•18 views

Embedchain Security Breach

Embedchain is an open source RAG framework from Embedchain Open Source. A security vulnerability exists in Embedchain versions prior to 0.1.57. An attacker exploited the vulnerability to conduct a regular expression denial of service attack via a long string in json.py...

7.5CVSS6.6AI score0.00775EPSS
SaveExploits0References3
Vulnrichment
Vulnrichment
•added 2024/01/21 12:00 a.m.•27 views

CVE-2024-23731

The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument...

7.4AI score0.01059EPSS
SaveExploits0References2
CVE
CVE
•added 2024/01/21 12:00 a.m.•74 views

CVE-2024-23732

CVE-2024-23732 affects the Embedchain JSON loader and is caused by a ReDoS in the json.py path when processing long input strings. The vulnerability is reported in Embedchain versions prior to 0.1.57. According to connected sources, exploitation could allow denial-of-service via crafted input len...

7.5CVSS7.2AI score0.00775EPSS
SaveExploits0References2Affected Software1
osv_cve
osv_cve
•added 2024/01/21 12:00 a.m.•29 views

CVE-2024-23732

The JSON loader in Embedchain before 0.1.57 allows a ReDoS regular expression denial of service via a long string to json.py...

7.5CVSS6.7AI score
SaveExploits0References4
osv_cve
osv_cve
•added 2024/01/21 12:00 a.m.•29 views

CVE-2024-23731

The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument...

9.8CVSS7.5AI score
SaveExploits0References4
CVE
CVE
•added 2024/01/21 12:00 a.m.•81 views

CVE-2024-23731

CVE-2024-23731 affects Embedchain’s OpenAPI loader prior to version 0.1.57 . The vulnerability arises from using yaml.load in the file openapi.py, enabling attackers to execute arbitrary code. The issue is confirmed by multiple sources (e.g., Red Hat and Veracode) and is classified as a CRITICAL ...

9.8CVSS9.6AI score0.01059EPSS
SaveExploits0References2Affected Software1
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2024/01/21 12:00 a.m.•6 views

CVE-2024-23731: Improper Neutralization of Argument Delimiters in a Command

The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument...

9.8CVSS8.6AI score0.01059EPSS
SaveExploits0References3
vulnersOsv
vulnersOsv
•added 2024/01/21 12:00 a.m.•2 views

traia-tools (>=0.1.25, <=0.1.26) potentially affected by CVE-2024-23732 via embedchain (0.0.18)

embedchain PYPI version 0.0.18 is affected by a known vulnerability. The following packages have a transitive dependency on embedchain and may be impacted: - traia-tools =0.1.25, =0.1.26 Source cves: CVE-2024-23732 Source advisory: MEND:CVE-2024-23732...

7.5CVSS0.00775EPSS
SaveExploits0
vulnersOsv
vulnersOsv
•added 2024/01/21 12:00 a.m.•3 views

traia-tools (>=0.1.25, <=0.1.26) potentially affected by CVE-2024-23731 via embedchain (0.0.18)

embedchain PYPI version 0.0.18 is affected by a known vulnerability. The following packages have a transitive dependency on embedchain and may be impacted: - traia-tools =0.1.25, =0.1.26 Source cves: CVE-2024-23731 Source advisory: MEND:CVE-2024-23731...

9.8CVSS0.01059EPSS
SaveExploits0
Cvelist
Cvelist
•added 2024/01/21 12:00 a.m.•54 views

CVE-2024-23732

The JSON loader in Embedchain before 0.1.57 allows a ReDoS regular expression denial of service via a long string to json.py...

7.5AI score0.00775EPSS
SaveExploits0References2
Mend
Mend
•added 2024/01/21 12:00 a.m.•9 views

CVE-2024-23732

The JSON loader in Embedchain before 0.1.57 allows a ReDoS regular expression denial of service via a long string to json.py...

8.7CVSS0.00775EPSS
SaveExploits0References5
Mend
Mend
•added 2024/01/21 12:00 a.m.•15 views

CVE-2024-23731

The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument...

9.8CVSS0.01059EPSS
SaveExploits0References7
Rows per page
Query Builder