Lucene search
+L

17 matches found

Kitploit
Kitploit
•added 2026/10/27 5:11 p.m.•21 views

egg-scripts-CVE-2018-3786

egg-scripts deploy tool for egg project. Note: Windows is partially supported, see22 Install $ npm i egg-scripts --save Usage Add eggctl to package.json scripts: "scripts": "start": "eggctl start --daemon", "stop": "eggctl stop" Then run as: npm start npm stop Note: egg-scripts is not recommended...

10CVSS8.9AI score0.12283EPSS
SaveExploits1References1
EUVD
EUVD
•added 2025/10/03 8:07 p.m.•29 views

EUVD-2018-0451

Malicious code in bioql PyPI...

10CVSS8.6AI score0.12283EPSS
SaveExploits1References7
vulnersOsv
vulnersOsv
•added 2018/09/17 8:43 p.m.•9 views

@taotieh/back_giscom (1.0.7), @taotieh/back_giscom__sample (>=0.1.2, <=0.1.7) +4 more potentially affected by CVE-2018-3786 via egg-scripts (2.6.0)

egg-scripts NPM version 2.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on egg-scripts and may be impacted: - @taotieh/backgiscom 1.0.7 - @taotieh/backgiscomsample =0.1.2, =0.2.0, =0.1.2, =0.1.9 - @taotieh/backgiscomtiletransform 0.0.0 Source cves:...

10CVSS8.7AI score0.12283EPSS
SaveExploits1
Github Security Blog
Github Security Blog
•added 2018/09/17 8:43 p.m.•55 views

Command Injection in egg-scripts

Versions of egg-scripts before 2.8.1 are vulnerable to command injection. This is only exploitable if a malicious argument is provided on the command line. Example: eggctl start --daemon --stderr='/tmp/eggctlstderr.log; touch /tmp/malicious' Recommendation Update to version 2.8.1 or later...

10CVSS4.4AI score0.12283EPSS
SaveExploits1References7Affected Software1
osv_ghsa
osv_ghsa
•added 2018/09/17 8:43 p.m.•26 views

GHSA-C9J3-WQPH-5XX9 Command Injection in egg-scripts

Versions of egg-scripts before 2.8.1 are vulnerable to command injection. This is only exploitable if a malicious argument is provided on the command line. Example: eggctl start --daemon --stderr='/tmp/eggctlstderr.log; touch /tmp/malicious' Recommendation Update to version 2.8.1 or later...

9.8CVSS9.7AI score0.12283EPSS
SaveExploits1References7
vulnersOsv
vulnersOsv
•added 2018/09/17 8:43 p.m.•2 views

@taotieh/back_giscom (1.0.7), @taotieh/back_giscom__sample (>=0.1.2, <=0.1.7) +4 more potentially affected by CVE-2018-3786 via egg-scripts (2.6.0)

egg-scripts NPM version 2.6.0 is affected by a known vulnerability. The following packages have a transitive dependency on egg-scripts and may be impacted: - @taotieh/backgiscom 1.0.7 - @taotieh/backgiscomsample =0.1.2, =0.2.0, =0.1.2, =0.1.9 - @taotieh/backgiscomtiletransform 0.0.0 Source cves:...

10CVSS0.12283EPSS
SaveExploits1
CNVD
CNVD
•added 2018/08/27 12:00 a.m.•39 views

egg-scripts command injection vulnerability

egg-scripts is a deployment tool for deploying, running and managing egg projects. A command injection vulnerability exists in egg-scripts versions prior to 2.8.1. The vulnerability can be exploited to execute arbitrary shell commands with the help of maliciously crafted command line arguments...

10CVSS9.8AI score0.12283EPSS
SaveExploits1References1
Prion
Prion
•added 2018/08/24 8:29 p.m.•27 views

Command injection

A command injection vulnerability in egg-scripts v2.8.1 allows arbitrary shell command execution through a maliciously crafted command line argument...

10CVSS9.7AI score0.12283EPSS
SaveExploits1References3Affected Software1
NVD
NVD
•added 2018/08/24 8:29 p.m.•37 views

CVE-2018-3786

A command injection vulnerability in egg-scripts v2.8.1 allows arbitrary shell command execution through a maliciously crafted command line argument...

10CVSS9.7AI score0.12283EPSS
SaveExploits1References3
osv_cve
osv_cve
•added 2018/08/24 8:29 p.m.•32 views

CVE-2018-3786

A command injection vulnerability in egg-scripts v2.8.1 allows arbitrary shell command execution through a maliciously crafted command line argument...

9.8CVSS7.4AI score
SaveExploits0References3
vulnersOsv
vulnersOsv
•added 2018/08/24 8:00 p.m.•3 views

@taotieh/back_giscom (1.0.7), @taotieh/back_giscom__sample (>=0.1.2, <=0.1.7) +6 more potentially affected by CVE-2018-3786 via egg-scripts (>=1.2.0, <=2.6.0)

egg-scripts NPM version =1.2.0, =0.1.2, =0.2.0, =0.1.2, =1.0.0, =0.0.1, =1.0.2 Source cves: CVE-2018-3786 Source advisory: MEND:CVE-2018-3786...

10CVSS0.12283EPSS
SaveExploits1
CVE
CVE
•added 2018/08/24 8:00 p.m.•89 views

CVE-2018-3786

CVE-2018-3786 affects egg-scripts prior to 2.8.1. A crafted command line argument enables command injection, allowing arbitrary shell command execution. Impact, per sources, is remote code execution in affected setups; exploitability is via untrusted input passed to egg-scripts. Remediation: upgr...

10CVSS9.6AI score0.12283EPSS
SaveExploits1References3Affected Software1
Mend
Mend
•added 2018/08/24 8:00 p.m.•10 views

CVE-2018-3786

A command injection vulnerability in egg-scripts v2.8.1 allows arbitrary shell command execution through a maliciously crafted command line argument...

10CVSS0.12283EPSS
SaveExploits1References7
nodejs
nodejs
•added 2018/08/24 12:07 p.m.•29 views

Command Injection

Overview Versions of egg-scripts before 2.8.1 are vulnerable to command injection. This is only exploitable if a malicious argument is provided on the command line. Example: eggctl start --daemon --stderr='/tmp/eggctlstderr.log; touch /tmp/malicious' Recommendation Update to version 2.8.1 or late...

7.5AI score
SaveExploits0Affected Software1
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2018/08/24 12:00 a.m.•8 views

CVE-2018-3786: Improper Neutralization of Special Elements used in a Command

A command injection vulnerability in egg-scripts...

10CVSS8.2AI score0.12283EPSS
SaveExploits1References3
Positive Technologies
Positive Technologies
•added 2018/08/24 12:00 a.m.•23 views

PT-2018-16203 · Egg · Egg-Scripts

Name of the Vulnerable Software and Affected Versions: egg-scripts versions prior to 2.8.1 Description: A command injection issue allows arbitrary shell command execution through a maliciously crafted command line argument. This is only exploitable if a malicious argument is provided on the comma...

10CVSS9.8AI score0.12283EPSS
SaveExploits1References9
Hacker One
Hacker One
•added 2018/07/31 1:54 p.m.•54 views

Node.js third-party modules: [egg-scripts] Command injection

I would like to report a command injection vulnerability in egg-scripts. It allows arbitrary shell command execution through a maliciously crafted command line argument. Module module name: egg-scripts version: 2.6.0 npm page: https://www.npmjs.com/package/egg-scripts Module Description "deploy...

10CVSS1.2AI score0.12283EPSS
SaveExploits1
Rows per page
Query Builder