20567 matches found
Xerte Online Toolkits Arbitrary File Upload - Upload Image
This module exploits the user template file import function's unrestricted file upload in versions 3.14 and earlier to upload and execute a shell. This targets editor/uploadImage.php. This has only been tested in implementations where the authentication type is "Db". OPSEC - if the user is logged...
PT-2025-31841 · Unknown · Givanz Vvveb
Name of the Vulnerable Software and Affected Versions: givanz Vvveb versions up to 1.0.5 Description: A problematic issue exists in givanz Vvveb that allows information disclosure. The issue is located in an unknown part of the file /vadmin123/index.php?module=editor/editor within the Drag-and-Dr...
Vvveb injection vulnerability
Vvveb is a powerful and easy-to-use CMS from Givan Individual Developers for building websites, blogs or e-commerce stores. An injection vulnerability exists in Vvveb version 1.0.5, which stems from code injection due to a misbehavior of the function Save in the file...
CVE-2025-8520: Server-Side Request Forgery (SSRF)
A vulnerability classified as critical was found in givanz Vvveb up to 1.0.5. This vulnerability affects unknown code of the file /vadmin123/?module=editor/editor of the component Drag-and-Drop Editor. The manipulation of the argument url leads to server-side request forgery. The attack can be...
Cursor operating system command injection vulnerability
Cursor is an AI code editor from Cursor open source. An operating system command injection vulnerability exists in Cursor versions 1.17 through 1.2, which stems from an information disclosure in the MCP deep link handler that could lead to arbitrary system command execution...
Cursor operating system command injection vulnerability
Cursor is an AI code editor from Cursor open source. An operating system command injection vulnerability exists in Cursor 1.2.4 and earlier versions, which stems from the fact that the MCP configuration file can be modified, potentially leading to remote persistent code execution...
CVE-2025-54132
Cursor is a code editor built for programming with AI. In versions below 1.3, Mermaid which is used to render diagrams allows embedding images which then get rendered by Cursor in the chat box. An attacker can use this to exfiltrate sensitive information to a third-party attacker controlled serve...
CVE-2025-54131
Cursor is a code editor built for programming with AI. In versions below 1.3, an attacker can bypass the allow list in auto-run mode with a backtick or $cmd. If a user has swapped Cursor from its default settings requiring approval for every terminal call to an allowlist, an attacker can execute...
CVE-2025-54136 Cursor's Modification of MCP Server Definitions Bypasses Manual Re-approvals
Cursor is a code editor built for programming with AI. In versions 1.2.4 and below, attackers can achieve remote and persistent code execution by modifying an already trusted MCP configuration file inside a shared GitHub repository or editing the file locally on the target's machine. Once a...
CVE-2025-54133 Cursor's MCP Install Deeplink Does Not Show Arguments in its User-Dialog
Cursor is a code editor built for programming with AI. In versions 1.17 through 1.2, there is a UI information disclosure vulnerability in Cursor's MCP Model Context Protocol deeplink handler, allowing attackers to execute 2-click arbitrary system commands through social engineering attacks. When...
CVE-2025-54132
CVE-2025-54132 affects Cursor’s Mermaid-based diagram tool prior to version 1.3. An attacker can trigger prompt injections to cause Mermaid-rendered images to fetch data to a remote attacker-controlled server, enabling exfiltration of sensitive information. The issue is fixed in version 1.3; upgr...
CVE-2025-54131 Cursor bypasses its allow list to execute arbitrary commands
Cursor is a code editor built for programming with AI. In versions below 1.3, an attacker can bypass the allow list in auto-run mode with a backtick or $cmd. If a user has swapped Cursor from its default settings requiring approval for every terminal call to an allowlist, an attacker can execute...
CVE-2025-54131
Cursor before v1.3 is vulnerable: an attacker can bypass the auto-run allow list using a backtick (`) or $(cmd) to execute arbitrary commands outside the allowlist, especially if the user has switched to an allowlist setting. The issue can be triggered via indirect prompt injection and is fixed i...
Cursor AI Code Editor Fixed Flaw Allowing Attackers to Run Commands via Prompt Injection
Cybersecurity researchers have disclosed a now-patched, high-severity security flaw in Cursor, a popular artificial intelligence AI code editor, that could result in remote code execution RCE. The vulnerability, tracked as CVE-2025-54135 CVSS score: 8.6, has been addressed in version 1.3 released...
CVE-2025-54135
creationtimestamp| type| source ---|---|--- 2025-08-01 13:31:00+00:00| seen| https://thehackernews.com/2025/08/cursor-ai-code-editor-fixed-flaw.html 2025-08-01 15:45:09+00:00| published-proof-of-concept| https://t.me/thehackernews/7272 2025-08-01 18:23:18+00:00| seen|...
PT-2025-31699 · Cursor · Cursor
Name of the Vulnerable Software and Affected Versions: Cursor versions prior to 1.3 Description: Cursor, a code editor built for programming with AI, allows an attacker to bypass the allow list in auto-run mode using a backtick or $cmd. This bypass enables arbitrary command execution outside of t...
PT-2025-31700
Name of the Vulnerable Software and Affected Versions Cursor versions prior to 1.3 Description Cursor is a code editor built for programming with AI. In versions below 1.3, Mermaid, a tool used for rendering diagrams, allows embedding images. An attacker can leverage this functionality to...
Cursor command injection vulnerability
Cursor is an AI code editor from Cursor open source. A command injection vulnerability exists in Cursor versions prior to 1.3 that stems from an autorun mode that allows bypassing whitelisting, potentially leading to arbitrary command execution...
Cursor code issue vulnerabilities
Cursor is an AI code editor open-sourced by Cursor. A code issue vulnerability exists in Cursor versions prior to 1.3 that stems from Mermaid allowing embedded images, which could lead to the disclosure of sensitive information...