Lucene search
+L

55 matches found

KittySploit
KittySploit
•added 2026/07/28 11:27 a.m.•8 views

Node ecstatic Directory Listing Detection

Directiory listing enabled in Node ecstatic. !/usr/bin/env python3 -- coding: utf-8 -- """Directiory listing enabled in Node ecstatic.""" from kittysploit import from lib.protocols.http.httpclient import Httpclient class ModuleScanner, Httpclient: info = 'name': 'Node ecstatic Directory Listing...

5.8AI score
SaveExploits0References2
vulnersOsv
vulnersOsv
•added 2026/05/14 5:11 a.m.•4 views

3rr (>=0.0.1, <=0.0.2), @apatheticwes/trigger (>=0.1.0, <=0.2.0) +555 more potentially affected by unknown CVE via ecstatic (>=0.1.6, <=2.1.0)

ecstatic NPM version =0.1.6, =0.0.1, =0.1.0, =3.0.0-beta.45, =1.0.0, =0.2.3, =0.2.1, =1.0.0, =0.1.1, =0.0.1, =1.0.0, =2.1.1 and more Source cves: unknown CVE Source advisory: MEND:WS-2019-0066...

5.8AI score
SaveExploits0
Mend
Mend
•added 2026/05/14 5:11 a.m.•6 views

WS-2019-0066

Versions of ecstatic prior to 4.1.2 fails to validate redirects, allowing attackers to craft requests that result in an HTTP 301 redirect to any other domains...

6.1CVSS5.9AI score
SaveExploits0References2
vulnersOsv
vulnersOsv
•added 2026/05/14 5:11 a.m.•5 views

cubx-http-server (0.4.2), karma-extjs-jasmine-tester (>=1.0.0, <=1.1.3) +5 more potentially affected by unknown CVE via ecstatic (>=3.1.1, <=3.3.0)

ecstatic NPM version =3.1.1, =1.0.0, =0.1.0, =0.0.1, =0.1.0, =0.1.0, =0.1.0, =0.2.1 Source cves: unknown CVE Source advisory: MEND:WS-2019-0066...

5.8AI score
SaveExploits0
vulnersOsv
vulnersOsv
•added 2026/05/14 2:23 a.m.•4 views

3rr (>=0.0.1, <=0.0.2), @cypress/core-example (>=0.2.3, <=0.8.0) +212 more potentially affected by unknown CVE via ecstatic (>=0.5.1, <=1.3.1)

ecstatic NPM version =0.5.1, =0.0.1, =0.2.3, =0.2.1, =0.1.1, =1.0.0, =1.6.9, =0.0.6, =3.0.0-0, =0.0.0, =0.0.1, =0.1.0, =0.1.1 - adamczyca 1.0.0 and more Source cves: unknown CVE Source advisory: MEND:WS-2015-0002...

5.8AI score
SaveExploits0
vulnersOsv
vulnersOsv
•added 2026/05/14 2:23 a.m.•3 views

@apechimp/cool-led (1.0.0), @clinkchat/tiny-emitter (3.0.0) +112 more potentially affected by unknown CVE via ecstatic (>=0.1.6, <=0.4.13)

ecstatic NPM version =0.1.6, =0.0.1, =4.1.1, =0.2.1, =0.0.7, =0.0.0, =0.3.1, =0.0.0, =0.0.12, =0.0.1, =0.3.4, =0.3.12 and more Source cves: unknown CVE Source advisory: MEND:WS-2015-0002...

5.8AI score
SaveExploits0
Mend
Mend
•added 2026/05/14 2:23 a.m.•6 views

WS-2015-0002

Certain input strings when passed to new Date or Date.parse will cause v8 to raise an exception. This leads to a crash and denial of service in ecstatic when this input is passed into the server via the If-Modified-Since header...

8.7CVSS5.8AI score
SaveExploits0References2
EUVD
EUVD
•added 2025/10/07 12:30 a.m.•20 views

EUVD-2018-0201

Malware in sbrugna...

7.5CVSS7.6AI score0.02061EPSS
SaveExploits0References7
EUVD
EUVD
•added 2025/10/07 12:30 a.m.•24 views

EUVD-2017-0364

Malware in sbrugna...

7.8CVSS7.6AI score0.02557EPSS
SaveExploits1References10
RedhatCVE
RedhatCVE
•added 2025/05/22 7:55 a.m.•14 views

CVE-2019-10775

ecstatic have a denial of service vulnerability. Successful exploitation could lead to crash of an application...

7.5CVSS7.5AI score0.01274EPSS
SaveExploits0References1
vulnersOsv
vulnersOsv
•added 2021/12/09 7:09 p.m.•4 views

com.github.agmenc:ecstatic_2.10 (0.0.2), com.github.agmenc:trivial-rest_2.10 (>=0.0.1, <=0.1.1) +57 more potentially affected by CVE-2021-43797 via io.netty:netty (3.9.1.1.final)

io.netty:netty MAVEN version 3.9.1.1.final is affected by a known vulnerability. The following packages have a transitive dependency on io.netty:netty and may be impacted: - com.github.agmenc:ecstatic2.10 0.0.2 - com.github.agmenc:trivial-rest2.10 =0.0.1, =0.2.0, =0.5.1 -...

6.5CVSS0.02884EPSS
SaveExploits0
vulnersOsv
vulnersOsv
•added 2020/12/15 4:52 p.m.•9 views

netlify-plugin-cypress (>=1.0.2, <=1.3.3) potentially affected by CVE-2019-10775 via ecstatic (4.1.2)

ecstatic NPM version 4.1.2 is affected by a known vulnerability. The following packages have a transitive dependency on ecstatic and may be impacted: - netlify-plugin-cypress =1.0.2, =1.3.3 Source cves: CVE-2019-10775 Source advisory: OSV:GHSA-JC84-3G44-WF2Q...

7.5CVSS5.3AI score0.01274EPSS
SaveExploits0
osv_ghsa
osv_ghsa
•added 2020/12/15 4:52 p.m.•19 views

GHSA-JC84-3G44-WF2Q Denial of Service in ecstatic

ecstatic have a denial of service vulnerability. Successful exploitation could lead to crash of an application...

7.5CVSS7.1AI score0.01274EPSS
SaveExploits0References2
vulnersOsv
vulnersOsv
•added 2020/12/15 4:52 p.m.•4 views

netlify-plugin-cypress (>=1.0.2, <=1.3.3) potentially affected by CVE-2019-10775 via ecstatic (4.1.2)

ecstatic NPM version 4.1.2 is affected by a known vulnerability. The following packages have a transitive dependency on ecstatic and may be impacted: - netlify-plugin-cypress =1.0.2, =1.3.3 Source cves: CVE-2019-10775 Source advisory: GHSA-JC84-3G44-WF2Q...

7.5CVSS0.01274EPSS
SaveExploits0
osv_ghsa
osv_ghsa
•added 2020/08/19 10:44 p.m.•8 views

GHSA-X4RF-4MQF-CM8W Open Redirect in ecstatic

Withdrawn: Duplicate of GHSA-9q64-mpxx-87fg...

7.2AI score
SaveExploits0References3
Github Security Blog
Github Security Blog
•added 2020/08/19 10:44 p.m.•21 views

Open Redirect in ecstatic

Withdrawn: Duplicate of GHSA-9q64-mpxx-87fg...

1AI score
SaveExploits0References4Affected Software1
vulnersOsv
vulnersOsv
•added 2020/04/01 4:35 p.m.•6 views

cubx-http-server (0.4.2), karma-extjs-jasmine-tester (>=1.0.0, <=1.1.3) +5 more potentially affected by unknown CVE via ecstatic (>=3.1.1, <=3.3.0)

ecstatic NPM version =3.1.1, =1.0.0, =0.1.0, =0.0.1, =0.1.0, =0.1.0, =0.1.0, =0.2.1 Source cves: unknown CVE Source advisory: OSV:GHSA-9Q64-MPXX-87FG...

5.4AI score
SaveExploits0
osv_ghsa
osv_ghsa
•added 2020/04/01 4:35 p.m.•73 views

GHSA-9Q64-MPXX-87FG Open Redirect in ecstatic

Versions of ecstatic prior to 4.1.2, 3.3.2 or 2.2.2 are vulnerable to Open Redirect. The package fails to validate redirects, allowing attackers to craft requests that result in an HTTP 301 redirect to any other domains. Recommendation If using ecstatic 4.x, upgrade to 4.1.2 or later. If using...

7.5AI score
SaveExploits0References2
vulnersOsv
vulnersOsv
•added 2020/04/01 4:35 p.m.•5 views

cubx-http-server (0.4.2), karma-extjs-jasmine-tester (>=1.0.0, <=1.1.3) +5 more potentially affected by CVE-2019-10775 via ecstatic (>=3.1.1, <=3.3.0)

ecstatic NPM version =3.1.1, =1.0.0, =0.1.0, =0.0.1, =0.1.0, =0.1.0, =0.1.0, =0.2.1 Source cves: CVE-2019-10775 Source advisory: GHSA-9Q64-MPXX-87FG...

7.5CVSS0.01274EPSS
SaveExploits0
vulnersOsv
vulnersOsv
•added 2020/04/01 4:35 p.m.•7 views

atqueillo (1.0.0), consequaturlaudantium (1.0.0) +10 more potentially affected by unknown CVE via ecstatic (>=2.0.0, <=2.1.0)

ecstatic NPM version =2.0.0, =1.8.4, =1.0.15, =1.0.0, =1.0.0, =1.2.0, =1.4.0 - react-currency-conversion 1.0.5 Source cves: unknown CVE Source advisory: OSV:GHSA-9Q64-MPXX-87FG...

5.4AI score
SaveExploits0
Rows per page
Query Builder