33 matches found
CVE-2023-54396 PocketMine-MP before 4.8.1 Server Crash via Banner NBT
PocketMine-MP versions before 4.8.1 fail to validate dye color IDs in banner NBT data during deserialization. Attackers can provide invalid color values in inventory transactions or via commands to trigger undefined offset errors and crash the server...
CVE-2023-54396 PocketMine-MP before 4.8.1 Server Crash via Banner NBT
PocketMine-MP versions before 4.8.1 fail to validate dye color IDs in banner NBT data during deserialization. Attackers can provide invalid color values in inventory transactions or via commands to trigger undefined offset errors and crash the server...
CVE-2023-54396
PocketMine-MP versions before 4.8.1 fail to validate dye color IDs in banner NBT data during deserialization. Attackers with low privileges can supply invalid color values through inventory transactions or via commands , triggering undefined offset errors that crash the server. The impact is avai...
CVE-2023-54396: Improper Validation of Array Index
PocketMine-MP versions before 4.8.1 fail to validate dye color IDs in banner NBT data during deserialization. Attackers can provide invalid color values in inventory transactions or via commands to trigger undefined offset errors and crash the server...
PT-2026-88987
PocketMine-MP versions before 4.8.1 fail to validate dye color IDs in banner NBT data during deserialization. Attackers can provide invalid color values in inventory transactions or via commands to trigger undefined offset errors and crash the server...
backtrader-plotting (0.5.3), dye-score (0.1.0) +3 more potentially affected by CVE-2026-21883 via bokeh (1.0.4)
bokeh PYPI version 1.0.4 is affected by a known vulnerability. The following packages have a transitive dependency on bokeh and may be impacted: - backtrader-plotting 0.5.3 - dye-score 0.1.0 - explorepy 0.5.0 - flexmeasures =0.2.4.dev12, =0.11.3 - jsmol-bokeh-extension 0.1.0.2 Source cves:...
CVE-2026-35197
dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1...
CVE-2026-35197
dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1...
CVE-2026-35197
dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1...
CVE-2026-35197 Code injection in dye template expressions
dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1...
CVE-2026-35197
dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1...
CVE-2026-35197 Code injection in dye template expressions
dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1...
CVE-2026-35197 Code injection in dye template expressions
dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1...
CVE-2026-35197
CVE-2026-35197 affects the dye library for shell scripts. Before version 1.1.1, certain dye template expressions could lead to arbitrary code execution. The issue was discovered and fixed by the dye author, and is not publicly known to be exploited. A fix is available in 1.1.1. The NVD and Red Ha...
CVE-2026-35197: Improper Control of Generation of Code
dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1...
PT-2026-30721
dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1...
Dye code injection vulnerability
Dye is a portable library developed by Mattie’s personal developer, designed for adding colors and styles to shell script outputs. Versions of dye prior to 1.1.1 contained a code injection vulnerability; this vulnerability stemmed from certain template expressions that could allow arbitrary code ...
cellphonedbu (>=1.1.1.6, <=1.1.1.7), dagster-dask (>=0.5.0rc4, <=0.6.4) +2 more potentially affected by CVE-2026-23528 via distributed (1.28.1)
distributed PYPI version 1.28.1 is affected by a known vulnerability. The following packages have a transitive dependency on distributed and may be impacted: - cellphonedbu =1.1.1.6, =0.5.0rc4, =0.5.0, =0.5.5 Source cves: CVE-2026-23528 Source advisory: OSV:PYSEC-2026-169...
cellphonedbu (>=1.1.1.6, <=1.1.1.7), dagster-dask (>=0.5.0rc4, <=0.6.4) +2 more potentially affected by CVE-2026-23528 via distributed (1.28.1)
distributed PYPI version 1.28.1 is affected by a known vulnerability. The following packages have a transitive dependency on distributed and may be impacted: - cellphonedbu =1.1.1.6, =0.5.0rc4, =0.5.0, =0.5.5 Source cves: CVE-2026-23528 Source advisory: OSV:GHSA-C336-7962-WFJ2...
chispa (0.2.0), dye-score (0.1.0) +4 more potentially affected by CVE-2025-55039 via pyspark (2.4.0)
pyspark PYPI version 2.4.0 is affected by a known vulnerability. The following packages have a transitive dependency on pyspark and may be impacted: - chispa 0.2.0 - dye-score 0.1.0 - md2k-cerebral-cortex 3.0.0 - pybda =0.0.4, =0.0.4, =0.0.1, =0.0.8 Source cves: CVE-2025-55039 Source advisory:...