9794 matches found
ecdsa-private-key-recovery
ecdsa-key-recovery Perform ECDSA and DSA Nonce Reuse private key recovery attacks A cryptographic research tool for analyzing signature vulnerabilities Let's recover the private-key for two signatures sharing the same nonce k. Note how choosing the same nonce k results in both signatures having a...
CVE-2026-85248
CVE-2026-85248 — camel-pqc: concurrent Signature race signature verification bypass Runnable proof-of-concept reproducer for the Apache Camel vulnerability where the PQC producer held a singlejava.security.Signature instance and used it for every exchange without synchronization. Signature is...
punk.py
punk.py unix SSH post-exploitation 1337 tool how it works punk.py is a post-exploitation tool meant to help network pivoting from a compromised unix box. It collect usernames, ssh keys and known hosts from a unix system, then it tries to connect via ssh to all the combinations found. punk.py is...
LR-WebPKI
LR+ WebPKI Evaluation Artifact This package contains the finalized LR+ reference implementation, production reconstruction wrappers, tests, and generated evaluation outputs for context-closed post-quantum authentication over WebPKI CA context. The package is intentionally written as a submission...
dsa
A Summary of Go's crypto/dsa Vulnerability CVE-2016-3959 Alex Mullins April 9, 2016 Introduction Recently, there was a bug discovered in the Digital Signature Algorithm DSA crypto library for the Go programming language. In this article we'll go over the details of the bug and how an attacker cou...
[SECURITY] [DSA 6621-1] thunderbird security update
------------------------------------------------------------------------- Debian Security Advisory DSA-6621-1 [email protected] https://www.debian.org/security/ Moritz Muehlenhoff November 12, 2026 https://www.debian.org/security/faq -...
cryptovenom
CryptoVenom CryptoVenom: The Cryptography Swiss Army knife What is CryptoVenom? CryptoVenom is an OpenSource tool which contains a lot of cryptosystems and cryptoanalysis methods all in one, including classical algorithms, hash algorithms, encoding algorithms, logic gates, mathematical functions,...
ejbca-pqc-lab
EJBCA Pure PQC Lab — ML-DSA-65 Two-Tier PKI Hierarchy A hands-on implementation of NIST FIPS 204 ML-DSA in a two-tier PKI hierarchy using EJBCA Community Edition. 📖 Full walkthrough: Building a Post-Quantum PKI: How I Signed a Root CA and Sub CA Using ML-DSA on EJBCA What This Lab Builds A comple...
wolfCOSE
wolfCOSE wolfCOSE is a lightweight and fast C library implementing core CBOR and COSE standards, backed by wolfSSL for cryptography. Supported Standards & RFCs Core Specifications: RFC 8949 - Concise Binary Object Representation CBOR RFC 9052 - CBOR Object Signing and Encryption COSE RFC 9053 -...
Astra Linux – vulnerability in linux-6.1, linux-6.12, linux-6.18
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: round up PTP perout pin duration Pin duration is converted from the user-provided period to SJA1105 clock ticks, then passed as the cycletime argument to futurebasetime. Very small period values may become zero...
Astra Linux – vulnerability in linux-6.18
In the Linux kernel, the following vulnerability has been resolved: net: dsa: mt7530: leave the MDIO IRQ mappings to regmap-irq mt7530removecommon disposes the per-PHY interrupt mappings via remove, but the regmap-irq chip that owns the domain is devm-registered; thus its parent interrupt is only...
Astra Linux – vulnerability in linux-6.1
In the Linux kernel, the following vulnerability has been resolved: net: dsa: sja1105: flower: reject cross-chip redirect dsaportfromnetdev may return a valid port from a different switch chip. Programming the port index of another chip into the local hardware causes redirection to the wrong port...
Astra Linux – vulnerability in linux-6.18
In the Linux kernel, the following vulnerability has been resolved: net: dsa: tagbrcm: legacy FCS: request needed tailroom The legacy FCS tagger calculates the CRC over skb-len bytes starting from skb-data. When a nonlinear skb reaches the tagger, it reads beyond the linear head into unrelated sl...
Astra Linux – vulnerability in linux-6.1
In the Linux kernel, the following vulnerability has been resolved: net: dsa: mv88e6xxx: bound the policy rule dump by the caller’s buffer size mv88e6xxxgetrxnfc uses rxnfc-rulecnt as the write index while dumping the policy IDR, clobbering the input value before it has been looked at. That input...
CLEANSTART-2025-ZT05905 OpenSSL DSA signature algorithm has been shown to be vulnerable to a timing side channel attack
CVE-2018-0734 affects multiple packages. The OpenSSL DSA signature algorithm has been shown to be vulnerable to a timing side channel attack. See references for individual vulnerability details...
CLEANSTART-2026-KN59138 Validating certificate chains which contain DSA public keys can cause programs to panic, due to a interface cast that assumes they implement the Equal method
CVE-2025-58188 affects multiple packages. Validating certificate chains which contain DSA public keys can cause programs to panic, due to a interface cast that assumes they implement the Equal method. See references for individual vulnerability details...
CLEANSTART-2026-ZD85754 RSA and DSA public key parsers did not enforce size limits on key parameters
CVE-2026-39829 affects multiple packages. The RSA and DSA public key parsers did not enforce size limits on key parameters. See references for individual vulnerability details...
CLEANSTART-2026-TJ32379 Validating certificate chains which contain DSA public keys can cause programs to panic, due to a interface cast that assumes they implement the Equal method
CVE-2025-58188 affects multiple packages. Validating certificate chains which contain DSA public keys can cause programs to panic, due to a interface cast that assumes they implement the Equal method. See references for individual vulnerability details...
CLEANSTART-2026-OR90950 RSA and DSA public key parsers did not enforce size limits on key parameters
CVE-2026-39829 affects multiple packages. The RSA and DSA public key parsers did not enforce size limits on key parameters. See references for individual vulnerability details...
CLEANSTART-2026-AQ55158 Validating certificate chains which contain DSA public keys can cause programs to panic, due to a interface cast that assumes they implement the Equal method
CVE-2025-58188 affects multiple packages. Validating certificate chains which contain DSA public keys can cause programs to panic, due to a interface cast that assumes they implement the Equal method. See references for individual vulnerability details...