Lucene search
+L

195 matches found

Debian CVE
Debian CVE
•added 2025/02/10 5:35 p.m.•21 views

CVE-2025-25188

Hickory DNS is a Rust based DNS client, server, and resolver. A vulnerability present starting in version 0.8.0 and prior to versions 0.24.3 and 0.25.0-alpha.5 impacts Hickory DNS users relying on DNSSEC verification in the client library, stub resolver, or recursive resolver. The DNSSEC validati...

7.1CVSS5.4AI score0.00284EPSS
SaveExploits0
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2025/02/10 12:00 a.m.•3 views

CVE-2025-25188: Insufficient Verification of Data Authenticity

Hickory DNS is a Rust based DNS client, server, and resolver. A vulnerability present starting in version 0.8.0 and prior to versions 0.24.3 and 0.25.0-alpha.5 impacts Hickory DNS users relying on DNSSEC verification in the client library, stub resolver, or recursive resolver. The DNSSEC validati...

7.1CVSS5.7AI score0.00284EPSS
SaveExploits0References1
OSV
OSV
•added 2025/02/07 12:00 p.m.•16 views

RUSTSEC-2025-0006 Hickory DNS failure to verify self-signed RRSIG for DNSKEYs

Summary The DNSSEC validation routines treat entire RRsets of DNSKEY records as trusted once they have established trust in only one of the DNSKEYs. As a result, if a zone includes a DNSKEY with a public key that matches a configured trust anchor, all keys in that zone will be trusted to...

7.3AI score
SaveExploits0References3
Tenable Nessus
Tenable Nessus
•added 2024/09/03 12:00 a.m.•38 views

EulerOS Virtualization 2.12.1 : systemd (EulerOS-SA-2024-2318)

According to the versions of the systemd packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cau...

7.5CVSS6.9AI score0.99988EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/08/20 12:00 a.m.•37 views

EulerOS 2.0 SP12 : systemd (EulerOS-SA-2024-2228)

According to the versions of the systemd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of...

7.5CVSS6.9AI score0.99988EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/07/16 12:00 a.m.•46 views

EulerOS 2.0 SP9 : dnsmasq (EulerOS-SA-2024-1954)

According to the versions of the dnsmasq package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of...

7.5CVSS6.9AI score0.99988EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/07/16 12:00 a.m.•35 views

EulerOS 2.0 SP9 : systemd (EulerOS-SA-2024-1947)

According to the versions of the systemd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of...

7.5CVSS6.9AI score0.99988EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/07/16 12:00 a.m.•40 views

EulerOS 2.0 SP9 : systemd (EulerOS-SA-2024-1974)

According to the versions of the systemd packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of...

7.5CVSS6.9AI score0.99988EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/06/28 12:00 a.m.•33 views

EulerOS 2.0 SP12 : dnsmasq (EulerOS-SA-2024-1865)

According to the versions of the dnsmasq package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of...

7.5CVSS6.9AI score0.99988EPSS
SaveExploits1References3
Tenable Nessus
Tenable Nessus
•added 2024/06/28 12:00 a.m.•41 views

EulerOS 2.0 SP12 : dnsmasq (EulerOS-SA-2024-1851)

According to the versions of the dnsmasq package installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : The Closest Encloser Proof aspect of the DNS protocol in RFC 5155 when RFC 9276 guidance is skipped allows remote attackers to cause a denial of...

7.5CVSS6.9AI score0.99988EPSS
SaveExploits1References3
Veracode
Veracode
•added 2024/02/18 6:35 a.m.•77 views

Denial Of Service

dnsmasq is vulnerable to Denial of Service. The vulnerability due to KeyTrap issue when dealing with a zone that contains numerous DNSKEY DNS Key and RRSIG Resource Record Signature records, the protocol specification implies that an algorithm must evaluate all combinations of DNSKEY and RRSIG...

7.5CVSS6.6AI score0.99988EPSS
SaveExploits0References31Affected Software7
OSV
OSV
•added 2024/02/14 4:15 p.m.•14 views

AZL-34559 CVE-2023-50387 affecting package bind for versions less than 9.20.0-1

Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU consumption via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG...

7.5CVSS6.7AI score0.99988EPSS
SaveExploits0References1
OSV
OSV
•added 2024/02/14 4:15 p.m.•15 views

AZL-34440 CVE-2023-50387 affecting package unbound for versions less than 1.19.1-1

Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU consumption via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG...

7.5CVSS7AI score0.99988EPSS
SaveExploits0References1
Vulnrichment
Vulnrichment
•added 2024/02/14 12:00 a.m.•17 views

CVE-2023-50387

Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU consumption via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG...

7.8AI score0.99988EPSS
SaveExploits0References30
AlpineLinux
AlpineLinux
•added 2024/02/14 12:00 a.m.•117 views

CVE-2023-50387

Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU consumption via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG...

7.5CVSS8AI score0.99988EPSS
SaveExploits0
OSV
OSV
•added 2024/02/14 12:00 a.m.•84 views

CVE-2023-50387

Certain DNSSEC aspects of the DNS protocol in RFC 4033, 4034, 4035, 6840, and related RFCs allow remote attackers to cause a denial of service CPU consumption via one or more DNSSEC responses, aka the "KeyTrap" issue. One of the concerns is that, when there is a zone with many DNSKEY and RRSIG...

7.5CVSS7.4AI score
SaveExploits0References38
Code423n4
Code423n4
•added 2023/04/28 12:00 a.m.•16 views

length OF THE BYTES ARRAY IS NOT CHECKED BEFORE SUBSTRING IS EXTRACTED FROM IT, WHICH COULD LEAD TO SUBSTRING OF bytes(0)

Lines of code Vulnerability details Impact In RRUtils.readDNSKEY function, if the length == 4 then the self.publicKey will be an empty bytes array. No check is performed to validata the length variable. This will return the public key of the DNSKEY as an empty bytes array. Check should be perform...

6.8AI score
SaveExploits0
Code423n4
Code423n4
•added 2023/04/26 12:00 a.m.•23 views

verifySignatureWithKey - RRSIG RR's Signer's Name is never checked if it matches owner name

Lines of code Vulnerability details Impact According to RFC 4035 and as mentioned in the comments in function "verifySignatureWithKey" , the Signer's name should also be checked if it matches the owner name. If the Signer's Name field of an RRSIG record does not match the owner name of a DNSKEY...

6.7AI score
SaveExploits0
OpenVAS
OpenVAS
•added 2023/01/12 12:00 a.m.•38 views

Huawei EulerOS: Security Advisory for unbound (EulerOS-SA-2023-1156)

The remote host is missing an update for the Huawei EulerOS SPDX-FileCopyrightText: 2023 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...

7.5CVSS7.7AI score0.01636EPSS
SaveExploits0References2
UbuntuCve
UbuntuCve
•added 2022/09/26 12:00 a.m.•58 views

CVE-2022-3204

A vulnerability named 'Non-Responsive Delegation Attack' NRDelegation Attack has been discovered in various DNS resolving software. The NRDelegation Attack works by having a malicious delegation with a considerable number of non responsive nameservers. The attack starts by querying a resolver for...

7.5CVSS6.9AI score0.01636EPSS
SaveExploits0References3
Rows per page
Query Builder