9755 matches found
CVE-2025-13654
The duc disk management tool is vulnerable to a stack buffer overflow within the buffer_get function. The issue arises because a condition can evaluate to true due to an underflow , resulting in an out-of-bounds read . This vulnerability has been addressed in version 1.4.6 . Security updates are ...
CVE-2025-13654 CVE-2025-13654
A stack buffer overflow vulnerability exists in the bufferget function of duc, a disk management tool, where a condition can evaluate to true due to underflow, allowing an out-of-bounds read...
CVE-2025-13654 CVE-2025-13654
A stack buffer overflow vulnerability exists in the bufferget function of duc, a disk management tool, where a condition can evaluate to true due to underflow, allowing an out-of-bounds read...
duc security vulnerabilities
duc is a tool for checking disk usage by the individual developer Ico Doornekamp. A security vulnerability exists in duc that stems from a stack buffer overflow in the bufferget function, which could lead to out-of-bounds reads...
CVE-2025-40233 ocfs2: clear extent cache after moving/defragmenting extents
In the Linux kernel, the following vulnerability has been resolved: ocfs2: clear extent cache after moving/defragmenting extents The extent map cache can become stale when extents are moved or defragmented, causing subsequent operations to see outdated extent flags. This triggers a BUGON in...
CVE-2025-40233
In CVE-2025-40233, the Linux kernel OCFS2 subsystem fixes a stale extent map cache that can occur during reflinked extent moves/defrag, triggering BUG_ON in ocfs2_refcount_cal_cow_clusters(). The issue arises when copy_file_range() creates a reflinked extent with OCFS2_EXT_REFCOUNTED, then FITRIM...
EUVD-2025-201226
In the Linux kernel, the following vulnerability has been resolved: ocfs2: clear extent cache after moving/defragmenting extents The extent map cache can become stale when extents are moved or defragmented, causing subsequent operations to see outdated extent flags. This triggers a BUGON in...
kernel: md-raid10: fix KASAN warning
In the Linux kernel, the following vulnerability has been resolved: md-raid10: fix KASAN warning There's a KASAN warning in raid10removedisk when running the lvm test lvconvert-raid-reshape.sh. We fix this warning by verifying that the value "number" is valid. BUG: KASAN: slab-out-of-bounds in...
Exploit for CVE-2025-55182
CVE-2025-55182 Raw HTTP Requests to exploit the insecure lazy...
CVE-2025-63914
An issue was discovered in Cinnamon kotaemon 0.11.0. The mayextractzip function in the \libs\ktem\ktem\index\file\ui.py file does not check the contents of uploaded ZIP files. Although the contents are extracted into a temporary folder that is cleared before each extraction, successfully uploadin...
Linux Distros Unpatched Vulnerability : CVE-2025-64775
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0...
Linux kernel RAID LVM md_start_sync() Buffer Overflow DoS
Vulnerability of the mdstartsync function in the drivers/md/md.c module – The Linux kernel’s support for multiple devices RAID and LVM is related to the occurrence of mutual locking. Exploiting this vulnerability could allow a remote attacker to cause service failures...
maxminddb's `Reader::open_mmap` unsoundly marks unsafe memmap operation as safe
maxminddb prior to version 0.27 declared Reader::openmmap as safe despite wrapping an inherently unsafe memmap2 operation with no extra step done to guarantee safety. This could have led to undefined behaviour if the file were to be modified on disk while the memory map was still active...
GHSA-MJ73-J457-8X9Q maxminddb's `Reader::open_mmap` unsoundly marks unsafe memmap operation as safe
maxminddb prior to version 0.27 declared Reader::openmmap as safe despite wrapping an inherently unsafe memmap2 operation with no extra step done to guarantee safety. This could have led to undefined behaviour if the file were to be modified on disk while the memory map was still active...
CVE-2025-61229
An issue in Shirt Pocket's SuperDuper! 3.10 and earlier allow a local attacker to modify the default task template to execute an arbitrary preflight script with root privileges and Full Disk Access, thus bypassing macOS privacy controls...
CVE-2025-65844: Unrestricted Upload of File with Dangerous Type
EverShop 2.0.1 allows a remote unauthenticated attacker to upload arbitrary files and create directories via the /api/images endpoint. The endpoint is accessible without authentication by default, and server-side validation of uploaded files is insufficient. This can be abused to upload arbitrary...
Servicing stack update for Windows 10, Version 1903: July 26, 2019
Servicing stack update for Windows 10, Version 1903: July 26, 2019 Applies To Windows 10, version 1903, all editions Summary This update makes quality improvements to the servicing stack, which is the component that installs Windows updates. Key changes include: Addresses an issue in which an...
CVE-2025-65844
EverShop 2.0.1 allows a remote unauthenticated attacker to upload arbitrary files and create directories via the /api/images endpoint. The endpoint is accessible without authentication by default, and server-side validation of uploaded files is insufficient. This can be abused to upload arbitrary...
CVE-2025-65844
EverShop 2.0.1 allows a remote unauthenticated attacker to upload arbitrary files and create directories via the /api/images endpoint. The endpoint is accessible without authentication by default, and server-side validation of uploaded files is insufficient. This can be abused to upload arbitrary...
GHSA-XX7V-HQXH-CJR9 Apache Struts is Vulnerable to DoS via File Leak
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.0, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue...