221 matches found
GHSA-VJ54-72F3-P5JV devalue prototype pollution vulnerability
devalue.parse allows proto to be set A string passed to devalue.parse could represent an object with a proto property, which would assign a prototype to an object while allowing properties to be overwritten: js class Vector constructorx, y this.x = x; this.y = y; get magnitude return this.x 2 +...
Prototype Pollution
Overview devalue is a JSON.stringify, but handles cyclical references, repeated references, undefined, regular expressions, dates, Map and Set. Affected versions of this package are vulnerable to Prototype Pollution via the parse function. An attacker can manipulate object prototypes or assign...
@jill64/svelte-dark-theme (>=2.3.65, <=5.1.7), @jill64/svelte-i18n (>=1.1.27, <=2.2.1) +9 more potentially affected by CVE-2025-57820 via devalue (>=5.0.0, <=5.1.1)
devalue NPM version =5.0.0, =2.3.65, =1.1.27, =1.1.21, =1.2.263, =2.2.3, =0.0.2-dev.84, =1.0.23, =1.0.22, =1.0.0, =1.0.6, =2.1.10, =2.1.15 Source cves: CVE-2025-57820 Source advisory: OSV:GHSA-VJ54-72F3-P5JV...
@jill64/svelte-dark-theme (>=2.3.65, <=5.1.7), @jill64/svelte-i18n (>=1.1.27, <=2.2.1) +9 more potentially affected by CVE-2025-57820 via devalue (>=5.0.0, <=5.1.1)
devalue NPM version =5.0.0, =2.3.65, =1.1.27, =1.1.21, =1.2.263, =2.2.3, =0.0.2-dev.84, =1.0.23, =1.0.22, =1.0.0, =1.0.6, =2.1.10, =2.1.15 Source cves: CVE-2025-57820 Source advisory: SNYK:JS-DEVALUE-12205530...
@jill64/svelte-dark-theme (>=2.3.65, <=5.1.7), @jill64/svelte-i18n (>=1.1.27, <=2.2.1) +9 more potentially affected by CVE-2025-57820 via devalue (>=5.0.0, <=5.1.1)
devalue NPM version =5.0.0, =2.3.65, =1.1.27, =1.1.21, =1.2.263, =2.2.3, =0.0.2-dev.84, =1.0.23, =1.0.22, =1.0.0, =1.0.6, =2.1.10, =2.1.15 Source cves: CVE-2025-57820 Source advisory: GHSA-VJ54-72F3-P5JV...
CVE-2025-57820: Improperly Controlled Modification of Object Prototype Attributes
Svelte devalue is a utility library. Prior to version 5.3.2, a string passed to devalue.parse could represent an object with a proto property and devalue.parse does not check that an index is numeric. This could result in assigning prototypes to objects and properties, leading to prototype...
PT-2025-34819
Name of the Vulnerable Software and Affected Versions: Svelte devalue versions prior to 5.3.2 Description: Svelte devalue is a utility library susceptible to prototype pollution. Passing a string to devalue.parse that represents an object with a proto property, without numeric index checking, can...
Cross-Site Scripting (XSS)
devalue is vulnerable to cross-site scripting XSS attacks. A remote attacker is able to inject and execute arbitrary Javascript on a victim's browser due to the unsafe use of JSON.stringify in the stringifyPrimitive function...
3nit-utils (>=0.30.0, <=1.0.2), @aller/theming (>=1.0.0, <=1.0.2) +25 more potentially affected by unknown CVE via devalue (2.0.0)
devalue NPM version 2.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on devalue and may be impacted: - 3nit-utils =0.30.0, =1.0.0, =1.2.1-next.3, =0.0.1, =0.1.1, =1.11.8, =4.1.1, =0.1.2, =0.1.1, =0.0.2-canary.2, =9.0.5-canary.0, =9.1.5-canary.9 and...
Cross-site Scripting (XSS)
Overview devalue is a JSON.stringify, but handles cyclical references, repeated references, undefined, regular expressions, dates, Map and Set. Affected versions of this package are vulnerable to Cross-site Scripting XSS. It does not properly mitigate against unsafe characters in serialized regul...
Cross-Site Scripting in @nuxt/devalue
Versions of @nuxt/devalue prior to 1.2.3 are vulnerable to Cross-Site Scripting. Due to insufficient input sanitization attacker may inject arbitrary JavaScript code through object keys. Recommendation Upgrade to version 1.2.3 or later...
CVE-2019-13506
@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS...
CVE-2019-13506
@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS...
Cross site scripting
@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS...
CVE-2019-13506
CVE-2019-13506 affects @nuxt/devalue before 1.2.3 (used in Nuxt.js before 2.6.2). The root cause is mishandling of object keys, leading to Cross-Site Scripting (XSS). Impact: potential XSS via object keys in affected builds; CVSS ~6.1 (NVD v3). Mitigation: upgrade to @nuxt/devalue 1.2.3 or later ...
CVE-2019-13506
@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS...
CVE-2019-13506
@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS...
PT-2019-13374
Name of the Vulnerable Software and Affected Versions @Nuxt/devalue versions prior to 1.2.3 Nuxt.js versions prior to 2.6.2 Description The issue is related to the mishandling of object keys, leading to Cross-Site Scripting XSS. Insufficient input sanitization allows an attacker to inject arbitra...
CVE-2019-13506: Improper Neutralization of Input During Web Page Generation
@nuxt/devalue before 1.2.3, as used in Nuxt.js before 2.6.2, mishandles object keys, leading to XSS...
Cross-site Scripting (XSS)
devalue is vulnerable to cross-site scripting attacks. The vulnerability exists due to lack of sanitized values in safeKey and safeProp which allows an attacker to inject and execute malicious javascript...