120 matches found
CVE-2026-46591
camel-neo4j Cypher Injection Reproducer CVE-2026-46591 This project demonstrates a Cypher injection in Apache Camel's camel-neo4j component, tracked as CVE-2026-46591. The producer builds the Cypher WHERE clause for its match/retrieve and delete operations from the CamelNeo4jMatchProperties map...
CVE-2026-32247
CVE-2026-32247 — Cypher Injection in graphiti-core via unsanitized nodelabels Severity : High CVSS 8.1 CWE : CWE-943 — Improper Neutralization of Special Elements in Data Query Logic Affected : graphiti-core = 0.28.1 pip Fixed in : 0.28.2 Advisory : GHSA-gg5m-55jj-8m5g NVD :...
Flexible GraphRAG: Cypher/Graph Injection via broken string-escaping in FalkorDB adapter (_escape()) - full graph wipe from ingested-document content
Description def escapev: str - str: return strv.replace"'", "\'".replace"\", "\\" The escaping order is backwards, exactly like the classic HTML double-escape bug: step 1 inserts a literal backslash in front of every ', then step 2 re-matches that just-inserted backslash and doubles it. For an...
EUVD-2026-108207
Flexible GraphRAG: Cypher/Graph Injection via broken string-escaping in FalkorDB adapter escape - full graph wipe from ingested-document content...
CVE-2026-114510
Flexible GraphRAG is a Python framework for building graph and retrieval-augmented generation applications across multiple graph, vector, and search backends. From 0.6.0 until 0.8.2, the escape helper in flexible-graphrag/langchain/graph/pgstoreadapters/falkordbadapter.py escapes quotes before...
CVE-2026-114510 Flexible GraphRAG: Cypher/Graph Injection via broken string-escaping in FalkorDB adapter (_escape()) - full graph wipe from ingested-document content
Flexible GraphRAG is a Python framework for building graph and retrieval-augmented generation applications across multiple graph, vector, and search backends. From 0.6.0 until 0.8.2, the escape helper in flexible-graphrag/langchain/graph/pgstoreadapters/falkordbadapter.py escapes quotes before...
CVE-2026-114510
Flexible GraphRAG is a Python framework for building graph and retrieval-augmented generation applications across multiple graph, vector, and search backends. From 0.6.0 until 0.8.2, the escape helper in flexible-graphrag/langchain/graph/pgstoreadapters/falkordbadapter.py escapes quotes before...
CVE-2026-114510 Flexible GraphRAG: Cypher/Graph Injection via broken string-escaping in FalkorDB adapter (_escape()) - full graph wipe from ingested-document content
Flexible GraphRAG is a Python framework for building graph and retrieval-augmented generation applications across multiple graph, vector, and search backends. From 0.6.0 until 0.8.2, the escape helper in flexible-graphrag/langchain/graph/pgstoreadapters/falkordbadapter.py escapes quotes before...
CVE-2026-114510
The Flexible GraphRAG Python framework (versions 0.6.0 to 0.8.2) is vulnerable to Cypher/Graph Injection due to a broken string-escaping mechanism in the _escape() helper within the FalkorDB adapter . When GRAPH_BACKEND=langchain and GRAPH_DB=falkordb are configured, an attacker can provide malic...
PT-2026-121404
Name of the Vulnerable Software and Affected Versions Flexible GraphRAG versions 0.6.0 through 0.8.1 Description The escape helper in flexible-graphrag/langchain/graph/pg store adapters/falkordb adapter.py incorrectly escapes quotes before backslashes. This allows an inserted escape to be doubled...
Steve Reiner Flexible GraphRAG improper output handling vulnerability
A security vulnerability exists in Steve Reiner Flexible GraphRAG versions 0.6.0 through 0.8.2. This vulnerability arises because the escape helper function in the falkordbadapter.py file first escapes quotes and then escapes backslashes. The resulting values are interpolated into the Cypher...
CVE-2026-86460
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
CVE-2026-86460 Apache Syncope: Cypher Injection via FIQL Search on Neo4j Persistence
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
CVE-2026-86460
A Cypher injection vulnerability exists in the Neo4j persistence layer of Apache Syncope when processing certain FIQL search conditions . This flaw affects versions 3.0.0-M0 through 3.0.16 , 4.0.0-M0 through 4.0.7 , and 4.1.0-M0 through 4.1.2 . Impacting the persistence layer, the vulnerability c...
EUVD-2026-77375
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
CVE-2026-86460 Apache Syncope: Cypher Injection via FIQL Search on Neo4j Persistence
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
CVE-2026-86460
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
CVE-2026-86460: Improper Neutralization of Special Elements used in an SQL Command
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
PT-2026-91150
Cypher injection vulnerability in the Neo4j persistence layer when processing some FIQL search conditions. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.7, from 4.1.0-M0 through 4.1.2. Users are recommended to upgrade to version 4.0.8 / 4.1.3, which fi...
CVE-2026-76223 ArcadeDB before 26.8.1 Permission Bypass via DEFINE FUNCTION
ArcadeDB com.arcadedb versions 26.7.3 and earlier fail to enforce the UPDATESCHEMA permission check when a DEFINE FUNCTION statement targets an already-existing function library. A user with only database access can add or overwrite SQL or Cypher functions in an existing library and persist the...