5 matches found
@jpmorganchase/perspective-viewer-highcharts (>=0.1.7, <=0.1.13), angular-universe (>=0.0.1, <=0.0.2) +3 more potentially affected by CVE-2018-20801 via highcharts (>=6.0.1, <=6.0.7)
highcharts NPM version =6.0.1, =0.1.7, =0.0.1, =1.1.0, =2.1.0 - web-platform-library 0.0.2 - zeppelin-highmaps 1.0.0 Source cves: CVE-2018-20801 Source advisory: GHSA-XMC8-CJFR-PHX3...
@jpmorganchase/perspective-viewer-highcharts (>=0.1.7, <=0.1.13), angular-universe (>=0.0.1, <=0.0.2) +3 more potentially affected by CVE-2018-20801 via highcharts (>=6.0.1, <=6.0.7)
highcharts NPM version =6.0.1, =0.1.7, =0.0.1, =1.1.0, =2.1.0 - web-platform-library 0.0.2 - zeppelin-highmaps 1.0.0 Source cves: CVE-2018-20801 Source advisory: OSV:GHSA-XMC8-CJFR-PHX3...
CVE-2018-20801
In js/parts/SvgRenderer.js in Highcharts JS before 6.1.0, the use of backtracking regular expressions permitted an attacker to conduct a denial of service attack against the SVGRenderer component, aka ReDoS...
@attivio/suit (>=0.0.1, <=1.0.7), @beisen/beisen-cloud-ui (>=1.22.1-3, <=1.22.2-16) +187 more potentially affected by CVE-2018-20801 via highcharts (>=4.2.0, <=6.0.7)
highcharts NPM version =4.2.0, =0.0.1, =1.22.1-3, =0.0.1, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.1.0, =0.22.0, =0.8.1, =0.1.0, =0.23.0, =0.1.0, =0.45.0, =0.1.0, =0.60.1 and more Source cves: CVE-2018-20801 Source advisory: MEND:CVE-2018-20801...
CVE-2018-20801
Highcharts JS (before 6.1.0) has a Regular Expression Denial of Service (ReDoS) flaw in SvgRenderer.js due to backtracking regex usage. This could allow an attacker to disrupt the SVGRenderer component by processing crafted input. Remediation: upgrade to Highcharts 6.1.0 or newer. Affected CVE: C...