4153 matches found
hashes
RustCrypto: Hashes !Project Chatchat-imagechat-link !dependency statusdeps-imagedeps-link !Apache2/MIT licensedlicense-image Collection of cryptographic hash functions1 written in pure Rust. All algorithms reside in separate crates and are implemented using traits from digest crate. Usage example...
rustdllproxy
rustdllproxy A Rust crate utility to easily generate and develop proxy DLLs for Windows applications. Installation cargo install rustdllproxy Compatibility This crate currently only supports the standard DLL PE format. Current Limitations When hooking functions with custom code, the function...
lacuna-rs
lacuna-rs Ghost-frame call-stack spoofing + runtime indirect syscalls for Windows x64 — ported to Rust. Ported from LACUNA Chain lacunachain.c by Mohamed Alzhrani 0xmaz. lacuna-rs is a reusable Rust crate that provides the same primitives as the original C TTP, structured so it can be dropped int...
vuke
vuke Research tool for analyzing and reproducing vulnerable Bitcoin key generation. Features Modular architecture - pluggable sources and transforms Multiple input sources Numeric ranges test weak seeds Wordlists brainwallet analysis Timestamps time-based PRNG exploitation Stdin streaming pipelin...
Shelter
Shelter Shelter is a completely weaponized sleep obfuscation technique that allows to fully encrypt your in-memory payload making an extensive use of ROP. This crate comes with the following characteristics: AES-128 encryption. Whole PE encryption capability. Removal of execution permission durin...
checkout-index
checkout-index - Reproducer for CVE-2025-22620 This is the proof of concept code for RUSTSEC-2025-0001 CVE-2025-22620, GHSA-fqmf-w4xh-33rh. It is the same code as in the advisory, but in the form of a Rust project, with Cargo.toml and Cargo.lock included. This repo was useful while writing the...
CVE-2026-102438
An uncontrolled search path element vulnerability in ASUS Armoury Crate allows local users to execute arbitrary code with SYSTEM privileges via replacement of a dynamic-link library DLL that is later loaded by a high-privilege process. Refer to the ' Security Update for Armoury Crate App ' sectio...
EUVD-2026-104782
An uncontrolled search path element vulnerability in ASUS Armoury Crate allows local users to execute arbitrary code with SYSTEM privileges via replacement of a dynamic-link library DLL that is later loaded by a high-privilege process. Refer to the ' Security Update for Armoury Crate App ' sectio...
CVE-2026-102438
The ASUS Armoury Crate application is susceptible to an uncontrolled search path element vulnerability (CWE-427). This flaw allows local users to execute arbitrary code with SYSTEM privileges by replacing a dynamic-link library (DLL) that is subsequently loaded by a high-privilege process. Remedi...
CVE-2026-102438
An uncontrolled search path element vulnerability in ASUS Armoury Crate allows local users to execute arbitrary code with SYSTEM privileges via replacement of a dynamic-link library DLL that is later loaded by a high-privilege process. Refer to the ' Security Update for Armoury Crate App ' sectio...
CVE-2026-105297
Summary Before version 0.8.1, Pingora's HTTP/2 server used the h2 crate's default limits unless the application set its own 16 MiB decoded header-list size and no limit on concurrent streams. A remote, unauthenticated client can send 1-byte HPACK references to a near-empty header, making the serv...
CVE-2026-105297
The Pingora HTTP/2 server is vulnerable to a remote, unauthenticated denial of service (DoS) due to memory exhaustion. Before version 0.8.1 , the server used default limits that allowed a client to send 1-byte HPACK references to near-empty headers, forcing the server to allocate hundreds of thou...
CVE-2026-105297 Pingora HTTP/2 server memory exhaustion through unbounded default header-list and concurrent-stream limits
Summary Before version 0.8.1, Pingora's HTTP/2 server used the h2 crate's default limits unless the application set its own 16 MiB decoded header-list size and no limit on concurrent streams. A remote, unauthenticated client can send 1-byte HPACK references to a near-empty header, making the serv...
CVE-2026-105297 Pingora HTTP/2 server memory exhaustion through unbounded default header-list and concurrent-stream limits
Summary Before version 0.8.1, Pingora's HTTP/2 server used the h2 crate's default limits unless the application set its own 16 MiB decoded header-list size and no limit on concurrent streams. A remote, unauthenticated client can send 1-byte HPACK references to a near-empty header, making the serv...
EUVD-2026-104678
Summary Before version 0.8.1, Pingora's HTTP/2 server used the h2 crate's default limits unless the application set its own 16 MiB decoded header-list size and no limit on concurrent streams. A remote, unauthenticated client can send 1-byte HPACK references to a near-empty header, making the serv...
PT-2026-118095
Name of the Vulnerable Software and Affected Versions ASUS Armoury Crate affected versions not specified Description An uncontrolled search path element issue allows local users to execute arbitrary code with SYSTEM privileges. This occurs through the replacement of a dynamic-link library DLL,...
RUSTSEC-2026-0348 Brotli certificate decompression can allocate up to 1 GiB before authentication
The built-in Brotli certificate decompressor enabled by the non-default brotli crate feature bounded the size of the decompressed output, but accepted a peer-selected history window. Brotli's large-window extension was enabled, so a five-byte header could cause an allocation of 1 GiB. A peer can...
boha
@agntn/puzzles Public crypto puzzles and bounties, as typed records. You ask for a puzzle, you get its address, its key material and what happened on chain. Why? Every puzzle thread has the same three things: the addresses, the prizes, and who solved what. Every scanner and tracker re-types them...
http-desync-guardian
Resumen HTTP/1.1 experimentó una larga evolución desde 1991 hasta 2014: HTTP/0.9 – 1991 HTTP/1.0 – 1996 HTTP/1.1 RFC 2068 – 1997 RFC 2616 - 1999 RFC 7230 - 2014 Esto significa que existe una variedad de servidores y clientes, los cuales pueden tener diferentes puntos de vista sobre los límites de...
goblin
libgoblin Documentazione https://docs.rs/goblin/ registro delle modifiche Utilizzo Goblin richiede rustc 1.85.0 edizione Rust 2024. Aggiungi al tuo Cargo.toml dependencies goblin = "0.10" Caratteristiche nome fantastico del crate implementazione zero-copy, cross-platform, endian-aware per ELF64/3...