606 matches found
snowflake-sqlalchemy (>=1.0.9, <=1.1.14), target-snowflake (0.0.2) potentially affected by CVE-2022-42965 via snowflake-connector-python (1.9.1)
snowflake-connector-python PYPI version 1.9.1 is affected by a known vulnerability. The following packages have a transitive dependency on snowflake-connector-python and may be impacted: - snowflake-sqlalchemy =1.0.9, =1.1.14 - target-snowflake 0.0.2 Source cves: CVE-2022-42965 Source advisory:...
apache-airflow-providers-snowflake (>=2.4.0rc1, <=2.5.1), arreyy (0.0.1) +68 more potentially affected by CVE-2022-42965 via snowflake-connector-python (>=2.0.0, <=2.8.1)
snowflake-connector-python PYPI version =2.0.0, =2.4.0rc1, =20230717.1.0, =0.1.0, =0.6.4rc0, =0.5.1, =1.0.5, =0.5.19, =0.1.1, =0.48.0, =0.15.3rc1, =0.19.1a7, =0.1.1, =0.1.4 - dbt-oracledb 0.1.0 and more Source cves: CVE-2022-42965 Source advisory: OSV:GHSA-4R6J-FWCX-94CF...
apache-airflow-providers-snowflake (>=2.4.0rc1, <=2.5.1), arreyy (0.0.1) +68 more potentially affected by CVE-2022-42965 via snowflake-connector-python (>=2.0.0, <=2.8.1)
snowflake-connector-python PYPI version =2.0.0, =2.4.0rc1, =20230717.1.0, =0.1.0, =0.6.4rc0, =0.5.1, =1.0.5, =0.5.19, =0.1.1, =0.48.0, =0.15.3rc1, =0.19.1a7, =0.1.1, =0.1.4 - dbt-oracledb 0.1.0 and more Source cves: CVE-2022-42965 Source advisory: GHSA-4R6J-FWCX-94CF...
Regular Expression Denial Of Service (ReDoS)
snowflake-connector-python is vulnerable to regular expression denial of service. The vulnerability is due to the getfiletransfertype function in cursor.py which does not properly validate the SQL queries, allowing an attacker to crash the application by providing a malicious input...
CVE-2022-42965
An exponential ReDoS Regular Expression Denial of Service can be triggered in the snowflake-connector-python PyPI package, when an attacker is able to supply arbitrary input to the undocumented getfiletransfertype method...
Design/Logic Flaw
An exponential ReDoS Regular Expression Denial of Service can be triggered in the snowflake-connector-python PyPI package, when an attacker is able to supply arbitrary input to the undocumented getfiletransfertype method...
CVE-2022-42965 Exponential ReDoS in snowflake-connector-python leads to denial of service
An exponential ReDoS Regular Expression Denial of Service can be triggered in the snowflake-connector-python PyPI package, when an attacker is able to supply arbitrary input to the undocumented getfiletransfertype method...
CVE-2022-42965 Exponential ReDoS in snowflake-connector-python leads to denial of service
An exponential ReDoS Regular Expression Denial of Service can be triggered in the snowflake-connector-python PyPI package, when an attacker is able to supply arbitrary input to the undocumented getfiletransfertype method...
CVE-2022-42965
CVE-2022-42965 affects the Python Snowflake connector (snowflake-connector-python). The vulnerability is an exponential ReDoS in the undocumented get_file_transfer_type method, allowing a network attacker to trigger a denial of service by supplying crafted input. Underlying cause: a vulnerable re...
CVE-2022-42965
An exponential ReDoS Regular Expression Denial of Service can be triggered in the snowflake-connector-python PyPI package, when an attacker is able to supply arbitrary input to the undocumented getfiletransfertype method...
CVE-2022-42965: Inefficient Regular Expression Complexity
An exponential ReDoS Regular Expression Denial of Service can be triggered in the snowflake-connector-python PyPI package, when an attacker is able to supply arbitrary input to the undocumented getfiletransfertype method...
apache-airflow-providers-snowflake (>=2.4.0rc1, <=2.5.1), arreyy (0.0.1) +69 more potentially affected by CVE-2022-42965 via snowflake-connector-python (>=1.7.11, <=2.8.1)
snowflake-connector-python PYPI version =1.7.11, =2.4.0rc1, =20230717.1.0, =0.1.0, =0.4.0rc2, =0.5.1, =1.0.5, =0.5.19, =0.1.1, =0.48.0, =0.15.3rc1, =0.19.1a7, =0.1.1, =0.1.4 - dbt-oracledb 0.1.0 and more Source cves: CVE-2022-42965 Source advisory: MEND:CVE-2022-42965...
MySQL Connectors Privilege Escalation
Vulnerability in the MySQL Connectors component of Oracle MySQL subcomponent: Connector/Python. Supported versions that are affected are 2.1.5 and earlier. Easily "exploitable" vulnerability allows low privileged attacker with logon to the infrastructure where MySQL Connectors executes to...
GHSA-V5RQ-W2XM-7G5F Improper Access Control in MySQL Connector Python
Vulnerability in the MySQL Connectors component of Oracle MySQL subcomponent: Connector/Python. Supported versions that are affected are 8.0.13 and prior and 2.1.8 and prior. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise MySQL Connector...
Improper Access Control in MySQL Connector Python
Vulnerability in the MySQL Connectors component of Oracle MySQL subcomponent: Connector/Python. Supported versions that are affected are 8.0.13 and prior and 2.1.8 and prior. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise MySQL Connector...
santoku (>=200902.10.0, <=201111.17.0) potentially affected by CVE-2019-2435 via mysql-connector-python (8.0.5)
mysql-connector-python PYPI version 8.0.5 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - santoku =200902.10.0, =201111.17.0 Source cves: CVE-2019-2435 Source advisory: GHSA-V5RQ-W2XM-7G5F...
santoku (>=200902.10.0, <=201111.17.0) potentially affected by CVE-2019-2435 via mysql-connector-python (8.0.5)
mysql-connector-python PYPI version 8.0.5 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - santoku =200902.10.0, =201111.17.0 Source cves: CVE-2019-2435 Source advisory: OSV:GHSA-V5RQ-W2XM-7G5F...
Mageia: Security Advisory (MGASA-2020-0345)
The remote host is missing an update for the SPDX-FileCopyrightText: 2022 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
Updated mysql-connector-python packages fix security vulnerability
Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise MySQL Connectors. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized creation, deletion o...
OPENSUSE-SU-2020:0430-1 Security update for python-mysql-connector-python
This update for python-mysql-connector-python fixes the following issues: python-mysql-connector-python was updated to 8.0.19 boo1122204 - CVE-2019-2435: - WL13531: Remove xplugin namespace - WL13372: DNS SRV support - WL12738: Specify TLS ciphers to be used by a client or session - BUG30270760:...