606 matches found
acedeploy (>=2.4.15, <=2.4.115), acepolicies (>=0.1.17, <=0.1.23) +106 more potentially affected by CVE-2025-24794 via snowflake-connector-python (>=2.7.12, <=3.13.0)
snowflake-connector-python PYPI version =2.7.12, =2.4.15, =0.1.17, =0.0.1.dev7, =0.1.0.dev1, =0.0.1a4.post0, =1.0.23, =0.1.3, =0.1.0, =1.13.21, =20241210.4.0, =20230717.1.0, =20240129.2.0 - clope 0.1.2 and more Source cves: CVE-2025-24794 Source advisory: OSV:GHSA-M4F6-VCJ4-W5MX...
acedeploy (>=2.4.15, <=2.4.115), acepolicies (>=0.1.17, <=0.1.23) +106 more potentially affected by CVE-2025-24794 via snowflake-connector-python (>=2.7.12, <=3.13.0)
snowflake-connector-python PYPI version =2.7.12, =2.4.15, =0.1.17, =0.0.1.dev7, =0.1.0.dev1, =0.0.1a4.post0, =1.0.23, =0.1.3, =0.1.0, =1.13.21, =20241210.4.0, =20230717.1.0, =20240129.2.0 - clope 0.1.2 and more Source cves: CVE-2025-24794 Source advisory: SNYK:PYTHON-SNOWFLAKECONNECTORPYTHON-8674...
Deserialization of Untrusted Data
Overview snowflake-connector-python is a Snowflake Connector for Python Affected versions of this package are vulnerable to Deserialization of Untrusted Data due to the insecure handling of serialization exceptions which is not supported for all exceptions. This is because The OCSP response cache...
GHSA-R2X6-CJG7-8R43 snowflake-connector-python vulnerable to insecure cache files permissions
Issue Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. On Linux systems, when temporary credential caching is enabled, the Snowflake Connector for Python will cache temporary credentials locally in a world-readable file. This vulnerability affects version...
acedeploy (>=2.4.15, <=2.4.115), acepolicies (>=0.1.17, <=0.1.23) +132 more potentially affected by CVE-2025-24795 via snowflake-connector-python (>=2.3.7, <=3.13.0)
snowflake-connector-python PYPI version =2.3.7, =2.4.15, =0.1.17, =0.0.1.dev7, =0.1.0.dev1, =0.0.1a4.post0, =2.4.0rc1, =1.0.23, =0.1.3, =0.1.0, =1.13.21, =20241210.4.0, =20230717.1.0, =20240129.2.0 and more Source cves: CVE-2025-24795 Source advisory: GHSA-R2X6-CJG7-8R43...
acedeploy (>=2.4.15, <=2.4.115), acepolicies (>=0.1.17, <=0.1.23) +132 more potentially affected by CVE-2025-24795 via snowflake-connector-python (>=2.3.7, <=3.13.0)
snowflake-connector-python PYPI version =2.3.7, =2.4.15, =0.1.17, =0.0.1.dev7, =0.1.0.dev1, =0.0.1a4.post0, =2.4.0rc1, =1.0.23, =0.1.3, =0.1.0, =1.13.21, =20241210.4.0, =20230717.1.0, =20240129.2.0 and more Source cves: CVE-2025-24795 Source advisory: OSV:GHSA-R2X6-CJG7-8R43...
acedeploy (>=2.4.15, <=2.4.115), acepolicies (>=0.1.17, <=0.1.23) +132 more potentially affected by CVE-2025-24795 via snowflake-connector-python (>=2.3.7, <=3.13.0)
snowflake-connector-python PYPI version =2.3.7, =2.4.15, =0.1.17, =0.0.1.dev7, =0.1.0.dev1, =0.0.1a4.post0, =2.4.0rc1, =1.0.23, =0.1.3, =0.1.0, =1.13.21, =20241210.4.0, =20230717.1.0, =20240129.2.0 and more Source cves: CVE-2025-24795 Source advisory: SNYK:PYTHON-SNOWFLAKECONNECTORPYTHON-8675785...
acedeploy (>=2.4.15, <=2.4.115), acepolicies (>=0.1.17, <=0.1.23) +132 more potentially affected by CVE-2025-24795 via snowflake-connector-python (>=2.3.7, <=3.13.0)
snowflake-connector-python PYPI version =2.3.7, =2.4.15, =0.1.17, =0.0.1.dev7, =0.1.0.dev1, =0.0.1a4.post0, =2.4.0rc1, =1.0.23, =0.1.3, =0.1.0, =1.13.21, =20241210.4.0, =20230717.1.0, =20240129.2.0 and more Source cves: CVE-2025-24795 Source advisory: MEND:CVE-2025-24795...
CVE-2025-24794 The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. The OCSP response cache uses pickle as the...
acedeploy (>=2.4.15, <=2.4.115), acepolicies (>=0.1.17, <=0.1.23) +106 more potentially affected by CVE-2025-24794 via snowflake-connector-python (>=2.7.12, <=3.13.0)
snowflake-connector-python PYPI version =2.7.12, =2.4.15, =0.1.17, =0.0.1.dev7, =0.1.0.dev1, =0.0.1a4.post0, =1.0.23, =0.1.3, =0.1.0, =1.13.21, =20241210.4.0, =20230717.1.0, =20240129.2.0 - clope 0.1.2 and more Source cves: CVE-2025-24794 Source advisory: MEND:CVE-2025-24794...
acedeploy (>=2.4.15, <=2.4.115), acepolicies (>=0.1.17, <=0.1.23) +139 more potentially affected by CVE-2025-24793 via snowflake-connector-python (>=2.2.5, <=3.13.0)
snowflake-connector-python PYPI version =2.2.5, =2.4.15, =0.1.17, =0.0.1.dev7, =0.1.0.dev1, =0.0.1a4.post0, =2.4.0rc1, =1.0.23, =0.1.3, =0.1.0, =1.13.21, =20241210.4.0, =20250324.2.0 and more Source cves: CVE-2025-24793 Source advisory: MEND:CVE-2025-24793...
UBUNTU-CVE-2025-21548
Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 9.1.0 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successf...
CVE-2025-21548
Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 9.1.0 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successf...
CVE-2025-21548
Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 9.1.0 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successf...
CVE-2025-21548: Uncontrolled Resource Consumption
Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 9.1.0 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Connectors. Successf...
py-mysql-connector-python -- Vulnerability in the MySQL Connectors product of Oracle MySQL
Oracle reports: Vulnerability in the MySQL Connectors product of Oracle MySQL component: Connector/Python. Supported versions that are affected are 9.1.0 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL...
openSUSE 15 Security Update : python-mysql-connector-python (openSUSE-SU-2024:0351-1)
The remote openSUSE 15 host has a package installed that is affected by a vulnerability as referenced in the openSUSE- SU-2024:0351-1 advisory. - Update to 9.1.0 boo1231740, CVE-2024-21272 - WL16452: Bundle all installable authentication plugins when building the C-extension - WL16444: Drop build...
santoku (>=200902.10.0, <=201111.17.0) potentially affected by unknown CVE via mysql-connector-python (8.0.5)
mysql-connector-python PYPI version 8.0.5 is affected by a known vulnerability. The following packages have a transitive dependency on mysql-connector-python and may be impacted: - santoku =200902.10.0, =201111.17.0 Source cves: unknown CVE Source advisory: SNYK:PYTHON-MYSQLCONNECTORPYTHON-832093...
SQL Injection
Overview mysql-connector-python is a MySQL driver written in Python which does not depend on MySQL C client libraries and implements the DB API v2.0 specification PEP-249. Affected versions of this package are vulnerable to SQL Injection due to improper sanitization of schema and table names...
Oracle MySQL Connector/Python Data Access
The vulnerability of the Connector/Python driver for MySQL Connectors in the Oracle MySQL database management system is related to insufficient validation of input data. Exploiting this vulnerability can allow an attacker to gain unauthorized access to read, add, modify, or delete data, or to cau...