606 matches found
dbt (>=0.15.3rc1, <=0.16.0b1), dbt-snowflake (>=0.15.3rc1, <=0.16.0b1) +1 more potentially affected by CVE-2026-15925 via snowflake-connector-python (2.0.4)
snowflake-connector-python PYPI version 2.0.4 is affected by a known vulnerability. The following packages have a transitive dependency on snowflake-connector-python and may be impacted: - dbt =0.15.3rc1, =0.15.3rc1, =1.0.5, =1.1.0 Source cves: CVE-2026-15925 Source advisory: OSV:PYSEC-2026-3920...
dbt-schema-builder (>=0.4.3, <=0.4.4), dbt-snowflake (>=1.0.0rc1, <=1.0.1) +2 more potentially affected by CVE-2026-15925 via snowflake-connector-python (2.7.10)
snowflake-connector-python PYPI version 2.7.10 is affected by a known vulnerability. The following packages have a transitive dependency on snowflake-connector-python and may be impacted: - dbt-schema-builder =0.4.3, =1.0.0rc1, =0.1.1, =0.2.7 - elementary-lineage 0.1.0 Source cves: CVE-2026-15925...
Insufficiently Protected Credentials
Overview snowflake-connector-python is a Snowflake Connector for Python Affected versions of this package are vulnerable to Insufficiently Protected Credentials in the WORKLOADIDENTITY authenticator through AuthByWorkloadIdentity.prepare in src/snowflake/connector/auth/workloadidentity.py. An...
ae-mcp (0.2.0), airbyte (>=0.11.0, <=0.27.0) +157 more potentially affected by CVE-2026-86600 via snowflake-connector-python (>=3.15.0, <=4.7.2)
snowflake-connector-python PYPI version =3.15.0, =0.11.0, =0.1.0, =2.0.0a3, =0.0.1, =0.1.0, =2020.5.20rc1, =1.0.0b2, =0.1.5, =0.1.1, =0.185.0, =0.260.0 and more Source cves: CVE-2026-86600 Source advisory: SNYK:PYTHON-SNOWFLAKECONNECTORPYTHON-19653600...
ae-mcp (0.2.0), airbyte (>=0.11.0, <=0.27.0) +157 more potentially affected by CVE-2026-86600 via snowflake-connector-python (>=3.15.0, <=4.7.2)
snowflake-connector-python PYPI version =3.15.0, =0.11.0, =0.1.0, =2.0.0a3, =0.0.1, =0.1.0, =2020.5.20rc1, =1.0.0b2, =0.1.5, =0.1.1, =0.185.0, =0.260.0 and more Source cves: CVE-2026-86600 Source advisory: MEND:CVE-2026-86600...
ae-mcp (0.2.0), analytics-agent-connector-snowflake (>=0.1.0, <=0.4.0) +31 more potentially affected by CVE-2026-86597 via snowflake-connector-python (>=4.0.0, <=4.7.2)
snowflake-connector-python PYPI version =4.0.0, =0.1.0, =2020.5.20rc1, =1.0.0b2, =0.185.0, =1.0.3, =1.0.0, =0.1.0, =1.10.7, =1.2.1, =2.79.1a0, =3.0.0, =3.0.1.post1 - klondike 0.3.0 and more Source cves: CVE-2026-86597 Source advisory: SNYK:PYTHON-SNOWFLAKECONNECTORPYTHON-19666491...
Insertion of Sensitive Information into Log File
Overview snowflake-connector-python is a Snowflake Connector for Python Affected versions of this package are vulnerable to Insertion of Sensitive Information into Log File via the logging process. An attacker can obtain authentication tokens, encryption keys, pre-signed URLs, and SAML assertions...
acedeploy (>=2.4.15, <=2.4.366.dev1), acepolicies (>=0.1.17, <=0.1.23) +290 more potentially affected by CVE-2026-86597 via snowflake-connector-python (>=1.7.11, <=4.7.2)
snowflake-connector-python PYPI version =1.7.11, =2.4.15, =0.1.17, =0.0.1.dev7, =0.1.0, =0.1.0.dev1, =0.0.1a4.post0, =1.0.6, =0.0.1, =0.1.0, =2020.5.20rc1, =1.0.0b2, =2.5.1 - arreyy 0.0.1 and more Source cves: CVE-2026-86597 Source advisory: MEND:CVE-2026-86597...
Improper Certificate Validation
Overview snowflake-connector-python is a Snowflake Connector for Python Affected versions of this package are vulnerable to Improper Certificate Validation in the OCSP processing functionality, which accepts an OCSP response without checking that its CertID matches the certificate being validated...
ae-mcp (0.2.0), analytics-agent-connector-snowflake (>=0.1.0, <=0.4.0) +31 more potentially affected by CVE-2026-85525 via snowflake-connector-python (>=4.0.0, <=4.7.2)
snowflake-connector-python PYPI version =4.0.0, =0.1.0, =2020.5.20rc1, =1.0.0b2, =0.185.0, =1.0.3, =1.0.0, =0.1.0, =1.10.7, =1.2.1, =2.79.1a0, =3.0.0, =3.0.1.post1 - klondike 0.3.0 and more Source cves: CVE-2026-85525 Source advisory: SNYK:PYTHON-SNOWFLAKECONNECTORPYTHON-19638983...
acedeploy (>=2.4.15, <=2.4.366.dev1), acepolicies (>=0.1.17, <=0.1.23) +290 more potentially affected by CVE-2026-85525 via snowflake-connector-python (>=1.7.11, <=4.7.2)
snowflake-connector-python PYPI version =1.7.11, =2.4.15, =0.1.17, =0.0.1.dev7, =0.1.0, =0.1.0.dev1, =0.0.1a4.post0, =1.0.6, =0.0.1, =0.1.0, =2020.5.20rc1, =1.0.0b2, =2.5.1 - arreyy 0.0.1 and more Source cves: CVE-2026-85525 Source advisory: MEND:CVE-2026-85525...
CLSA-2025-1765930332 TuxCare security update for mysql-connector-python (1 CVE)
TuxCare rebuilt mysql-connector-python to address 1 CVE. Fixed in 8.4.0.post1+tuxcare...
PT-2026-73653
TuxCare rebuilt mysql-connector-python to address 1 CVE. Fixed in 8.4.0.post1+tuxcare...
Malicious code in postgresql-connector-python (PyPI)
Source: kam193 87f55ac62324b5fc631b711e125f897d8ae10d06a9d80173463d9a5fa1915302 Installing the package or importing the module exfiltrates basic information about the host, and the package has no other purpose. --- Category: PROBABLYPENTEST - Packages looking like typical pentest packages, but al...
dagster-snowflake (>=0.4.0rc2, <=0.6.1) potentially affected by CVE-2026-15925 via snowflake-connector-python (1.7.11)
snowflake-connector-python PYPI version 1.7.11 is affected by a known vulnerability. The following packages have a transitive dependency on snowflake-connector-python and may be impacted: - dagster-snowflake =0.4.0rc2, =0.6.1 Source cves: CVE-2026-15925 Source advisory: OSV:GHSA-5CC2-282F-JJQ2...
target-snowflake (0.0.0) potentially affected by CVE-2026-15925 via snowflake-connector-python (1.8.7)
snowflake-connector-python PYPI version 1.8.7 is affected by a known vulnerability. The following packages have a transitive dependency on snowflake-connector-python and may be impacted: - target-snowflake 0.0.0 Source cves: CVE-2026-15925 Source advisory: OSV:GHSA-5CC2-282F-JJQ2...
snowflake-sqlalchemy (>=1.0.9, <=1.1.14), target-snowflake (0.0.2) potentially affected by CVE-2026-15925 via snowflake-connector-python (1.9.1)
snowflake-connector-python PYPI version 1.9.1 is affected by a known vulnerability. The following packages have a transitive dependency on snowflake-connector-python and may be impacted: - snowflake-sqlalchemy =1.0.9, =1.1.14 - target-snowflake 0.0.2 Source cves: CVE-2026-15925 Source advisory:...
kpc-nifi-utils (0.2.3) potentially affected by CVE-2026-15925 via snowflake-connector-python (2.0.0)
snowflake-connector-python PYPI version 2.0.0 is affected by a known vulnerability. The following packages have a transitive dependency on snowflake-connector-python and may be impacted: - kpc-nifi-utils 0.2.3 Source cves: CVE-2026-15925 Source advisory: OSV:GHSA-5CC2-282F-JJQ2...
dagster-snowflake (>=0.6.4rc0, <=0.6.5), data-lineage (>=0.5.1, <=0.9.0) +5 more potentially affected by CVE-2026-15925 via snowflake-connector-python (2.0.1)
snowflake-connector-python PYPI version 2.0.1 is affected by a known vulnerability. The following packages have a transitive dependency on snowflake-connector-python and may be impacted: - dagster-snowflake =0.6.4rc0, =0.5.1, =0.8.3, =1.0.7, =2.43.2, =0.16.0, =0.1.0.dev3, =0.1.2 Source cves:...
ewah (>=0.1.25, <=0.2.5), fivetran-autogen (>=0.0.1rc8, <=0.0.1rc9) +8 more potentially affected by CVE-2026-15925 via snowflake-connector-python (2.0.2)
snowflake-connector-python PYPI version 2.0.2 is affected by a known vulnerability. The following packages have a transitive dependency on snowflake-connector-python and may be impacted: - ewah =0.1.25, =0.0.1rc8, =0.0.2, =2.2.0, =0.14.1, =0.110.1, =2.0.0, =0.1.0, =0.4.11 - ploosh-core 0.1.7.1 -...