14962 matches found
PT-2023-33518 · Linux · Linux Kernel
Name of the Vulnerable Software and Affected Versions: Linux Kernel versions prior to v6.0.18 Description: The issue concerns the ext4 file system, specifically with the fast-commit of encrypted directory operations. The actual impact and attack plausibility have not yet been proven...
PT-2023-33980
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v5.15.87 Description The issue concerns the ext4 file system, specifically with the fast-commit of encrypted directory operations. The actual impact and potential for attack have not been proven yet...
PT-2023-33502 · Linux · Linux Kernel
Name of the Vulnerable Software and Affected Versions: Linux Kernel versions 6.0.16 through 6.0.18 Description: The issue is related to a lockdep splat in the bond miimon commit function. The actual impact and attack plausibility have not yet been proven. Recommendations: For Linux Kernel version...
PT-2023-33652 · Linux · Linux Kernel
Name of the Vulnerable Software and Affected Versions: Linux Kernel versions prior to v6.0.16 Description: The issue is related to the drm/amd/display component, where DRR actions are not properly disabled during state commit. The actual impact and attack plausibility have not yet been proven...
PT-2023-34364
Name of the Vulnerable Software and Affected Versions Linux Kernel versions 3.2 through 5.10.162 Description The issue is related to the dm thin feature, where the last transaction's pmd-root is used when a commit fails. This problem was introduced in version v3.2 and is fixed in version v5.10.16...
PT-2023-33562
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v6.0.18 Description The issue is related to the dm thin component, where it uses the last transaction's pmd-root when a commit fails. This problem was introduced in version v3.2 and is fixed in version v6.0.18. T...
PT-2023-33977
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v5.15.87 Description The issue is related to off-by-one errors in fast-commit block filling in the ext4 filesystem. The actual impact and attack plausibility have not yet been proven. Recommendations For Linux...
git -- Heap overflow in `git archive`, `git log --format` leading to RCE
The git team reports: git log has the ability to display commits using an arbitrary format with its --format specifiers. This functionality is also exposed to git archive via the export-subst gitattribute. When processing the padding operators e.g., %, %, or % , an integer overflow can occur in...
PT-2023-1321
Name of the Vulnerable Software and Affected Versions Git versions prior to 2.30.7 Description The issue is related to an integer overflow in the pretty.c::format and pad commit function of the Git distributed revision control system. This overflow can result in arbitrary heap writes, potentially...
PT-2023-34340
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v5.10.163 Description The issue concerns leaking uninitialized memory in the fast-commit journal of the ext4 file system. The actual impact and attack plausibility have not yet been proven. Recommendations For...
PT-2023-33411
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v4.19.268 Description A NULL pointer dereference issue exists in the nilfs palloc commit free entry function. The actual impact and attack plausibility have not yet been proven. Recommendations For Linux Kernel...
PT-2023-34341 · Linux · Linux Kernel
Name of the Vulnerable Software and Affected Versions: Linux Kernel versions prior to v5.10.163 Description: The issue concerns the ext4 file system, specifically with fast-commit of encrypted directory operations. It was introduced in version v5.10 and fixed in version v5.10.163. The actual impa...
CVE-2023-22493 RSSHub is vulnerable to SSRF (Server-Side Request Forgery)
RSSHub is an open source RSS feed generator. RSSHub is vulnerable to Server-Side Request Forgery SSRF attacks. This vulnerability allows an attacker to send arbitrary HTTP requests from the server to other servers or resources on the network. An attacker can exploit this vulnerability by sending ...
Fixed in Apache Tomcat 9.0.71
Important: Apache Tomcat denial of service CVE-2023-24998 Apache Tomcat uses a packaged renamed copy of Apache Commons FileUpload to provide the file upload functionality defined in the Jakarta Servlet specification. Apache Tomcat was, therefore, also vulnerable to the Apache Commons FileUpload...
jenkins-plugin: Cross-site Request Forgery (CSRF) in org.jenkins-ci.plugins:git
A flaw was found in the Git Jenkins plugin. The affected versions of the Git Jenkins Plugin allow attackers to trigger the builds of jobs configured to use an attacker-specified Git repository and to cause them to check out an attacker-specified commit...
GitHub: Rogue collaborators and ambiguous branch names in GitHub
An incorrect comparison vulnerability was identified in GitHub Enterprise Server that allowed commit smuggling. This affected all versions prior to 3.9 and was fixed in later versions...
CVE-2022-23509
Weave GitOps is a simple open source developer platform for people who want cloud native applications, without needing Kubernetes expertise. GitOps run has a local S3 bucket which it uses for synchronizing files that are later applied against a Kubernetes cluster. The communication between GitOps...
CVE-2022-23508 GitOps Run allows for Kubernetes workload injection
Weave GitOps is a simple open source developer platform for people who want cloud native applications, without needing Kubernetes expertise. A vulnerability in GitOps run could allow a local user or process to alter a Kubernetes cluster's resources. GitOps run has a local S3 bucket which it uses...
CVE-2022-2196
A regression exists in the Linux Kernel within KVM: nVMX that allowed for speculative execution attacks. L2 can carry out Spectre v2 attacks on L1 due to L1 thinking it doesn't need retpolines or IBPB after running L2 due to KVM L0 advertising eIBRS support to L1. An attacker at L2 with code...
CVE-2022-2196
A regression exists in the Linux Kernel within KVM: nVMX that allowed for speculative execution attacks. L2 can carry out Spectre v2 attacks on L1 due to L1 thinking it doesn't need retpolines or IBPB after running L2 due to KVM L0 advertising eIBRS support to L1. An attacker at L2 with code...