108 matches found
biz.neustar.jenkins.plugins:packer (>=1.3, <=1.4), com.amazonaws:codedeploy (1.12) +30 more potentially affected by CVE-2018-1000195 via org.jenkins-ci.main:jenkins-core (1.554.1)
org.jenkins-ci.main:jenkins-core MAVEN version 1.554.1 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - biz.neustar.jenkins.plugins:packer =1.3, =1.12.0-alpha-1, =1.46, =4.7, =1.0.0, =2.9.9, =1.10,...
com.amazonaws:codedeploy (>=1.17, <=1.23), hudson.plugins.octopusdeploy:octopusdeploy (>=1.3.0, <=1.4.0) +6 more potentially affected by CVE-2018-6356 via org.jenkins-ci.main:jenkins-core (1.612)
org.jenkins-ci.main:jenkins-core MAVEN version 1.612 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.amazonaws:codedeploy =1.17, =1.3.0, =2.7.0, =1.0, =1.4 -...
com.amazonaws:codedeploy (>=1.17, <=1.23), hudson.plugins.octopusdeploy:octopusdeploy (>=1.3.0, <=1.4.0) +6 more potentially affected by CVE-2019-1003049 via org.jenkins-ci.main:jenkins-core (1.612)
org.jenkins-ci.main:jenkins-core MAVEN version 1.612 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.amazonaws:codedeploy =1.17, =1.3.0, =2.7.0, =1.0, =1.4 -...
com.amazonaws:codedeploy (>=1.17, <=1.23), hudson.plugins.octopusdeploy:octopusdeploy (>=1.3.0, <=1.4.0) +6 more potentially affected by CVE-2018-1999005 via org.jenkins-ci.main:jenkins-core (1.612)
org.jenkins-ci.main:jenkins-core MAVEN version 1.612 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.amazonaws:codedeploy =1.17, =1.3.0, =2.7.0, =1.0, =1.4 -...
com.amazonaws:codedeploy (>=1.17, <=1.23), hudson.plugins.octopusdeploy:octopusdeploy (>=1.3.0, <=1.4.0) +6 more potentially affected by CVE-2018-1000195 via org.jenkins-ci.main:jenkins-core (1.612)
org.jenkins-ci.main:jenkins-core MAVEN version 1.612 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.amazonaws:codedeploy =1.17, =1.3.0, =2.7.0, =1.0, =1.4 -...
com.amazonaws:codedeploy (>=1.3, <=1.11), com.sonyericsson.hudson.plugins.multi-slave-config-plugin:multi-slave-config-plugin (>=1.1.0, <=1.2.0) +18 more potentially affected by CVE-2018-1999003 via org.jenkins-ci.main:jenkins-core (1.554)
org.jenkins-ci.main:jenkins-core MAVEN version 1.554 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - com.amazonaws:codedeploy =1.3, =1.1.0, =1.2.3, =1.1.0, =1.0, =1.0, =1.0, =2.0.4, =1.10, =1.15,...
Malicious Package
Overview awscodedeploy-agent is a malicious package. Affected versions of this package were found to be a Malicious Package, as it utilised typosquatting to run Malicious 3rd party scripts. It replaced genuine packages using an and replaced it with - and vice versa Remediation Avoid using...
CloudBees Jenkins AWS CodeDeploy Plugin Information Disclosure Vulnerability
CloudBees Jenkins is a set of Java-based continuous integration tools , it is mainly used to monitor the continuous software version of the release/testing project and some of the timed execution of the task . AWS CodeDeploy Plugin is used in one of the deployment components . An information...
CloudBees Jenkins AWS CodeDeploy Plugin Information Disclosure Vulnerability
CloudBees Jenkins is a set of Java-based continuous integration tools , it is mainly used to monitor the continuous software version of the release/testing project and some of the timed execution of the task . AWS CodeDeploy Plugin is used in one of the deployment components . An information...
CVE-2018-1000402
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a File and Directory Information Exposure vulnerability in AWSCodeDeployPublisher.java that can result in Disclosure of environment variables. This vulnerability appears to have been fixed in 1.20 and later...
CVE-2018-1000403
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodeDeployPublisher.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to...
Information disclosure
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a File and Directory Information Exposure vulnerability in AWSCodeDeployPublisher.java that can result in Disclosure of environment variables. This vulnerability appears to have been fixed in 1.20 and later...
Design/Logic Flaw
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodeDeployPublisher.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to...
CVE-2018-1000403
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodeDeployPublisher.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to...
CVE-2018-1000402
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a File and Directory Information Exposure vulnerability in AWSCodeDeployPublisher.java that can result in Disclosure of environment variables. This vulnerability appears to have been fixed in 1.20 and later...
CVE-2018-1000402
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a File and Directory Information Exposure vulnerability in AWSCodeDeployPublisher.java that can result in Disclosure of environment variables. This vulnerability appears to have been fixed in 1.20 and later...
CVE-2018-1000403
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodeDeployPublisher.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to...
CVE-2018-1000403
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a Insufficiently Protected Credentials vulnerability in AWSCodeDeployPublisher.java that can result in Credentials Disclosure. This attack appear to be exploitable via local file access. This vulnerability appears to...
CVE-2018-1000402
Jenkins project Jenkins AWS CodeDeploy Plugin version 1.19 and earlier contains a File and Directory Information Exposure vulnerability in AWSCodeDeployPublisher.java that can result in Disclosure of environment variables. This vulnerability appears to have been fixed in 1.20 and later...
CVE-2018-1000403
Summary: Jenkins AWS CodeDeploy Plugin (Jenkins) versions ≤ 1.19 contain an Insufficiently Protected Credentials vulnerability in AWSCodeDeployPublisher.java, enabling partial credentials disclosure via local file access. The issue arises from credentials handling within the plugin, per CVE-2018-...