Lucene search
+L

17 matches found

Positive Technologies
Positive Technologies
•added 2024/10/30 12:00 a.m.•23 views

PT-2024-30544 · Snowflake · Snowflake Jdbc Driver

Name of the Vulnerable Software and Affected Versions: Snowflake JDBC driver versions = 3.2.6 and = 3.2.6 and = 3.19.1, upgrade to version 3.20.0 or later as soon as possible to fix the incorrect security setting. As a temporary workaround, consider avoiding the use of the CLIENT ENCRYPTION KEY...

7.4CVSS7.4AI score0.00176EPSS
SaveExploits0References6
CNNVD
CNNVD
•added 2023/10/19 12:00 a.m.•23 views

Texas Instruments OMAP L138 Security Vulnerability

The Texas Instruments OMAP L138 is a DSP+ARM industrial processor from Texas Instruments. A security vulnerability exists in the Texas Instruments OMAP L138 secure variants, which stems from the ES implementation being susceptible to a timing side-channel, which can be exploited by an attacker to...

4.4CVSS6.4AI score0.00104EPSS
SaveExploits0References2
Github Security Blog
Github Security Blog
•added 2021/04/12 6:51 p.m.•73 views

mongodb-client-encryption vulnerable to Improper Certificate Validation

A specific version of the Node.js mongodb-client-encryption module does not perform correct validation of the KMS server’s certificate. This vulnerability in combination with a privileged network position active MITM attack could result in interception of traffic between the Node.js driver and th...

6.8CVSS6.2AI score0.00202EPSS
SaveExploits0References5Affected Software1
osv_ghsa
osv_ghsa
•added 2021/04/12 6:51 p.m.•46 views

GHSA-RJMF-P882-645M mongodb-client-encryption vulnerable to Improper Certificate Validation

A specific version of the Node.js mongodb-client-encryption module does not perform correct validation of the KMS server’s certificate. This vulnerability in combination with a privileged network position active MITM attack could result in interception of traffic between the Node.js driver and th...

6.8CVSS6.4AI score0.00202EPSS
SaveExploits0References5
nodejs
nodejs
•added 2021/04/12 6:50 p.m.•85 views

Improper Certificate Validation

Overview Version 1.2.0 of mongodb-client-encryption does not perform correct validation of the KMS server’s certificate. This vulnerability in combination with a privileged network position active MITM attack could result in interception of traffic between the Node.js driver and the KMS service...

4.3CVSS3.8AI score0.00202EPSS
SaveExploits0
Veracode
Veracode
•added 2021/02/26 7:00 a.m.•28 views

Man-in-the-Middle (MitM)

mongodb-client-encryption is vulnerable to man-in-the-middle attacks. The module does not perform correct validation of the KMS servers certificate and would potentially allow for man-in-the-middle attackers to intercept and modify network traffic...

6.8CVSS6.4AI score0.00202EPSS
SaveExploits0References2Affected Software1
NVD
NVD
•added 2021/02/25 5:15 p.m.•32 views

CVE-2021-20327

A specific version of the Node.js mongodb-client-encryption module does not perform correct validation of the KMS server’s certificate. This vulnerability in combination with a privileged network position active MITM attack could result in interception of traffic between the Node.js driver and th...

6.8CVSS0.00202EPSS
SaveExploits0References1
osv_cve
osv_cve
•added 2021/02/25 5:15 p.m.•46 views

CVE-2021-20327

A specific version of the Node.js mongodb-client-encryption module does not perform correct validation of the KMS server’s certificate. This vulnerability in combination with a privileged network position active MITM attack could result in interception of traffic between the Node.js driver and th...

6.8CVSS6.4AI score0.00202EPSS
SaveExploits0References1
CVE
CVE
•added 2021/02/25 4:25 p.m.•117 views

CVE-2021-20327

CVE-2021-20327 affects the Node.js mongodb-client-encryption library, specifically version 1.2.0, which does not perform proper validation of the KMS server certificate. This can enable an attacker with privileged network access to perform a MITM and intercept traffic between the Node.js driver a...

6.8CVSS6.2AI score0.00202EPSS
SaveExploits0References1Affected Software1
Mend
Mend
•added 2021/02/25 4:25 p.m.•9 views

CVE-2021-20327

A specific version of the Node.js mongodb-client-encryption module does not perform correct validation of the KMS server’s certificate. This vulnerability in combination with a privileged network position active MITM attack could result in interception of traffic between the Node.js driver and th...

7.4CVSS0.00202EPSS
SaveExploits0References5
attackerkb
attackerkb
•added 2021/02/25 2:51 p.m.•11 views

CVE-2021-20327

A specific version of the Node.js mongodb-client-encryption module does not perform correct validation of the KMS server’s certificate. This vulnerability in combination with a privileged network position active MITM attack could result in interception of traffic between the Node.js driver and th...

6.8CVSS6.6AI score0.00202EPSS
SaveExploits0References2Affected Software1
Positive Technologies
Positive Technologies
•added 2021/02/25 12:00 a.m.•16 views

PT-2021-13886

Name of the Vulnerable Software and Affected Versions: mongodb-client-encryption module version 1.2.0 Description: The issue arises from the mongodb-client-encryption module's failure to correctly validate the KMS server's certificate. This could allow an attacker with a privileged network positi...

6.8CVSS6.9AI score0.00202EPSS
SaveExploits0References11
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2021/02/25 12:00 a.m.•8 views

CVE-2021-20327: Improper Certificate Validation

A specific version of the Node.js mongodb-client-encryption module does not perform correct validation of the KMS server’s certificate. This vulnerability in combination with a privileged network position active MITM attack could result in interception of traffic between the Node.js driver and th...

6.8CVSS5.8AI score0.00202EPSS
SaveExploits0References4
MongoDB
MongoDB
•added 2021/02/25 12:00 a.m.•88 views

MongoDB Node.js client side field level encryption library may not be validating KMS certificate

A specific version of the Node.js mongodb-client-encryption module does not perform correct validation of the KMS server’s certificate. This vulnerability in combination with a privileged network position active MITM attack could result in interception of traffic between the Node.js driver and th...

6.8CVSS6.2AI score0.00202EPSS
SaveExploits0References1Affected Software1
Prion
Prion
•added 2017/07/31 2:29 p.m.•34 views

Heap overflow

Heap-based buffer overflow in Actian Pervasive PSQL v12.10 and Zen v13 allows remote attackers to execute arbitrary code via crafted traffic to TCP port 1583. The overflow occurs after Server-Client encryption-key exchange. The issue results from an integer underflow that leads to a zero-byte...

7.5CVSS9.7AI score0.02494EPSS
SaveExploits1References3Affected Software2
RedHat Linux
RedHat Linux
•added 2016/01/08 1:39 a.m.•37 views

samba: client requesting encryption vulnerable to downgrade attack

A man-in-the-middle vulnerability was found in the way "connection signing" was implemented by Samba. A remote attacker could use this flaw to downgrade an existing Samba client connection and force the use of plain text...

5.4CVSS6.7AI score0.07263EPSS
SaveExploits0References5
CERT
CERT
•added 2002/02/11 12:00 a.m.•24 views

KTH Kerberos Telnet implementations do not strictly enforce client encryption request

Overview A vulnerability exists in the KTH Kerberos IV and Kerberos V Heimdal Telnet implementations. When a KTH Kerberos Telnet client requests data encryption and the server does not appear to support it, the client will establish the connection using no encryption. A properly located attacker...

7AI score
SaveExploits0References3
Rows per page
Query Builder