17823 matches found
[SECURITY] Fedora 41 Update: cri-tools1.29-1.29.0-11.fc41
CLI and validation tools for Kubelet Container Runtime Interface CRI...
AWS SAM CLI < 1.133.0 multiple vulnerabilities
The version of AWS SAM CLI installed on the remote host is prior to 1.133.0 and is, therefore, affected by multiple vulnerabilities: - When running the AWS SAM CLI build process with Docker and symlinks are included in the build files, the container environment allows a user to access privileged...
AWS SAM CLI Installed (Windows)
Binary data awssamcliwindetect.nbin...
CVE-2025-3047
When running the AWS Serverless Application Model Command Line Interface SAM CLI build process with Docker and symlinks are included in the build files, the container environment allows a user to access privileged files on the host by leveraging the elevated permissions granted to the tool. A use...
CVE-2025-3048
After completing a build with AWS Serverless Application Model Command Line Interface SAM CLI which include symlinks, the content of those symlinks are copied to the cache of the local workspace as regular files or directories. As a result, a user who does not have access to those symlinks outsid...
org.jenkins-ci.main:jenkins-test-harness (1.419), org.jenkins-ci.main:jenkins-war (1.419) +4 more potentially affected by CVE-2025-31721 via org.jenkins-ci.main:jenkins-core (1.419)
org.jenkins-ci.main:jenkins-core MAVEN version 1.419 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - org.jenkins-ci.main:jenkins-test-harness 1.419 - org.jenkins-ci.main:jenkins-war 1.419 -...
org.jenkins-ci.main:jenkins-test-harness (1.419), org.jenkins-ci.main:jenkins-war (1.419) +4 more potentially affected by CVE-2025-31720 via org.jenkins-ci.main:jenkins-core (1.419)
org.jenkins-ci.main:jenkins-core MAVEN version 1.419 is affected by a known vulnerability. The following packages have a transitive dependency on org.jenkins-ci.main:jenkins-core and may be impacted: - org.jenkins-ci.main:jenkins-test-harness 1.419 - org.jenkins-ci.main:jenkins-war 1.419 -...
better-lambda-deploy (>=0.7.0, <=0.8.5), localambda (0.0.1) potentially affected by CVE-2025-3048 via aws-sam-cli (>=1.12.0, <=1.38.1)
aws-sam-cli PYPI version =1.12.0, =0.7.0, =0.8.5 - localambda 0.0.1 Source cves: CVE-2025-3048 Source advisory: GHSA-PP64-WJ43-XQCR...
tc-sam-cli (0.0.12) potentially affected by CVE-2025-3048 via aws-sam-cli (0.37.0)
aws-sam-cli PYPI version 0.37.0 is affected by a known vulnerability. The following packages have a transitive dependency on aws-sam-cli and may be impacted: - tc-sam-cli 0.0.12 Source cves: CVE-2025-3048 Source advisory: OSV:GHSA-PP64-WJ43-XQCR...
tc-sam-cli (0.0.11) potentially affected by CVE-2025-3048 via aws-sam-cli (0.22.0)
aws-sam-cli PYPI version 0.22.0 is affected by a known vulnerability. The following packages have a transitive dependency on aws-sam-cli and may be impacted: - tc-sam-cli 0.0.11 Source cves: CVE-2025-3048 Source advisory: OSV:GHSA-PP64-WJ43-XQCR...
better-lambda-deploy (>=0.2.2, <=0.5.9) potentially affected by CVE-2025-3048 via aws-sam-cli (0.41.0)
aws-sam-cli PYPI version 0.41.0 is affected by a known vulnerability. The following packages have a transitive dependency on aws-sam-cli and may be impacted: - better-lambda-deploy =0.2.2, =0.5.9 Source cves: CVE-2025-3048 Source advisory: OSV:GHSA-PP64-WJ43-XQCR...
AWS SAM CLI Path Traversal allows file copy to local cache
Summary The AWS Serverless Application Model Command Line Interface AWS SAM CLI is an open-source CLI tool that helps Lambda developers to build and develop Lambda applications locally on their computers using Docker. After completing a build with AWS SAM CLI which include symlinks, the content o...
better-lambda-deploy (>=0.7.0, <=0.8.5), localambda (0.0.1) potentially affected by CVE-2025-3048 via aws-sam-cli (>=1.12.0, <=1.38.1)
aws-sam-cli PYPI version =1.12.0, =0.7.0, =0.8.5 - localambda 0.0.1 Source cves: CVE-2025-3048 Source advisory: SNYK:PYTHON-AWSSAMCLI-9576384...
Directory Traversal
Overview aws-sam-cli is an AWS SAM CLI is a CLI tool for local development and testing of Serverless applications Affected versions of this package are vulnerable to Directory Traversal through the symlink handling process. After completing a build, the content of those symlinks is copied to the...
GHSA-PP64-WJ43-XQCR AWS SAM CLI Path Traversal allows file copy to local cache
Summary The AWS Serverless Application Model Command Line Interface AWS SAM CLI is an open-source CLI tool that helps Lambda developers to build and develop Lambda applications locally on their computers using Docker. After completing a build with AWS SAM CLI which include symlinks, the content o...
better-lambda-deploy (>=0.7.0, <=0.8.5), localambda (0.0.1) potentially affected by CVE-2025-3048 via aws-sam-cli (>=1.12.0, <=1.38.1)
aws-sam-cli PYPI version =1.12.0, =0.7.0, =0.8.5 - localambda 0.0.1 Source cves: CVE-2025-3048 Source advisory: OSV:GHSA-PP64-WJ43-XQCR...
better-lambda-deploy (>=0.0.4, <=0.2.1) potentially affected by CVE-2025-3048 via aws-sam-cli (0.40.0)
aws-sam-cli PYPI version 0.40.0 is affected by a known vulnerability. The following packages have a transitive dependency on aws-sam-cli and may be impacted: - better-lambda-deploy =0.0.4, =0.2.1 Source cves: CVE-2025-3048 Source advisory: OSV:GHSA-PP64-WJ43-XQCR...
better-lambda-deploy (>=0.6.0, <=0.6.9) potentially affected by CVE-2025-3048 via aws-sam-cli (0.53.0)
aws-sam-cli PYPI version 0.53.0 is affected by a known vulnerability. The following packages have a transitive dependency on aws-sam-cli and may be impacted: - better-lambda-deploy =0.6.0, =0.6.9 Source cves: CVE-2025-3048 Source advisory: OSV:GHSA-PP64-WJ43-XQCR...
tc-sam-cli (>=0.0.7, <=0.0.10) potentially affected by CVE-2025-3048 via aws-sam-cli (0.17.0)
aws-sam-cli PYPI version 0.17.0 is affected by a known vulnerability. The following packages have a transitive dependency on aws-sam-cli and may be impacted: - tc-sam-cli =0.0.7, =0.0.10 Source cves: CVE-2025-3048 Source advisory: OSV:GHSA-PP64-WJ43-XQCR...
better-lambda-deploy (>=0.0.4, <=0.2.1) potentially affected by CVE-2025-3047 via aws-sam-cli (0.40.0)
aws-sam-cli PYPI version 0.40.0 is affected by a known vulnerability. The following packages have a transitive dependency on aws-sam-cli and may be impacted: - better-lambda-deploy =0.0.4, =0.2.1 Source cves: CVE-2025-3047 Source advisory: OSV:GHSA-PX37-JPQX-97Q9...