8952 matches found
CVE-2023-27970
CVE-2023-27970 refers to an out-of-bounds write in Apple software that could allow an app to execute arbitrary code with kernel privileges. The available connected data specifies the vulnerability as fixed in iOS 16.4 and iPadOS 16.4, with Apple stating that improved bounds checking addresses the...
CVE-2023-23528
An out-of-bounds read was addressed with improved bounds checking. This issue is fixed in tvOS 16.4, iOS 16.4 and iPadOS 16.4. Processing a maliciously crafted Bluetooth packet may result in disclosure of process memory...
CVE-2023-23494
A buffer overflow was addressed with improved bounds checking. This issue is fixed in iOS 16.4 and iPadOS 16.4. A user in a privileged network position may be able to cause a denial-of-service...
CVE-2023-27946
CVE-2023-27946 describes an out-of-bounds read fixed by Apple in macOS Ventura 13.3, iOS 15.7.4, iPadOS 15.7.4, macOS Monterey 12.6.4, and macOS Big Sur 11.7.5. The issue could cause unexpected termination or arbitrary code execution when processing a maliciously crafted file. Affected components...
CVE-2023-27955: Buffer Copy without Checking Size of Input
The issue was addressed with improved checks. This issue is fixed in macOS Ventura 13.3, iOS 16.4 and iPadOS 16.4, macOS Monterey 12.6.4, tvOS 16.4, macOS Big Sur 11.7.5. An app may be able to read arbitrary files...
Huawei HarmonyOS security vulnerabilities
Huawei HarmonyOS is an operating system from Huawei China. It provides a full-scenario distributed operating system based on a microkernel. A security vulnerability exists in Huawei HarmonyOS, which stems from the presence of an improper privilege checking vulnerability. Successful exploitation o...
Oracle Linux 6 : openssl (ELSA-2023-12326)
The remote Oracle Linux 6 host has packages installed that are affected by a vulnerability as referenced in the ELSA-2023-12326 advisory. 1.0.1e-59.0.4 - Backport fixes for CVE-2023-0286 Orabug: 35212597 Tenable has extracted the preceding description block directly from the Oracle Linux security...
ShapeShift KeepKey buffer error vulnerability
ShapeShift KeepKey is an e-wallet device for cryptocurrency storage. A security vulnerability exists in ShapeShift KeepKey versions prior to 7.7.0 that stems from insufficient length checking, allowing an attacker to extract the BIP39 mnemonic from a hardware wallet via a crafted message that...
How to Diagnose IP Conflicts on the ADC
To check if any ADC IP address have IP conflict...
RHEL 9 : edk2 (RHSA-2023:2022)
The remote Redhat Enterprise Linux 9 host has packages installed that are affected by a vulnerability as referenced in the RHSA-2023:2022 advisory. EDK Embedded Development Kit is a project to enable UEFI support for Virtual Machines. This package contains a sample 64-bit UEFI firmware for QEMU a...
SUSE SLES12: libjavascriptcoregtk-4_0-18 / libwebkit2gtk-4_0-37 / etc (SUSE-SU-2023:2056-1)
The remote SUSE Linux SLES12 / SLESSAP12 host has packages installed that are affected by multiple vulnerabilities as referenced in the SUSE-SU-2023:2056-1 advisory. Update to version 2.38.6 bsc1210731: - CVE-2022-0108: Fixed information leak. - CVE-2022-32885: Fixed arbitrary code execution. -...
Remote Code Execution (RCE)
broccoli-compass is vulnerable to Remote Code Execution RCE. Lack of proper checking of attacker-controlled filenames which is included in the list of files passed to the library via its files option, allows an attacker to execute malicious code on the system...
Tenda AC15 sub_8EE8 function buffer overflow vulnerability
The Tenda AC15 is a wireless router from the Chinese company Tenda. A buffer overflow vulnerability exists in the Tenda AC15 sub8EE8 function due to incorrect boundary checking in the sub8EE8 function. An authenticated, remote attacker could exploit this vulnerability to cause a buffer overflow a...
CVE-2023-22665
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query...
Design/Logic Flaw
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query...
CVE-2023-22665
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query...
CVE-2023-22665 Apache Jena: Exposure of arbitrary execution in script engine expressions.
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query...
CVE-2023-22665
There is insufficient checking of user queries in Apache Jena versions 4.7.0 and earlier, when invoking custom scripts. It allows a remote user to execute arbitrary javascript via a SPARQL query...
PT-2023-2986 · Oracle · Mysql Server
Name of the Vulnerable Software and Affected Versions: EaseProbe versions prior to 2.1.0 Description: The issue is related to an SQL injection problem in EaseProbe when using MySQL/PostgreSQL data checking. This occurs due to a lack of protection measures for the SQL query structure, allowing an...
Oracle Linux 6 : openssl (ELSA-2023-12297)
The remote Oracle Linux 6 host has packages installed that are affected by a vulnerability as referenced in the ELSA-2023-12297 advisory. - Backport fixes for CVE-2023-0286 Orabug: 35212597 - Fix possible infinite loop in BNmodsqrt CVE-2022-0778Orabug: 33969800 - Backport fixes for CVE-2020-1971...