1623 matches found
WordPress plugin Kognetiks Chatbot has a security vulnerability
WordPress and WordPress plugin are both products of the WordPress Foundation.WordPress is a blogging platform developed using the PHP language. The platform supports setting up personal blog sites on servers with PHP and MySQL.WordPress plugin is an application plugin. A security vulnerability...
WordPress Kognetiks Chatbot for WordPress Plugin <= 2.1.7 is vulnerable to Broken Access Control
Software Kognetiks Chatbot for WordPress Type Plugin Vulnerable versions = 2.1.7 Fixed in 2.1.8 OWASP Top 10 A5: Broken Access Control Classification Broken Access Control CVE CVE-2024-10529 Patch priority Low CVSS severity Low 5.4 Developer Claim ownership PSID e735c38414b8 Credits Tieu Pham Tro...
WordPress Kognetiks Chatbot for WordPress Plugin <= 2.1.7 is vulnerable to Broken Access Control
Software Kognetiks Chatbot for WordPress Type Plugin Vulnerable versions = 2.1.7 Fixed in 2.1.8 OWASP Top 10 A5: Broken Access Control Classification Broken Access Control CVE CVE-2024-10530 Patch priority Low CVSS severity Low 4.3 Developer Claim ownership PSID 918318d433d6 Credits Tieu Pham Tro...
CVE-2024-10529: Missing Authorization
The Kognetiks Chatbot for WordPress plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the deleteassistant function in all versions up to, and including, 2.1.7. This makes it possible for authenticated attackers, with subscriber-level acce...
CVE-2024-10530: Missing Authorization
The Kognetiks Chatbot for WordPress plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the addnewassistant function in all versions up to, and including, 2.1.7. This makes it possible for authenticated attackers, with subscriber-level acce...
CVE-2024-10531: Missing Authorization
The Kognetiks Chatbot for WordPress plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the updateassistant function in all versions up to, and including, 2.1.7. This makes it possible for authenticated attackers, with subscriber-level acce...
CVE-2024-10684: Improper Neutralization of Input During Web Page Generation
The Kognetiks Chatbot for WordPress plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'dir' parameter in all versions up to, and including, 2.1.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject...
CVE-2024-11143: Cross-Site Request Forgery (CSRF)
The Kognetiks Chatbot for WordPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.1.8. This is due to missing or incorrect nonce validation on the updateassistant, addnewassistant, and deleteassistant functions. This makes it possible for...
WordPress plugin Kognetiks Chatbot has a cross-site scripting vulnerability
WordPress and WordPress plugin are both products of the WordPress Foundation.WordPress is a blogging platform developed using the PHP language. The platform supports personal blog sites on servers running PHP and MySQL.WordPress plugin is an application plugin. A cross-site scripting vulnerabilit...
WordPress plugin Kognetiks Chatbot has a cross-site request forgeing vulnerability
WordPress and WordPress plugin are both products of the WordPress Foundation.WordPress is a blogging platform developed using the PHP language. The platform supports setting up personal blog sites on servers with PHP and MySQL.WordPress plugin is an application plugin. A cross-site request forger...
WordPress plugin Kognetiks Chatbot has a security vulnerability
WordPress and WordPress plugin are both products of the WordPress Foundation.WordPress is a blogging platform developed using the PHP language. The platform supports setting up personal blog sites on servers with PHP and MySQL.WordPress plugin is an application plugin. A security vulnerability...
WordPress plugin Kognetiks Chatbot has a security vulnerability
WordPress and WordPress plugin are both products of the WordPress Foundation.WordPress is a blogging platform developed using the PHP language. The platform supports setting up personal blog sites on servers with PHP and MySQL.WordPress plugin is an application plugin. A security vulnerability...
PT-2024-16785
Name of the Vulnerable Software and Affected Versions Kognetiks Chatbot for WordPress plugin versions up to, and including, 2.1.8 Description The issue is related to Cross-Site Request Forgery CSRF due to missing or incorrect nonce validation on the update assistant, add new assistant, and delete...
WordPress Kognetiks Chatbot for WordPress Plugin <= 2.1.8 is vulnerable to Cross Site Request Forgery (CSRF)
Software Kognetiks Chatbot for WordPress Type Plugin Vulnerable versions = 2.1.8 Fixed in 2.1.9 OWASP Top 10 A5: Broken Access Control Classification Cross Site Request Forgery CSRF CVE CVE-2024-11143 Patch priority Low CVSS severity Low 4.3 Developer Claim ownership PSID d37ea7308959 Credits Tie...
WordPress Kognetiks Chatbot for WordPress plugin <= 2.1.7 - Reflected Cross-Site Scripting vulnerability
Reflected Cross-Site Scripting vulnerability discovered by Le Ngoc Anh in WordPress Plugin Kognetiks Chatbot for WordPress versions = 2.1.7...
WordPress Kognetiks Chatbot for WordPress plugin <= 2.1.7 - Missing Authorization to Authenticated (Subscriber+) Assistant Update vulnerability
Missing Authorization to Authenticated Subscriber+ Assistant Update vulnerability discovered by Tieu Pham Trong Nhan in WordPress Plugin Kognetiks Chatbot for WordPress versions = 2.1.7...
PT-2024-16348 · WordPress · Kognetiks Chatbot
Name of the Vulnerable Software and Affected Versions: Kognetiks Chatbot for WordPress plugin for WordPress versions up to, and including, 2.1.7 Description: The issue is related to unauthorized modification of data due to a missing capability check on the update assistant function. This allows...
PT-2024-16459
Name of the Vulnerable Software and Affected Versions Kognetiks Chatbot for WordPress plugin versions up to, and including, 2.1.7 Description The Kognetiks Chatbot for WordPress plugin is vulnerable to Reflected Cross-Site Scripting via the dir parameter due to insufficient input sanitization and...
WordPress Kognetiks Chatbot for WordPress Plugin <= 2.1.7 is vulnerable to Cross Site Scripting (XSS)
Software Kognetiks Chatbot for WordPress Type Plugin Vulnerable versions = 2.1.7 Fixed in 2.1.8 OWASP Top 10 A7: Cross-Site Scripting XSS Classification Cross Site Scripting XSS CVE CVE-2024-10684 Patch priority Medium CVSS severity Medium 7.1 Developer Claim ownership PSID e89537076c29 Credits L...
PT-2024-16345 · Kognetiks · Kognetiks Chatbot For Wordpress
Name of the Vulnerable Software and Affected Versions: Kognetiks Chatbot for WordPress plugin versions up to, and including, 2.1.7 Description: The Kognetiks Chatbot for WordPress plugin is vulnerable to unauthorized modification of data due to a missing capability check on the delete assistant...