Lucene search
+L

10 matches found

PyPA
PyPA
•added 2026/07/07 11:45 a.m.•35 views

Apache Superset Cross-site Scripting vulnerability

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint.This issue affects Apache Supers...

5.4CVSS5.8AI score0.01004EPSS
SaveExploits0References7Affected Software1
osv_pysec
osv_pysec
•added 2026/07/07 11:45 a.m.•31 views

PYSEC-2026-1190 Apache Superset Cross-site Scripting vulnerability

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache...

4.3CVSS5.7AI score0.01004EPSS
SaveExploits0References7
osv_bit
osv_bit
•added 2025/08/18 8:13 a.m.•17 views

BIT-SUPERSET-2025-55672 Apache Superset: Stored XSS on charts metadata

A stored Cross-Site Scripting XSS vulnerability exists in Apache Superset's chart visualization. An authenticated user with permissions to edit charts can inject a malicious payload into a column's label. The payload is not properly sanitized and gets executed in the victim's browser when they...

5.4CVSS6AI score0.00742EPSS
SaveExploits0References3
osv_suse
osv_suse
•added 2025/04/22 2:08 p.m.•20 views

SUSE-SU-2025:20196-1 Security update for helm

This update for helm fixes the following issues: - Update to version 3.17.2 bsc1238688, CVE-2025-22870: Updating to 0.37.0 for x/net builddeps: bump the k8s-io group with 7 updates - Update to version 3.17.1: merge null child chart objects builddeps: bump the k8s-io group with 7 updates fix: chec...

9.1CVSS6.4AI score0.03181EPSS
SaveExploits4References11
SUSE Linux
SUSE Linux
•added 2025/04/22 1:48 p.m.•21 views

Security update for helm

This update for helm fixes the following issues: Update to version 3.17.2 bsc1238688, CVE-2025-22870: Updating to 0.37.0 for x/net builddeps: bump the k8s-io group with 7 updates Update to version 3.17.1: merge null child chart objects builddeps: bump the k8s-io group with 7 updates fix: check...

8.2CVSS6.4AI score0.03181EPSS
SaveExploits4References20
Github Security Blog
Github Security Blog
•added 2023/11/27 12:30 p.m.•48 views

Apache Superset Cross-site Scripting vulnerability

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache...

5.4CVSS7.1AI score0.01004EPSS
SaveExploits0References5Affected Software1
osv_ghsa
osv_ghsa
•added 2023/11/27 12:30 p.m.•90 views

GHSA-WQ8Q-99P5-XFRW Apache Superset Cross-site Scripting vulnerability

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache...

4.3CVSS5.4AI score0.01004EPSS
SaveExploits0References5
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2023/11/27 12:00 a.m.•7 views

CVE-2023-43701: Improper Neutralization of Input During Web Page Generation

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache...

5.4CVSS6AI score0.01004EPSS
SaveExploits0References2
Positive Technologies
Positive Technologies
•added 2023/11/27 12:00 a.m.•18 views

PT-2023-28919

Name of the Vulnerable Software and Affected Versions Apache Superset versions prior to 2.1.2 Description The issue is caused by improper payload validation and an improper REST API response type. This allows an authenticated malicious actor to store malicious code into Chart's metadata. The code...

5.4CVSS6.2AI score0.01004EPSS
SaveExploits0References14
CNNVD
CNNVD
•added 2023/11/27 12:00 a.m.•22 views

Apache Superset Cross-Site Scripting Vulnerability

Apache Superset is a data visualization and data exploration platform from the Apache USA Foundation. A cross-site scripting vulnerability exists in Apache Superset versions prior to 2.1.2, which stems from the presence of incorrect payload validation and incorrect REST API response type issues. ...

5.4CVSS6.2AI score0.01004EPSS
SaveExploits0References2
Rows per page
Query Builder