19 matches found
Astra Linux – vulnerability in linux-5.10, linux-6.1, linux-5.15
In the Linux kernel, the following vulnerability has been resolved: can: hi311x: populate ndochangemtu to prevent buffer overflow Sending a PFPACKET allows bypassing the CAN framework logic and directly reaching the xmit function of a CAN driver. The only check performed by the PFPACKET framework...
Astra Linux – vulnerability in linux-5.10, linux-6.1, linux-5.15
In the Linux kernel, the following vulnerability has been resolved: can: sun4ican: populate ndochangemtu to prevent buffer overflow Sending a PFPACKET allows bypassing the CAN framework logic and directly reaching the xmit function of a CAN driver. The only check performed by the PFPACKET framewo...
CVE-2026-43234
In the Linux kernel, the following vulnerability has been resolved: team: avoid NETDEVCHANGEMTU event when unregistering slave syzbot is reporting unregisternetdevice: waiting for netdevsim0 to become free. Usage count = 3 reftracker: netdev@ffff88807dcf8618 has 1/2 users at netdevtrackeralloc...
CVE-2026-43234
In the Linux kernel, the following vulnerability has been resolved: team: avoid NETDEVCHANGEMTU event when unregistering slave syzbot is reporting unregisternetdevice: waiting for netdevsim0 to become free. Usage count = 3 reftracker: netdev@ffff88807dcf8618 has 1/2 users at netdevtrackeralloc...
PT-2026-37574
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description An issue exists in the team driver where a NETDEV CHANGEMTU event is triggered during the unregistration of a slave. This can lead to a situation where the system waits for a network...
CVE-2025-65199
Windscribe for Linux Desktop App is affected by a local privilege escalation vulnerability where a local user in the windscribe group can inject commands as root via the adapterName parameter of the changeMTU function. The root cause is a command injection in the changeMTU pathway, enabling arbit...
CVE-2025-65199 Windscribe for Linux 'changeMTU' local privilege escalation
A command injection vulnerability exists in Windscribe for Linux Desktop App that allows a local user who is a member of the windscribe group to execute arbitrary commands as root via the 'adapterName' parameter of the 'changeMTU' function. Fixed in Windscribe v2.18.3-alpha and v2.18.8...
Windscribe Desktop Application security vulnerabilities
Windscribe Desktop Application is a VPN software from Windscribe Open Source. A security vulnerability exists in Windscribe Desktop Application versions prior to 2.18.3-alpha and prior to 2.18.8, which stems from a command injection in the adapterName parameter of the changeMTU function, which...
CVE-2025-39986
In the Linux kernel, the following vulnerability has been resolved: can: sun4ican: populate ndochangemtu to prevent buffer overflow Sending an PFPACKET allows to bypass the CAN framework logic and to directly reach the xmit function of a CAN driver. The only check which is performed by the PFPACK...
can: sun4i_can: populate ndo_change_mtu() to prevent buffer overflow
...
can: etas_es58x: populate ndo_change_mtu() to prevent buffer overflow
...
CVE-2025-39985
In the Linux kernel, the following vulnerability has been resolved: can: mcbausb: populate ndochangemtu to prevent buffer overflow Sending an PFPACKET allows to bypass the CAN framework logic and to directly reach the xmit function of a CAN driver. The only check which is performed by the PFPACKE...
CVE-2025-39986
In the Linux kernel, the following vulnerability has been resolved: can: sun4ican: populate ndochangemtu to prevent buffer overflow Sending an PFPACKET allows to bypass the CAN framework logic and to directly reach the xmit function of a CAN driver. The only check which is performed by the PFPACK...
AZL-68474 CVE-2025-39985 affecting package kernel for versions less than 6.6.112.1-1
In the Linux kernel, the following vulnerability has been resolved: can: mcbausb: populate ndochangemtu to prevent buffer overflow Sending an PFPACKET allows to bypass the CAN framework logic and to directly reach the xmit function of a CAN driver. The only check which is performed by the PFPACKE...
CVE-2025-39988
The CVE-2025-39988 issue affects the etas_es58x CAN driver in the Linux kernel. Root cause: net_device_ops->ndo_change_mtu() is not populated, allowing a PF_PACKET-sourced MTU to be set arbitrarily large (e.g., can0 mtu 9999). This can enable a malicious CAN XL frame to bypass CAN framework ch...
CVE-2025-39986 can: sun4i_can: populate ndo_change_mtu() to prevent buffer overflow
In the Linux kernel, the following vulnerability has been resolved: can: sun4ican: populate ndochangemtu to prevent buffer overflow Sending an PFPACKET allows to bypass the CAN framework logic and to directly reach the xmit function of a CAN driver. The only check which is performed by the PFPACK...
CVE-2025-39987 can: hi311x: populate ndo_change_mtu() to prevent buffer overflow
In the Linux kernel, the following vulnerability has been resolved: can: hi311x: populate ndochangemtu to prevent buffer overflow Sending an PFPACKET allows to bypass the CAN framework logic and to directly reach the xmit function of a CAN driver. The only check which is performed by the PFPACKET...
CVE-2025-39986
The CVE-2025-39986 entry concerns the sun4i_can driver in the Linux kernel. The root cause is that sun4i_can does not populate net_device_ops->ndo_change_mtu(), which allows a local attacker to set an invalid MTU (e.g., mtu 9999) via PF_PACKET and then inject CAN XL frames through ETH_P_CANXL....
Linux Kernel Security Vulnerabilities
Linux kernel is the kernel used by Linux, the open source operating system of the Linux Foundation in the United States. A security vulnerability exists in the Linux kernel that stems from the sun4ican driver not implementing the ndochangemtu function, which could lead to a buffer overflow attack...