Lucene search
+L

12 matches found

VulnCheck KEV
VulnCheck KEV
•added 2025/07/03 12:00 a.m.•105 views

VulnCheck KEV: CVE-2025-29891

Bypass/Injection vulnerability in Apache Camel. This issue affects Apache Camel: from 4.10.0 before 4.10.2, from 4.8.0 before 4.8.5, from 3.10.0 before 3.22.4. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is...

4.8CVSS6.7AI score0.76087EPSS
SaveIn wildExploits2References2
Mend
Mend
•added 2025/04/01 11:56 a.m.•13 views

CVE-2025-30177

Bypass/Injection vulnerability in Apache Camel in Camel-Undertow component under particular conditions. This issue affects Apache Camel: from 4.10.0 before 4.10.3, from 4.8.0 before 4.8.6. Users are recommended to upgrade to version 4.10.3 for 4.10.x LTS and 4.8.6 for 4.8.x LTS. Camel undertow...

6.9CVSS6.5AI score0.01295EPSS
SaveExploits0References8
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2025/04/01 12:00 a.m.•7 views

CVE-2025-30177: Improper Neutralization of Internal Special Elements

Bypass/Injection vulnerability in Apache Camel in Camel-Undertow component under particular conditions. This issue affects Apache Camel: from 4.10.0 before 4.10.3, from 4.8.0 before 4.8.6. Users are recommended to upgrade to version 4.10.3 for 4.10.x LTS and 4.8.6 for 4.8.x LTS. Camel undertow...

6.5CVSS6.6AI score0.01295EPSS
SaveExploits0References1
Snyk
Snyk
•added 2025/03/12 3:32 p.m.•13 views

Improper Handling of Case Sensitivity

Overview Affected versions of this package are vulnerable to Improper Handling of Case Sensitivity due to a flaw in the header filtering mechanism that only blocks headers starting with specific prefixes, and may be manipulated to treat parameter values as headers. If an application accepts HTTP...

9.2CVSS6.5AI score0.97057EPSS
SaveExploits5References2
Mend
Mend
•added 2025/03/12 2:42 p.m.•9 views

CVE-2025-29891

Bypass/Injection vulnerability in Apache Camel. This issue affects Apache Camel: from 4.10.0 before 4.10.2, from 4.8.0 before 4.8.5, from 3.10.0 before 3.22.4. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is...

6.3CVSS6.6AI score0.76087EPSS
SaveExploits2References10
Veracode
Veracode
•added 2025/03/12 5:41 a.m.•35 views

Header Injection

org.apache.camel, camel-support is vulnerable to a Header Injection. The vulnerability is due to insufficient header filtering, where only headers starting with "Camel", "camel", or "org.apache.camel." are blocked, allows attackers to forge header names and manipulate method invocation in the...

5.6CVSS7AI score0.97057EPSS
SaveExploits4References10Affected Software1
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2025/03/12 12:00 a.m.•6 views

CVE-2025-29891: Improper Neutralization of Internal Special Elements

Bypass/Injection vulnerability in Apache Camel. This issue affects Apache Camel: from 4.10.0 before 4.10.2, from 4.8.0 before 4.8.5, from 3.10.0 before 3.22.4. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and 3.22.4 for 3.x releases. This vulnerability is...

4.8CVSS6.7AI score0.76087EPSS
SaveExploits2References1
Github Security Blog
Github Security Blog
•added 2025/03/09 3:31 p.m.•55 views

Apache Camel: Camel Message Header Injection via Improper Filtering

Bypass/Injection vulnerability in Apache Camel components under particular conditions. This issue affects Apache Camel: from 4.9.0 through = 4.10.1, from 4.8.0 through = 4.8.4, from 3.10.0 through = 3.22.3. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS and...

5.6CVSS6.9AI score0.97057EPSS
SaveExploits4References10Affected Software1
Snyk
Snyk
•added 2025/03/09 12:43 p.m.•14 views

Improper Handling of Case Sensitivity

Overview Affected versions of this package are vulnerable to Improper Handling of Case Sensitivity due to a flaw in the default filtering mechanism that only blocks headers starting with specific prefixes. An attacker can manipulate header entries to invoke arbitrary methods from the Bean registr...

9.2CVSS6.7AI score0.97057EPSS
SaveExploits4References2
Mend
Mend
•added 2025/03/09 12:09 p.m.•11 views

CVE-2025-27636

Bypass/Injection vulnerability in Apache Camel components under particular conditions. This issue affects Apache Camel: from 4.10.0 through = 4.10.1, from 4.8.0 through = 4.8.4, from 3.10.0 through = 3.22.3. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS an...

6.3CVSS6.9AI score0.97057EPSS
SaveExploits4References13
Rapid7 Vulnerability Database (full)
Rapid7 Vulnerability Database (full)
•added 2025/03/09 12:00 a.m.•8 views

CVE-2025-27636: Improper Handling of Case Sensitivity

Bypass/Injection vulnerability in Apache Camel components under particular conditions. This issue affects Apache Camel: from 4.10.0 through = 4.10.1, from 4.8.0 through = 4.8.4, from 3.10.0 through = 3.22.3. Users are recommended to upgrade to version 4.10.2 for 4.10.x LTS, 4.8.5 for 4.8.x LTS an...

5.6CVSS7AI score0.97057EPSS
SaveExploits4References1
vulnersOsv
vulnersOsv
•added 2021/05/21 7:20 p.m.•5 views

org.apache.camel:camel-amqp (2.7.4), org.apache.camel:camel-atom (2.7.4) +125 more potentially affected by CVE-2020-11971 via org.apache.camel:camel-core (2.7.4)

org.apache.camel:camel-core MAVEN version 2.7.4 is affected by a known vulnerability. The following packages have a transitive dependency on org.apache.camel:camel-core and may be impacted: - org.apache.camel:camel-amqp 2.7.4 - org.apache.camel:camel-atom 2.7.4 - org.apache.camel:camel-aws 2.7.4 ...

7.5CVSS0.13959EPSS
SaveExploits0
Rows per page
Query Builder