5281 matches found
CVE-2021-38587
The CVE-2021-38587 entry concerns cPanel prior to 96.0.13. The affected component is the script fix-cpanel-perl, which mishandles the creation of temporary files (SEC-586). The underlying issue is a faulty handling of temporary-file creation, enabling an impact described in the sources. The publi...
CVE-2021-38587
In cPanel before 96.0.13, scripts/fix-cpanel-perl mishandles the creation of temporary files SEC-586...
CVE-2021-38588
In cPanel before 96.0.13, fixcpanelperl lacks verification of the integrity of downloads SEC-587...
CVE-2021-38588
CVE-2021-38588 affects cPanel before 96.0.13, where fix_cpanel_perl does not verify the integrity of downloads (SEC-587). Root cause: lack of integrity verification in the download process. Impacts include partial confidentiality, integrity, and availability (per CVSS) with network exposure and n...
CVE-2021-38589
CVE-2021-38589 affects cPanel before 96.0.13, where scripts/fix-cpanel-perl does not properly restrict overwriting of files (SEC-588). This is a file-overwrite restriction flaw in the fix-cpanel-perl script. The vulnerability is documented across multiple sources (e.g., Red Hat advisory and NVD e...
CVE-2021-38589
In cPanel before 96.0.13, scripts/fix-cpanel-perl does not properly restrict the overwriting of files SEC-588...
CVE-2021-38590
In cPanel before 96.0.8, weak permissions on web stats can lead to information disclosure SEC-584...
CVE-2021-38590
CVE-2021-38590 affects cPanel before 96.0.8 where weak permissions on web statistics can lead to information disclosure (SEC-584). The vulnerability is caused by insufficient access controls on web stats, enabling local attackers to read information that should be restricted. Impact is informatio...
CVE-2021-38586: Undefined Security Weakness
In cPanel before 98.0.1, /scripts/cpanconfig performs unsafe operations on files SEC-589...
CVE-2021-38587: Concurrent Execution using Shared Resource with Improper Synchronization
In cPanel before 96.0.13, scripts/fix-cpanel-perl mishandles the creation of temporary files SEC-586...
CVE-2021-38588: Download of Code Without Integrity Check
In cPanel before 96.0.13, fixcpanelperl lacks verification of the integrity of downloads SEC-587...
CVE-2021-38589: Undefined Security Weakness
In cPanel before 96.0.13, scripts/fix-cpanel-perl does not properly restrict the overwriting of files SEC-588...
CVE-2021-38584: Improper Restriction of XML External Entity Reference
The WHM Locale Upload feature in cPanel before 98.0.1 allows XXE attacks SEC-585...
CVE-2021-38585: Deserialization of Untrusted Data
The WHM Locale Upload feature in cPanel before 98.0.1 allows unserialization attacks SEC-585...
PT-2021-22228
Name of the Vulnerable Software and Affected Versions cPanel versions prior to 98.0.1 Description The issue concerns unsafe operations on files performed by the /scripts/cpan config script. Recommendations For versions prior to 98.0.1, update to version 98.0.1 or later to resolve the issue...
PT-2021-22229
Name of the Vulnerable Software and Affected Versions cPanel versions prior to 96.0.13 Description The issue concerns the mishandling of temporary file creation in the scripts/fix-cpanel-perl component. Recommendations For versions prior to 96.0.13, update to version 96.0.13 or later to resolve t...
PT-2021-22227
Name of the Vulnerable Software and Affected Versions cPanel versions prior to 98.0.1 Description The issue concerns the WHM Locale Upload feature, which allows unserialization attacks. Recommendations For versions prior to 98.0.1, update to version 98.0.1 or later to resolve the issue...
PT-2021-22230
Name of the Vulnerable Software and Affected Versions cPanel versions prior to 96.0.13 Description The issue is related to the lack of verification of the integrity of downloads in the fix cpanel perl function. This could potentially lead to security issues. Recommendations For versions prior to...
PT-2021-22226
Name of the Vulnerable Software and Affected Versions cPanel versions prior to 98.0.1 Description The issue concerns the WHM Locale Upload feature, which allows XXE attacks. Recommendations For versions prior to 98.0.1, update to version 98.0.1 or later to resolve the issue...