3242 matches found
libsigrok
README The sigrok project aims at creating a portable, cross-platform, Free/Libre/Open-Source signal analysis software suite that supports various device types such as logic analyzers, oscilloscopes, multimeters, and more. libsigrok is a shared library written in C which provides the basic API fo...
MeshCore
About MeshCore MeshCore is a lightweight, portable C++ library that enables multi-hop packet routing for embedded projects using LoRa and other packet radios. It is designed for developers who want to create resilient, decentralized communication networks that work without the internet. π What is...
wolfCOSE
wolfCOSE wolfCOSE is a lightweight and fast C library implementing core CBOR and COSE standards, backed by wolfSSL for cryptography. Supported Standards & RFCs Core Specifications: RFC 8949 - Concise Binary Object Representation CBOR RFC 9052 - CBOR Object Signing and Encryption COSE RFC 9053 -...
HElib
HElib HElib is an open-source Apache License v2.0 software library that implements homomorphic encryption HE. Currently available schemes are the implementations of the Brakerski-Gentry-Vaikuntanathan BGV scheme with bootstrapping and the Approximate Number scheme of Cheon-Kim-Kim-Song CKKS, alon...
memoro
Memoro Memoro is a highly detailed heap profiler. Memoro not only shows you where and when your program makes heap allocations, but will show you how your program actually used that memory. Memoro collects detailed information on accesses to the heap, including reads and writes to memory and when...
longfellow-zk
Longfellow ZK Overview The Longfellow library enables the construction of zero-knowledge protocols concerning legacy identity verification standards such as the ISO MDOC standard, the JWT standard, and W3 Verifiable Credentials. This implementation is described in: Anonymous credentials from ECDS...
tiny-AES-c
Tiny AES in C This is a small and portable implementation of the AES ECB, CTR and CBC encryption algorithms written in C. You can override the default key-size of 128 bit with 192 or 256 bit by defining the symbols AES192 or AES256 in aes.h. The API is very simple and looks like this I am using C...
resiprocate
Overview The reSIProcate repository contains the following C++ libraries and applications: resip library: comprehensive RFC3261 SIP stack dum Dialog Usage Manager library: high level SIP library for creating SIP user agents no media stack recon library: high level SIP UA library with media stack...
xmlsec
XMLSec Library XMLSec library provides C based implementation for major XML Security standards: XML Signature Syntax and Processing XML Encryption Syntax and Processing Detailed information about supported features and algorithms can be found in the XMLDsig and the XMLEnc interoperability reports...
MemoryModulePP
MemoryModulePP memorymodule:https://github.com/fancycode/MemoryModule Library to load a DLL from memory Modify from memorymodule. Support exception...
SindriKit
SindriKit Offensive Development Deserves Better Architecture. A C library for building offensive capabilities. Core Concept Most offensive utilities hardcode their execution mechanics inside the technique's logic. A reflective loader doesn't just map an image; it maps it using a specific, hardcod...
expat_CVE-2024-28757
Expat, Release 2.2.6 This is Expat, a C library for parsing XML, started by James Clark in 1997. Expat is a stream-oriented XML parser. This means that you register handlers with the parser before starting the parse. These handlers are called when the parser discovers the associated structures in...
pinjectra
Pinjectra Pinjectra is a C/C++ library that implements Process Injection techniques with focus on Windows 10 64-bit in a "mix and match" style. Here's an example: // CreateRemoteThread Demo + DLL Load i.e., LoadLibraryA as Entry Point executor = new CodeViaCreateRemoteThread new...
external_expat_AOSP10_r33_CVE-2022-23852
Expat, Release 2.2.6 This is Expat, a C library for parsing XML, started by James Clark in 1997. Expat is a stream-oriented XML parser. This means that you register handlers with the parser before starting the parse. These handlers are called when the parser discovers the associated structures in...
wsb-detect
β³ wsb-detect wsb-detect enables you to detect if you are running in Windows Sandbox "WSB". The sandbox is used by Windows Defender for dynamic analysis, and commonly manually by security analysts and alike. At the tail end of 2019, Microsoft introduced a new feature named Windows Sandbox WSB for...
UnhookMe
UnhookMe - Dynamically unhooking imports resolver In the era of intrusive AVs and EDRs that introduce hot-patches to the running processes for their enhanced optics requirements, modern adversaries must have a robust tool to slide through these watchguards. The propsed implementation of dynamic...
wnfexec
Overview WnfExec is a C proof of concept library that injects shellcode into a process by hijacking a WNF subscription callback then triggering a state change. There's nothing novel here and was built based on the research of others. My intent was to solidfy the concept in my head, document the...
libptrace
libptrace libptrace is an event driven process/thread debugging, tracing, and manipulation framework. It is written in C and has Python 2.7 and 3.7 bindings. It is meant to be used as a library. The API has been designed with cross-platform support in mind. Although the current version only runs ...
CVE-2025-4802-Proof-of-Concept
CVE-2025-4802 β Proof of Concept β οΈ Disclaimer: This repository is for educational and authorized security research purposes only. Do not use this exploit against systems you do not own or have explicit permission to test. Misuse may violate laws and regulations. CVE Summary Field| Details ---|---...
kdmp-parser
kdmp-parser This C++ library parses Windows kernel full dumps .dump /f in WinDbg, BMP dumps .dump /ka in WinDbg as well as more recent dump types that were introduced in 2022. The library supports loading 64-bit dumps and provides read access to things like: The context record, The exception...