3224 matches found
SindriKit
SindriKit Offensive Development Deserves Better Architecture. A C library for building offensive capabilities. Core Concept Most offensive utilities hardcode their execution mechanics inside the technique's logic. A reflective loader doesn't just map an image; it maps it using a specific, hardcod...
resiprocate
Overview The reSIProcate repository contains the following C++ libraries and applications: resip library: comprehensive RFC3261 SIP stack dum Dialog Usage Manager library: high level SIP library for creating SIP user agents no media stack recon library: high level SIP UA library with media stack...
wolfCOSE
wolfCOSE wolfCOSE is a lightweight and fast C library implementing core CBOR and COSE standards, backed by wolfSSL for cryptography. Supported Standards & RFCs Core Specifications: RFC 8949 - Concise Binary Object Representation CBOR RFC 9052 - CBOR Object Signing and Encryption COSE RFC 9053 -...
pinjectra
Pinjectra Pinjectra is a C/C++ library that implements Process Injection techniques with focus on Windows 10 64-bit in a "mix and match" style. Here's an example: // CreateRemoteThread Demo + DLL Load i.e., LoadLibraryA as Entry Point executor = new CodeViaCreateRemoteThread new...
longfellow-zk
Longfellow ZK Overview The Longfellow library enables the construction of zero-knowledge protocols concerning legacy identity verification standards such as the ISO MDOC standard, the JWT standard, and W3 Verifiable Credentials. This implementation is described in: Anonymous credentials from ECDS...
MeshCore
About MeshCore MeshCore is a lightweight, portable C++ library that enables multi-hop packet routing for embedded projects using LoRa and other packet radios. It is designed for developers who want to create resilient, decentralized communication networks that work without the internet. ๐ What is...
wnfexec
Overview WnfExec is a C proof of concept library that injects shellcode into a process by hijacking a WNF subscription callback then triggering a state change. There's nothing novel here and was built based on the research of others. My intent was to solidfy the concept in my head, document the...
memoro
Memoro Memoro is a highly detailed heap profiler. Memoro not only shows you where and when your program makes heap allocations, but will show you how your program actually used that memory. Memoro collects detailed information on accesses to the heap, including reads and writes to memory and when...
wsb-detect
โณ wsb-detect wsb-detect enables you to detect if you are running in Windows Sandbox "WSB". The sandbox is used by Windows Defender for dynamic analysis, and commonly manually by security analysts and alike. At the tail end of 2019, Microsoft introduced a new feature named Windows Sandbox WSB for...
xmlsec
XMLSec ๋ผ์ด๋ธ๋ฌ๋ฆฌ XMLSec ๋ผ์ด๋ธ๋ฌ๋ฆฌ๋ ์ฃผ์ XML ๋ณด์ ํ์ค์ ์ํ C ๊ธฐ๋ฐ ๊ตฌํ์ ์ ๊ณตํฉ๋๋ค: XML ์๋ช ๊ตฌ๋ฌธ ๋ฐ ์ฒ๋ฆฌ XML ์ํธํ ๊ตฌ๋ฌธ ๋ฐ ์ฒ๋ฆฌ ์ง์๋๋ ๊ธฐ๋ฅ ๋ฐ ์๊ณ ๋ฆฌ์ฆ์ ๋ํ ์์ธํ ์ ๋ณด๋ XMLDsig ๋ฐ XMLEnc ์ํธ ์ด์ฉ์ฑ ๋ณด๊ณ ์์์ ํ์ธํ ์ ์์ต๋๋ค. ๋ฌธ์ XMLSec ๋ผ์ด๋ธ๋ฌ๋ฆฌ์ ์ ์ฒด ๋ฌธ์๋ XMLSec ์น์ฌ์ดํธ ๋ฐ XMLSec GitHub Wiki์ ๊ฒ์๋์ด ์์ต๋๋ค. ๋ผ์ด์ ์ค XMLSec ๋ผ์ด๋ธ๋ฌ๋ฆฌ๋ MIT ๋ผ์ด์ ์ค๋ก ๋ฐฐํฌ๋ฉ๋๋ค Copyright ํ์ผ ์ฐธ์กฐ. XMLSec ๋น๋ ๋ฐ ์ค์น ์...
kdmp-parser
kdmp-parser ์ด C++ ๋ผ์ด๋ธ๋ฌ๋ฆฌ๋ Windows ์ปค๋ full ๋คํWinDbg์ .dump /f, BMP ๋คํWinDbg์ .dump /ka ๋ฐ 2022๋ ์ ๋์ ๋ ๋ ์ต์ ๋คํ ์ ํ์ ํ์ฑํฉ๋๋ค. ์ด ๋ผ์ด๋ธ๋ฌ๋ฆฌ๋ 64๋นํธ ๋คํ ๋ก๋๋ฅผ ์ง์ํ๋ฉฐ ๋ค์๊ณผ ๊ฐ์ ํญ๋ชฉ์ ๋ํ ์ฝ๊ธฐ ์ก์ธ์ค๋ฅผ ์ ๊ณตํฉ๋๋ค: ์ปจํ ์คํธ ๋ ์ฝ๋, ์์ธ ๋ ์ฝ๋, ๋ฒ๊ทธ์ฒดํฌ ๋งค๊ฐ๋ณ์, ๋ฌผ๋ฆฌ ๋ฉ๋ชจ๋ฆฌ. ์ปดํ์ผ๋ ๋ฐ์ด๋๋ฆฌ๋ ๋ฆด๋ฆฌ์ค ์น์ ์์ ์ ๊ณต๋ฉ๋๋ค. ํน๋ณํ ๊ฐ์ฌ๋๋ฆฝ๋๋ค: hugsy๋์ ์๋ง์ ๊ธฐ์ฌ์๋ก์ด Python ๋ฐ์ธ๋ฉ, CI ๊ฐ์ , ์๋ก์ด ๋คํ ์ ํ ๋ฑ,...
UnhookMe
UnhookMe - Dynamically unhooking imports resolver In the era of intrusive AVs and EDRs that introduce hot-patches to the running processes for their enhanced optics requirements, modern adversaries must have a robust tool to slide through these watchguards. The propsed implementation of dynamic...
external_libexif_AOSP10_CVE-2020-0452
libexif ------- DESCRIPTION libexif is a library for parsing, editing, and saving EXIF data. It is intended to replace lots of redundant implementations in command-line utilities and programs with GUIs. FEATURES libexif supports parsing, editing and saving of EXIF data. In addition, it has gettex...
external_expat_AOSP10_r33_CVE-2022-23990
Expat, Release 2.2.6 This is Expat, a C library for parsing XML, started by James Clark in 1997. Expat is a stream-oriented XML parser. This means that you register handlers with the parser before starting the parse. These handlers are called when the parser discovers the associated structures in...
tiny-AES-c
C๋ก ์์ฑ๋ Tiny AES ์ด๊ฒ์ C๋ก ์์ฑ๋ AES ECB, CTR ๋ฐ CBC ์ํธํ ์๊ณ ๋ฆฌ์ฆ์ ์๊ณ ํด๋์ฑ์ด ๋ฐ์ด๋ ๊ตฌํ์ ๋๋ค. aes.h์์ AES192 ๋๋ AES256 ๊ธฐํธ๋ฅผ ์ ์ํ์ฌ ๊ธฐ๋ณธ ํค ํฌ๊ธฐ์ธ 128๋นํธ๋ฅผ 192๋นํธ ๋๋ 256๋นํธ๋ก ๋ณ๊ฒฝํ ์ ์์ต๋๋ค. API๋ ๋งค์ฐ ๊ฐ๋จํ๋ฉฐ ๋ค์๊ณผ ๊ฐ์ ํํ์ ๋๋ค C99 ์คํ์ผ์ ์ ํ ์ฃผ์์ ์ฌ์ฉํฉ๋๋ค: / Initialize context calling one of: / void AESinitctxstruct AESctx ctx, const uint8t key; void...
libpeconv
libPeConv PE ํ์ผ์ ๋ก๋ํ๊ณ ์กฐ์ํ๊ธฐ ์ํ ๋ผ์ด๋ธ๋ฌ๋ฆฌ์ ๋๋ค. ๋ชฉํ libPEConv์ ๋ชฉํ๋ PE ํ์ผ์ ์ฌ์ฉ์ ์ ์ ๋ก๋ฉ์ ์ํ "์ค์์ค ์๋ฏธ ๋์ดํ"๋ฅผ ๋ง๋๋ ๊ฒ์ด์์ต๋๋ค. ์ด ๋ผ์ด๋ธ๋ฌ๋ฆฌ๋ ์์ฒด ๋ก๋์ ๋น ๋ฅด๊ฒ ํตํฉํ ์ ์๋ ๋ค์ํ ํฌํผ ํจ์๋ฅผ ๋ชจ์ ๋์์ต๋๋ค. ์๋ฅผ ๋ค์ด: ์น์ ์ฌ๋งคํ, ์ฌ๋ฐฐ์น ์ ์ฉ, ์ํฌํธ ๋ก๋ฉ, ๋ฆฌ์์ค ํ์ฑ ๋ฑ์ด ์์ต๋๋ค. PE ํ์ผ์ ๋ก๋ํ ์ ์์ ๋ฟ๋ง ์๋๋ผ ์ผ๋ถ ๋จ๊ณ๋ฅผ ์ฌ์ฉ์ ์ ์ํ ์๋ ์์ต๋๋ค. ์ฆ, IAT ํํน์ฌ์ฉ์ ์ ์ IAT ํด์๊ธฐ ์ ๊ณต ๋ฐ ํจ์ ๋ฆฌ๋๋ ์ ์ ์ง์ํฉ๋๋ค. ๊ทธ๋ฌ๋...
external_expat_AOSP10_r33_CVE-2022-22822toCVE-2022-22827
Expat, Release 2.2.6 This is Expat, a C library for parsing XML, started by James Clark in 1997. Expat is a stream-oriented XML parser. This means that you register handlers with the parser before starting the parse. These handlers are called when the parser discovers the associated structures in...
libptrace
libptrace libptrace is an event driven process/thread debugging, tracing, and manipulation framework. It is written in C and has Python 2.7 and 3.7 bindings. It is meant to be used as a library. The API has been designed with cross-platform support in mind. Although the current version only runs ...
external_expat-2.1.0_CVE-2022-43680
Expat, Release 2.1.0 This is Expat, a C library for parsing XML, written by James Clark. Expat is a stream-oriented XML parser. This means that you register handlers with the parser before starting the parse. These handlers are called when the parser discovers the associated structures in the...
libsigrok
README sigrok ํ๋ก์ ํธ๋ ๋ค์ํ ์ฅ์น ์ ํ๋ก์ง ๋ถ์๊ธฐ, ์ค์ค๋ก์ค์ฝํ, ๋ฉํฐ๋ฏธํฐ ๋ฑ์ ์ง์ํ๋ ์ด์์ฑ ๋์ ํฌ๋ก์ค ํ๋ซํผ ์์ /์คํ์์ค ์ ํธ ๋ถ์ ์ํํธ์จ์ด ์ ํ๊ตฐ์ ๋ง๋๋ ๊ฒ์ ๋ชฉํ๋ก ํฉ๋๋ค. libsigrok์ ํ๋์จ์ด์ ํต์ ํ๊ณ ํ๋ํ ๋ฐ์ดํฐ๋ฅผ ๋ค์ํ ์ ๋ ฅ/์ถ๋ ฅ ํ์ผ ํ์์ผ๋ก ์ฝ๊ณ ์ฐ๊ธฐ ์ํ ๊ธฐ๋ณธ API๋ฅผ ์ ๊ณตํ๋ C๋ก ์์ฑ๋ ๊ณต์ ๋ผ์ด๋ธ๋ฌ๋ฆฌ์ ๋๋ค. Status libsigrok์ ์ฌ์ฉ ๊ฐ๋ฅํ ์ํ์ด๋ฉฐ ๊ณต์ tarball ๋ฆด๋ฆฌ์ค๊ฐ ์์ต๋๋ค. API๋ ๋ฆด๋ฆฌ์ค๋ง๋ค ๋ณ๊ฒฝ๋ ์ ์์ง๋ง, ์ด๋ ํญ์ ํจํค์ง ๋ฒ์ ๋ฒํธ์ ๊ณต...