870 matches found
EulerOS 2.0 SP13 : bzip2 (EulerOS-SA-2026-3009)
According to the versions of the bzip2 packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : bzip2 contains an offbyone error in the bzip2recover utility. When processing a specially crafted file, the application performs an outofbounds wri...
EulerOS 2.0 SP13 : bzip2 (EulerOS-SA-2026-2959)
According to the versions of the bzip2 packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : bzip2 contains an offbyone error in the bzip2recover utility. When processing a specially crafted file, the application performs an outofbounds wri...
CVE-2026-59901
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the Bzip2Decoder handler in Netty's compression codec pipeline is vulnerable to a denial-of-service attack through a malformed bzip2 stream that permanently captures the...
CVE-2026-59901 Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the Bzip2Decoder handler in Netty's compression codec pipeline is vulnerable to a denial-of-service attack through a malformed bzip2 stream that permanently captures the...
EUVD-2026-50440
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the Bzip2Decoder handler in Netty's compression codec pipeline is vulnerable to a denial-of-service attack through a malformed bzip2 stream that permanently captures the...
CVE-2026-59901
Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the Bzip2Decoder handler in Netty's compression codec pipeline is vulnerable to a denial-of-service attack through a malformed bzip2 stream that permanently captures the...
Linux Distros Unpatched Vulnerability : CVE-2026-59901
The Linux/Unix host has one or more packages installed that are impacted by a vulnerability without a vendor supplied patch available. - Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the Bzip2Decoder handler in Netty's...
CVE-2026-59901
A flaw was found in the netty-codec-compression component of Netty. This vulnerability, caused by a logic error in the bzip2 decoder, allows a remote attacker to send specially crafted bzip2-compressed data. Processing this malformed data can trigger an infinite loop, causing the decoder thread t...
Denial Of Service (DoS)
Netty is vulnerable to Denial of Service DoS. The vulnerability is due to an infinite loop in the run-length encoding RLE state machine within the Bzip2Decoder handler when processing a malformed bzip2 stream, which allows an attacker to exploit the issue by sending a specially crafted bzip2 stre...
Infinite loop
Overview io.netty:netty-codec is an event-driven asynchronous network application framework. Affected versions of this package are vulnerable to Infinite loop in the Bzip2Decoder handler's run-length encoding state machine. An attacker can cause the event-loop thread to hang indefinitely by...
Infinite loop
Overview Affected versions of this package are vulnerable to Infinite loop in the Bzip2Decoder handler's run-length encoding state machine. An attacker can cause the event-loop thread to hang indefinitely by supplying a specially crafted bzip2 stream that triggers an infinite loop during...
GHSA-558V-64GR-WGG4 Netty: [Bzip2Decoder] Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang
The Bzip2Decoder handler in Netty's compression codec pipeline is vulnerable to a denial-of-service attack through a malformed bzip2 stream that permanently captures the event-loop thread in an infinite loop. The vulnerability exists in the run-length encoding RLE state machine within...
Netty: [Bzip2Decoder] Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang
The Bzip2Decoder handler in Netty's compression codec pipeline is vulnerable to a denial-of-service attack through a malformed bzip2 stream that permanently captures the event-loop thread in an infinite loop. The vulnerability exists in the run-length encoding RLE state machine within...
PT-2026-63549
Name of the Vulnerable Software and Affected Versions Netty versions prior to 4.1.136.Final Netty versions prior to 4.2.16.Final Description The Bzip2Decoder handler in the compression codec pipeline is susceptible to a denial-of-service attack. A malformed bzip2 stream can trigger an infinite lo...
CVE-2026-42250 affecting package bzip2 for versions less than 1.0.8-2
CVE-2026-42250 affecting package bzip2 for versions less than 1.0.8-2. A patched version of the package is available...
[SECURITY] Fedora 43 Update: perl-Compress-Raw-Bzip2-2.218-1.fc43
This module provides a Perl interface to the bzip2 compression library. It is used by IO::Compress::Bzip2...
[SECURITY] Fedora 43 Update: perl-IO-Compress-2.221-1.fc43
This distribution provides a Perl interface to allow reading and writing of compressed data created with the zlib and bzip2 libraries. IO-Compress supports reading and writing of bzip2, RFC 1950, RFC 1951, RFC 1952 i.e. gzip and zip files/buffers. The following modules used to be distributed...
Moderate: Red Hat Security Advisory: Red Hat Hardened Images RPMs Security Update
An update for Red Hat Hardened Images RPMs is now available. This update includes the following RPMs: bzip2: bzip2-1.0.8-23.2.hum1 aarch64, x8664 bzip2-devel-1.0.8-23.2.hum1 aarch64, x8664 bzip2-libs-1.0.8-23.2.hum1 aarch64, x8664 bzip2-static-1.0.8-23.2.hum1 aarch64, x8664...
[SECURITY] Fedora 44 Update: perl-Compress-Raw-Bzip2-2.218-1.fc44
This module provides a Perl interface to the bzip2 compression library. It is used by IO::Compress::Bzip2...
[SECURITY] Fedora 44 Update: perl-IO-Compress-2.221-1.fc44
This distribution provides a Perl interface to allow reading and writing of compressed data created with the zlib and bzip2 libraries. IO-Compress supports reading and writing of bzip2, RFC 1950, RFC 1951, RFC 1952 i.e. gzip and zip files/buffers. The following modules used to be distributed...