897 matches found
CVE-2023-39331
A previously disclosed vulnerability CVE-2023-30584 was patched insufficiently in commit 205f1e6. The new path traversal vulnerability arises because the implementation does not protect itself against the application overwriting built-in utility functions with user-defined implementations. Please...
SUSE CVE-2023-39331
A previously disclosed vulnerability CVE-2023-30584 was patched insufficiently in commit 205f1e6. The new path traversal vulnerability arises because the implementation does not protect itself against the application overwriting built-in utility functions with user-defined implementations. Please...
PT-2023-6419 · Node.Js +4 · Node.Js +4
Name of the Vulnerable Software and Affected Versions: Node.js affected versions not specified Description: The issue arises because the implementation does not protect itself against the application overwriting built-in utility functions with user-defined implementations, leading to a path...
Intel NUC Privilege Escalation
The vulnerability of Intel NUC’s built-in software is related to deficiencies in access control. Exploiting this vulnerability can allow attackers to enhance their privileges...
CVE-2023-30731
Logic error in package installation via debugger command prior to SMR Oct-2023 Release 1 allows physical attacker to install an application that has different build type...
Vyper Buffer Error Vulnerability
Vyper is the Pythonic smart contract language for EVM. A buffer error vulnerability exists in versions of Vyper prior to 0.3.10, which stems from the fact that the memory createfromblueprint and possibly createcopyof used by built-in functions can become corrupted under certain circumstances...
CVE-2023-36657
An issue was discovered in OPSWAT MetaDefender KIOSK 4.6.1.9996. Built-in features of Windows desktop shortcuts, narrator can be abused for privilege escalation...
Design/Logic Flaw
An adversary could cause a continuous restart loop to the entire device by sending a large quantity of HTTP GET requests if the controller has the built-in web server enabled but does not have the built-in web server completely set up and configured for the SNAP PAC S1 Firmware version R10.3b...
PT-2023-27607 · Opto 22 · Snap Pac S1 Firmware
Name of the Vulnerable Software and Affected Versions: SNAP PAC S1 Firmware version R10.3b Description: An adversary could crash the entire device by sending a large quantity of ICMP requests if the controller has the built-in web server enabled but does not have the built-in web server completel...
PT-2023-27605
Name of the Vulnerable Software and Affected Versions SNAP PAC S1 Firmware version R10.3b Description The built-in web server of the SNAP PAC S1 Firmware does not require complex passwords, which could allow for a successful brute force attack if users do not set up complex credentials...
CVE-2023-40710: Allocation of Resources Without Limits or Throttling
An adversary could cause a continuous restart loop to the entire device by sending a large quantity of HTTP GET requests if the controller has the built-in web server enabled but does not have the built-in web server completely set up and configured for the SNAP PAC S1 Firmware version R10.3b...
Moxa NPort IAW5000A-I/O Series Serial Device Server Improper Neutralization of Special Elements Used in an OS Command (CVE-2021-32974)
Improper input validation in the built-in web server in Moxa NPort IAW5000A-I/O series firmware version 2.2 or earlier may allow a remote attacker to execute commands. This plugin only works with Tenable.ot. Please visit https://www.tenable.com/products/tenable-ot for more information...
Moxa NPort IAW5000A-I/O Series Serial Device Server Improper Input Validation (CVE-2021-32970)
Data can be copied without validation in the built-in web server in Moxa NPort IAW5000A-I/O series firmware version 2.2 or earlier, which may allow a remote attacker to cause denial-of-service conditions. This plugin only works with Tenable.ot. Please visit...
Debunking misinformation about Opera’s browsers
Privacy, Security Debunking misinformation about Opera’s browsers Share July 6th, 2023 At Opera, we take the privacy and security of our users very seriously. As a European company, we have to be compliant with the GDPR – one of the strongest, if not the strongest, data protection frameworks in t...
Unveiling Nebula's Report 2.0: A new approach to security reporting
We're excited to announce Report 2.0, a major upgrade to our report system in Nebula. Report 2.0 is not just a cosmetic touch up--it's a completely revamped security reporting solution designed to cater to your diverse business requirements, allowing for a more dynamic, data-driven approach to IT...
GHSA-VC52-GWM3-8V2F Missing "--allow-net" permission check for built-in Node modules
Impact Outbound HTTP requests made using the built-in "node:http" or "node:https" modules are incorrectly not checked against the network permission allow list --allow-net. Dependencies relying on these built-in modules are subject to the vulnerability too. Users of Deno versions prior to 1.34.0...
PT-2023-24607 · Deno · Eden Runtime +1
Name of the Vulnerable Software and Affected Versions: Deno versions 1.34.0 deno runtime versions 0.114.0 Description: The issue affects outbound HTTP requests made using the built-in node:http or node:https modules, which are incorrectly not checked against the network permission allow list...
ARIS controller File Upload Code Execution
The vulnerability of the built-in software of the ARIS controller is related to the unlimited loading of dangerous files. Exploiting this vulnerability allows a remote attacker to execute arbitrary code or cause service failures...
ARIS controller Auth Bypass RCE
The vulnerability of the built-in software of the ARIS controller is related to deficiencies in the authentication process, allowing a perpetrator to execute arbitrary code using a specially crafted request...
ARIS controller Auth Bypass
The vulnerability of the ARIS controller’s built-in software is related to insufficient protection of authentication data. Exploiting this vulnerability could allow a malicious actor, operating remotely, to obtain user authentication data from the web interface...