401056 matches found
ROS-20261012-73-0225
The vulnerability of the buildi2cfwhdr function in the drivers/usb/serial/ioti.c file of the Linux device driver for USB devices is related to the copying of buffers without checking the size of the input data. Exploiting this vulnerability could allow an attacker to compromise the confidentialit...
CVE-2026-109255: Heap-based Buffer Overflow
FreeRDP 3.0.0 before 3.32.0 contains an integer truncation vulnerability in licensecheckstreamlength that allows a malicious RDP server to trigger a heap buffer overflow on 32-bit clients. Attackers can send a crafted SERVERLICENSEREQUEST with a large scopeCount that bypasses length checks, causi...
CVE-2026-108822: Buffer Copy without Checking Size of Input
A vulnerability was detected in Kamailio up to 6.0.7/6.1.3. The affected element is the function isupgetcallingparty of the file src/modules/sipt/ss7parser.c of the component sipt Module. The manipulation of the argument length results in buffer overflow. The attack may be performed from remote...
PT-2026-110672
Name of the Vulnerable Software and Affected Versions FreeRDP versions 3.0.0 through 3.31.0 Description An integer truncation issue exists in the license check stream length function. A malicious RDP server can exploit this by sending a crafted SERVER LICENSE REQUEST containing a large scopeCount...
PT-2026-110682
Name of the Vulnerable Software and Affected Versions ImageMagick versions 7.1.1-7 through 7.1.2-31 Description A heap buffer over-read occurs due to incorrect string termination in XMP profiles, which are metadata formats used to describe the creation and history of a digital asset. An attacker...
PT-2026-110696
ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 lacks proper synchronization when the security policy is accessed, so simultaneous reads and writes of the policy by multiple threads trigger a race condition that causes a heap buffer over-write. An attacker able to induce concurrent security...
CVE-2026-109273: Use of Uninitialized Resource
ImageMagick before 6.9.13-57 and 7.x before 7.1.2-32 contains an information disclosure vulnerability in the PostScript decoder, which allocates a buffer one byte longer than the data it decoded. Attackers can supply a crafted PostScript file to expose a single uninitialized byte of memory conten...
Amazon Linux 2023 : libX11, libX11-common, libX11-devel (ALAS2023-2026-3179)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2026-3179 advisory. A malicious X server could exploit a buffer overflow in libX11 before 1.8.14 during handling of XkbGetMap overflowing the keysymmap. CVE-2026-88806 Tenable has extracted the preceding description block...
Amazon Linux 2 : libX11 (ALAS-2026-3977)
The version of libX11 installed on the remote host is prior to 1.6.7-3. It is, therefore, affected by a vulnerability as referenced in the ALAS2-2026-3977 advisory. A malicious X server could exploit a buffer overflow in libX11 before 1.8.14 during handling of XkbGetMap overflowing the keysymmap...
Important: libX11
Issue Overview: A malicious X server could exploit a buffer overflow in libX11 before 1.8.14 during handling of XkbGetMap overflowing the keysymmap. CVE-2026-88806 Affected Packages: libX11 Note: This advisory is applicable to Amazon Linux 2 AL2 Core repository. Visit this FAQ section for the...
Important: libX11
Issue Overview: A malicious X server could exploit a buffer overflow in libX11 before 1.8.14 during handling of XkbGetMap overflowing the keysymmap. CVE-2026-88806 Affected Packages: libX11 Issue Correction: Run dnf update libX11 --releasever 2023.12.20261012 or dnf update --advisory...
EulerOS 2.0 SP13 : glib2 (EulerOS-SA-2026-4139)
According to the versions of the glib2 packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : A flaw was found in GLib. A buffer over-read can occur in the gregexreplace function when used with the GREGEXRAW compile flag and case-change...
EulerOS 2.0 SP13 : libtiff (EulerOS-SA-2026-4157)
According to the versions of the libtiff packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : A flaw was found in libtiff. A remote attacker could exploit this vulnerability by providing a specially crafted PixarLog-compressed TIFF image...
EulerOS 2.0 SP13 : gzip (EulerOS-SA-2026-4143)
According to the versions of the gzip packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : GNU gzip contains a vulnerability in the gzexe utility related to insecure temporary file handling. When the mktemp utility is not available in the...
Amazon Linux 2 : parted (ALAS-2026-3982)
The version of parted installed on the remote host is prior to 3.1-29. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2-2026-3982 advisory. heap buffer overflow in initfats / fattableread NOTE:...
EulerOS 2.0 SP13 : wget (EulerOS-SA-2026-4205)
According to the versions of the wget packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : GNU Wget through 1.25.0, fixed in commit c2640fe, contains a heap buffer overflow vulnerability in the convertfname function within src/url.c that...
Amazon Linux 2 : libsoup (ALAS-2026-3998)
The version of libsoup installed on the remote host is prior to 2.56.0-6. It is, therefore, affected by multiple vulnerabilities as referenced in the ALAS2-2026-3998 advisory. A flaw was found in libsoup. When reassembling fragmented WebSocket messages into a GByteArray, libsoup did not adequatel...
EulerOS 2.0 SP13 : coreutils (EulerOS-SA-2026-4036)
According to the versions of the coreutils packages installed, the EulerOS installation on the remote host is affected by the following vulnerabilities : GNU coreutils unexpand is vulnerable to a heap-based buffer overflow due to an integer overflow during buffer allocation when processing large...
TencentOS Server 3: vim (TSSA-2026:1147)
The version of Tencent Linux installed on the remote TencentOS Server 3 host is prior to tested version. It is, therefore, affected by multiple vulnerabilities as referenced in the TSSA-2026:1147 advisory. Package updates are available for TencentOS Server 3 that fix the following vulnerabilities...
Amazon Linux 2023 : fetchmail (ALAS2023-2026-3186)
It is, therefore, affected by a vulnerability as referenced in the ALAS2023-2026-3186 advisory. A stack-based buffer overflow flaw was found in fetchmail when built with NTLM support. A malicious or compromised mail server advertising NTLM authentication can send a crafted Type 2 challenge that...