314 matches found
CVE-2026-33234
How I Turned AutoGPT's Email Feature Into an Internal Network Scanner CVE-2026-33234 | Moderate 5.0 | GHSA-4jwj-6mg5-wrwf Author: Pavan Nallamothu I was mapping every user-controlled input that touched the network in AutoGPT Platform. The HTTP layer was locked down tight. Private IP ranges...
CVE-2026-22038
CVE-2026-22038 — AutoGPT Stagehand Blocks Log API Keys in Plaintext CVE ID: CVE-2026-22038 Product: AutoGPT Platform Stagehand integration Affected Versions: All versions up to and including autogpt-platform-beta-v0.6.45 Patched In: autogpt-platform-beta-v0.6.46 Vulnerability Type: CWE-532 —...
autogpt-CVE-2026-30950-poc
AutoGPT CVE-2026-30950 POC Proof-of-concept demonstration for CVE-2026-30950, an authenticated IDOR Missing Authorization in the AutoGPT Platform that lets any logged-in user reassign — and thus hijack — any other user's chat session via a single PATCH request, with no prior access to the session...
CVE-2026-72922
AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. Prior to 0.6.70, AutoGPT's autogptplatform/backend/backend/api/features/integrations/router.py webhookingressgeneric route selected getwebhookmanagerprovider from the untrust...
CVE-2026-72922 AutoGPT: Webhook provider path confusion bypasses generic webhook secret verification
AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. Prior to 0.6.70, AutoGPT's autogptplatform/backend/backend/api/features/integrations/router.py webhookingressgeneric route selected getwebhookmanagerprovider from the untrust...
EUVD-2026-56177
AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. Prior to 0.6.70, AutoGPT's autogptplatform/backend/backend/api/features/integrations/router.py webhookingressgeneric route selected getwebhookmanagerprovider from the untrust...
CVE-2026-72922 AutoGPT: Webhook provider path confusion bypasses generic webhook secret verification
AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. Prior to 0.6.70, AutoGPT's autogptplatform/backend/backend/api/features/integrations/router.py webhookingressgeneric route selected getwebhookmanagerprovider from the untrust...
CVE-2026-72922
Summary: CVE-2026-72922 affects AutoGPT prior to version 0.6.70. The root cause is in autogpt_platform/backend/backend/api/features/integrations/router.py, where the webhook_ingress_generic route selects the webhook manager using the untrusted provider URL segment without verifying webhook.provid...
CVE-2026-72922 AutoGPT: Webhook provider path confusion bypasses generic webhook secret verification
AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. Prior to 0.6.70, AutoGPT's autogptplatform/backend/backend/api/features/integrations/router.py webhookingressgeneric route selected getwebhookmanagerprovider from the untrust...
CVE-2026-72922: Improper Authentication
AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. Prior to 0.6.70, AutoGPT's autogptplatform/backend/backend/api/features/integrations/router.py webhookingressgeneric route selected getwebhookmanagerprovider from the untrust...
PT-2026-70222
Name of the Vulnerable Software and Affected Versions AutoGPT versions prior to 0.6.70 Description AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. A path confusion issue exists in the webhook ingress generic route within...
autogpt-forge (>=0.1.0, <=0.1.3), cosmoai (>=0.6.0, <=0.6.6) +12 more potentially affected by CVE-2026-59822 via litellm (0.1.7713)
litellm PYPI version 0.1.7713 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - autogpt-forge =0.1.0, =0.6.0, =0.2.4, =0.1.11, =0.0.1, =0.1.7, =0.1.0, =0.1.2, =0.0.2, =0.0.3 - yival 0.1.0a4 Source cves: CVE-2026-59822 Sourc...
PYSEC-2026-1078 AutoGPT is Vulnerable to RCE via Disabled Block Execution
Summary AutoGPT Platform's block execution endpoints both main web API and external API allow executing blocks by UUID without checking the disabled flag. Any authenticated user can execute the disabled BlockInstallationBlock, which writes arbitrary Python code to the server filesystem and execut...
AutoGPT is Vulnerable to RCE via Disabled Block Execution
SummaryAutoGPT Platform's block execution endpoints both main web API and external API allow executing blocks by UUID without checking the disabled flag. Any authenticated user can execute the disabled BlockInstallationBlock, which writes arbitrary Python code to the server filesystem and execute...
autogpt-forge (>=0.1.0, <=0.1.3), cosmoai (>=0.6.0, <=0.6.6) +12 more potentially affected by CVE-2024-9606 via litellm (0.1.7713)
litellm PYPI version 0.1.7713 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - autogpt-forge =0.1.0, =0.6.0, =0.2.4, =0.1.11, =0.0.1, =0.1.7, =0.1.0, =0.1.2, =0.0.2, =0.0.3 - yival 0.1.0a4 Source cves: CVE-2024-9606 Source...
autogpt-forge (>=0.1.0, <=0.1.3), cosmoai (>=0.6.0, <=0.6.6) +12 more potentially affected by CVE-2024-4264 via litellm (0.1.7713)
litellm PYPI version 0.1.7713 is affected by a known vulnerability. The following packages have a transitive dependency on litellm and may be impacted: - autogpt-forge =0.1.0, =0.6.0, =0.2.4, =0.1.11, =0.0.1, =0.1.7, =0.1.0, =0.1.2, =0.0.2, =0.0.3 - yival 0.1.0a4 Source cves: CVE-2024-4264 Source...
AutoGPT bypass of the shell commands denylist settings
A vulnerability in significant-gravitas/autogpt version 0.5.1 allows an attacker to bypass the shell commands denylist settings. The issue arises when the denylist is configured to block specific commands, such as whoami and /bin/whoami. An attacker can circumvent this restriction by executing...
PYSEC-2026-257 AutoGPT bypass of the shell commands denylist settings
A vulnerability in significant-gravitas/autogpt version 0.5.1 allows an attacker to bypass the shell commands denylist settings. The issue arises when the denylist is configured to block specific commands, such as whoami and /bin/whoami. An attacker can circumvent this restriction by executing...
PT-2026-53354
A vulnerability in significant-gravitas/autogpt version 0.5.1 allows an attacker to bypass the shell commands denylist settings. The issue arises when the denylist is configured to block specific commands, such as whoami and /bin/whoami. An attacker can circumvent this restriction by executing...
CVE-2026-56663
AutoGPT is a workflow automation platform for creating, deploying, and managing continuous artificial intelligence agents. Prior to 0.6.52, an authenticated user can bypass the SSRF / private-IP protections in SendWebRequestBlock and reach internal network services. isipblocked in...