63 matches found
8base-js-sdk (>=0.1.0, <=0.1.6), 8base-react-sdk (>=0.37.2, <=2.6.6) +357 more potentially affected by CVE-2026-107371 via auth0-js (>=9.12.0, <=10.2.1)
auth0-js NPM version =9.12.0, =0.1.0, =0.37.2, =0.37.2, =1.0.1, =0.0.5, =0.0.0, =0.1.0, =0.37.2, =0.37.2, =0.37.2, =0.37.2, =0.37.2, =0.0.1, =0.4.1, =0.4.1, =3.1.0-beta.0 and more Source cves: CVE-2026-107371 Source advisory: SNYK:JS-AUTH0JS-20936882...
org.webjars.npm:github-com-auth0-angular-auth0 (3.0.0), org.webjars.npm:github-com-skiddoo-angular-lock (2.0.3) potentially affected by CVE-2026-107371 via org.webjars.npm:auth0-js (9.28.0)
org.webjars.npm:auth0-js MAVEN version 9.28.0 is affected by a known vulnerability. The following packages have a transitive dependency on org.webjars.npm:auth0-js and may be impacted: - org.webjars.npm:github-com-auth0-angular-auth0 3.0.0 - org.webjars.npm:github-com-skiddoo-angular-lock 2.0.3...
Insufficient Session Expiration
Overview auth0-js is an Auth0 headless browser sdk Affected versions of this package are vulnerable to Insufficient Session Expiration via the WebAuth authorize/parseHash transaction flow in src/web-auth/index.js and src/web-auth/transaction-manager.js. An attacker can submit an ID token from an...
CVE-2026-107371
When the authorize method is called with a maxAge parameter, the auth0.js library does not validate the authtime claim in the resulting ID token against the requested maxAge value. As a result, an application may process an ID token that represents an authentication event older than the requested...
CVE-2026-107371 Missing Verification of auth_time Claim in auth0.js
When the authorize method is called with a maxAge parameter, the auth0.js library does not validate the authtime claim in the resulting ID token against the requested maxAge value. As a result, an application may process an ID token that represents an authentication event older than the requested...
CVE-2026-107371
The auth0.js library contains a vulnerability where the authorize() method fails to validate the auth_time claim in the resulting ID token against the provided maxAge parameter. This flaw allows an application to potentially process an ID token representing an authentication event that is older t...
EUVD-2026-100483
When the authorize method is called with a maxAge parameter, the auth0.js library does not validate the authtime claim in the resulting ID token against the requested maxAge value. As a result, an application may process an ID token that represents an authentication event older than the requested...
CVE-2026-107371
When the authorize method is called with a maxAge parameter, the auth0.js library does not validate the authtime claim in the resulting ID token against the requested maxAge value. As a result, an application may process an ID token that represents an authentication event older than the requested...
CVE-2026-107371 Missing Verification of auth_time Claim in auth0.js
When the authorize method is called with a maxAge parameter, the auth0.js library does not validate the authtime claim in the resulting ID token against the requested maxAge value. As a result, an application may process an ID token that represents an authentication event older than the requested...
PT-2026-113367
🚨 CVE-2026-107371 When the authorize method is called with a maxAge parameter, the auth0.js library does not validate the auth time claim in the resulting ID token against the requested maxAge value. As a result, an application may process an ID token that represents an authentication event older...
CVE-2026-107371: Insufficient Session Expiration
When the authorize method is called with a maxAge parameter, the auth0.js library does not validate the authtime claim in the resulting ID token against the requested maxAge value. As a result, an application may process an ID token that represents an authentication event older than the requested...
CVE-2026-42280
Auth0.js is a client-side JavaScript library for Auth0. From 8.11.0 to 9.32.0, under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. This vulnerability is fixed in 10.0.0...
CVE-2026-42280
Auth0.js is a client-side JavaScript library for Auth0. From 8.11.0 to 9.32.0, under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. This vulnerability is fixed in 10.0.0...
8base-js-sdk (>=0.1.0, <=0.1.6), 8base-react-sdk (>=0.37.2, <=2.6.6) +438 more potentially affected by CVE-2026-42280 via auth0-js (>=8.11.3, <=9.32.0)
auth0-js NPM version =8.11.3, =0.1.0, =0.37.2, =0.37.2, =1.0.1, =0.0.5, =0.0.0, =0.1.0, =0.37.2, =0.37.2, =0.37.2, =0.37.2, =0.37.2, =0.0.1, =0.4.1, =0.4.1, =3.1.0-beta.0 and more Source cves: CVE-2026-42280 Source advisory: MEND:CVE-2026-42280...
CVE-2026-42280: Incorrect Authorization
Auth0.js is a client-side JavaScript library for Auth0. From 8.11.0 to 9.32.0, under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. This vulnerability is fixed in 10.0.0...
NPM: Auth.js SDK has Improper Permission Checking
NPM: Auth.js SDK has Improper Permission Checking vulnerability discovered by ? in WordPress Npm auth0-js versions = 8.11.0, = 9.32.0...
8base-js-sdk (>=0.1.0, <=0.1.6), 8base-react-sdk (>=0.37.2, <=2.6.6) +438 more potentially affected by CVE-2026-42280 via auth0-js (>=8.11.3, <=9.32.0)
auth0-js NPM version =8.11.3, =0.1.0, =0.37.2, =0.37.2, =1.0.1, =0.0.5, =0.0.0, =0.1.0, =0.37.2, =0.37.2, =0.37.2, =0.37.2, =0.37.2, =0.0.1, =0.4.1, =0.4.1, =3.1.0-beta.0 and more Source cves: CVE-2026-42280 Source advisory: GHSA-8QJV-JJ2Q-X832...
8base-js-sdk (>=0.1.0, <=0.1.6), 8base-react-sdk (>=0.37.2, <=2.6.6) +438 more potentially affected by CVE-2026-42280 via auth0-js (>=8.11.3, <=9.32.0)
auth0-js NPM version =8.11.3, =0.1.0, =0.37.2, =0.37.2, =1.0.1, =0.0.5, =0.0.0, =0.1.0, =0.37.2, =0.37.2, =0.37.2, =0.37.2, =0.37.2, =0.0.1, =0.4.1, =0.4.1, =3.1.0-beta.0 and more Source cves: CVE-2026-42280 Source advisory: OSV:GHSA-8QJV-JJ2Q-X832...
GHSA-8QJV-JJ2Q-X832 Auth.js SDK has Improper Permission Checking
Description Under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. Am I Affected? Users are affected if they meet each of the following preconditions: - Applications built...
8base-js-sdk (>=0.1.0, <=0.1.6), 8base-react-sdk (>=0.37.2, <=2.6.6) +438 more potentially affected by CVE-2026-42280 via auth0-js (>=8.11.3, <=9.32.0)
auth0-js NPM version =8.11.3, =0.1.0, =0.37.2, =0.37.2, =1.0.1, =0.0.5, =0.0.0, =0.1.0, =0.37.2, =0.37.2, =0.37.2, =0.37.2, =0.37.2, =0.0.1, =0.4.1, =0.4.1, =3.1.0-beta.0 and more Source cves: CVE-2026-42280 Source advisory: SNYK:JS-AUTH0JS-16438973...