13209 matches found
CVE-2024-47561
A vulnerability was found in Apache Avro. The project is affected and at risk if it accepts an org.apache.Avro/avroAvro schema for parsing provided by an end user. This flaw allows an attacker to trigger remote code execution by using the special "java-class" attribute. Mitigation 1. Avoid parsin...
cups-filters: libcupsfilters: `cfGetPrinterAttributes` API does not perform sanitization on returned IPP attributes
A flaw was found in OpenPrinting CUPS. In certain conditions, a remote attacker can add a malicious printer or directly hijack an existing printer by replacing the valid IPP URL with a malicious one. Also, it is possible that due to a lack of validation of IPP attributes returned by the server,...
cups-filters: libcupsfilters: `cfGetPrinterAttributes` API does not perform sanitization on returned IPP attributes
A flaw was found in OpenPrinting CUPS. In certain conditions, a remote attacker can add a malicious printer or directly hijack an existing printer by replacing the valid IPP URL with a malicious one. Also, it is possible that due to a lack of validation of IPP attributes returned by the server,...
WordPress Ibtana plugin <= 1.2.4.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via align Attribute vulnerability
Authenticated Contributor+ Stored Cross-Site Scripting via align Attribute vulnerability discovered by Francesco Carlucci in WordPress Plugin Ibtana versions = 1.2.4.4...
PT-2024-38912 · WordPress · Ibtana
Name of the Vulnerable Software and Affected Versions: Ibtana – WordPress Website Builder plugin for WordPress versions up to, and including, 1.2.4.4 Description: The issue is related to Stored Cross-Site Scripting via the align attribute within the 'wp:ive/ive-productscarousel' Gutenberg block d...
CVE-2024-8282: Improper Neutralization of Input During Web Page Generation
The Ibtana – WordPress Website Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘align’ attribute within the 'wp:ive/ive-productscarousel' Gutenberg block in all versions up to, and including, 1.2.4.4 due to insufficient input sanitization and output escaping. Thi...
cups-filters: libcupsfilters: `cfGetPrinterAttributes` API does not perform sanitization on returned IPP attributes
A flaw was found in OpenPrinting CUPS. In certain conditions, a remote attacker can add a malicious printer or directly hijack an existing printer by replacing the valid IPP URL with a malicious one. Also, it is possible that due to a lack of validation of IPP attributes returned by the server,...
389-ds-base: a heap overflow leading to denail-of-servce while writing a value larger than 256 chars (in log_entry_attr)
A heap overflow flaw was found in 389-ds-base. This issue leads to a denial of service when writing a value larger than 256 chars in logentryattr...
CVE-2024-47604
CVE-2024-47604 describes an XSS vulnerability in NuGetGallery’s handling of HTML element attributes. The issue could allow an attacker to execute arbitrary HTML or JavaScript in a victim’s browser. Affected product is NuGet Gallery (NuGet.org backend/frontend). The underlying root cause is improp...
CVE-2024-47604 XSS vulnerability in NuGetGallery HTML attributes handling
NuGet Gallery is a package repository that powers nuget.org. The NuGetGallery has a security vulnerability in its handling of HTML element attributes, which allows an attacker to execute arbitrary HTML or Javascript code in a victim's browser...
WordPress Guten Post Layout plugin <= 1.2.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via align Attribute vulnerability
Authenticated Contributor+ Stored Cross-Site Scripting via align Attribute vulnerability discovered by Francesco Carlucci in WordPress Plugin Guten Post Layout versions = 1.2.4...
uPlot Prototype Pollution vulnerability
Versions of the package uplot before 1.6.31 are vulnerable to Prototype Pollution via the uplot.assign function due to missing check if the attribute resolves to the object prototype...
CVE-2024-8288: Improper Neutralization of Input During Web Page Generation
The Guten Post Layout – An Advanced Post Grid Collection for WordPress Gutenberg plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘align’ attribute within the 'wp:guten-post-layout/post-grid' Gutenberg block in all versions up to, and including, 1.2.4 due to insufficient...
PT-2024-32668 · Microsoft · Nuget Gallery
Name of the Vulnerable Software and Affected Versions: NuGet Gallery affected versions not specified Description: The NuGet Gallery has a security issue in its handling of HTML element attributes. This allows an attacker to execute arbitrary HTML or Javascript code in a victim's browser...
PT-2024-38916 · WordPress · The Guten Post Layout
Name of the Vulnerable Software and Affected Versions: The Guten Post Layout – An Advanced Post Grid Collection for WordPress versions up to, and including, 1.2.4 Description: The issue is related to Stored Cross-Site Scripting via the align attribute within the 'wp:guten-post-layout/post-grid'...
K000141253: Python vulnerability CVE-2024-22195
Security Advisory Description Jinja is an extensible templating engine. Special placeholders in the template allow writing code similar to Python syntax. It is possible to inject arbitrary HTML attributes into the rendered HTML template, potentially leading to Cross-Site Scripting XSS. The Jinja...
DEBIAN-CVE-2024-47532
RestrictedPython is a restricted execution environment for Python to run untrusted code. A user can gain access to protected and potentially sensible information indirectly via AttributeError.obj and the string module. The problem will be fixed in version 7.3. As a workaround, If the application...
PYSEC-2024-186
RestrictedPython is a restricted execution environment for Python to run untrusted code. A user can gain access to protected and potentially sensible information indirectly via AttributeError.obj and the string module. The problem will be fixed in version 7.3. As a workaround, If the application...
Oracle Linux 9 : cups-filters (ELSA-2024-7346)
The remote Oracle Linux 9 host has packages installed that are affected by multiple vulnerabilities as referenced in the ELSA-2024-7346 advisory. - CVE-2024-47175 cups-filters: remote command injection via attacker controlled data in PPD file - CVE-2024-47076 cups-filters: cfGetPrinterAttributes...
SUSE CVE-2024-46859
In the Linux kernel, the following vulnerability has been resolved: platform/x86: panasonic-laptop: Fix SINF array out of bounds accesses The panasonic laptop code in various places uses the SINF array with index values of 0 - SINFCURBRIGHT0x0d without checking that the SINF array is big enough...