15 matches found
Malicious code in concurrently-async-graphql-triton (npm)
Source: amazon-inspector e423d178b25c621093439cac9ee66381edc17e5d3f4a0cd24bb4303865868754 This package appears to be part of the tea.xyz token reward campaign that flooded npm. These packages typically contain autopublish scripts auto.js, autopublish.js, autopublish2.js, autopublish3.js designed ...
CVE-2024-47614
async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10...
WS-2022-0182
Executing deeply nested queries may cause stack overflow in async-graphql before 4.0.6...
GHSA-5GC2-7C65-8FQ8 async-graphql Directive Overload
Impact - Service Disruption: The server may become unresponsive or extremely slow, potentially leading to downtime. - Resource Exhaustion: Excessive use of server resources, such as CPU and memory, could negatively impact other services running on the same infrastructure. - User Experience...
CVE-2024-47614
async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10...
CVE-2024-47614 async-graphql vulnerable to Directive Overload
async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10...
CVE-2024-47614
async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10...
CVE-2024-47614 async-graphql vulnerable to Directive Overload
async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10...
CVE-2024-47614 async-graphql vulnerable to Directive Overload
async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10...
CVE-2024-47614
The CVE-2024-47614 issue affects the Rust GraphQL server library async-graphql prior to version 7.0.10 . The vulnerability arises because it does not limit the number of directives for a field, which can lead to Service Disruption , Resource Exhaustion , and degraded User Experience . Affected so...
CVE-2024-47614: Allocation of Resources Without Limits or Throttling
async-graphql is a GraphQL server library implemented in Rust. async-graphql before 7.0.10 does not limit the number of directives for a field. This can lead to Service Disruption, Resource Exhaustion, and User Experience Degradation. This vulnerability is fixed in 7.0.10...
Async-GraphQL security vulnerabilities
async-graphql is a fully compliant high-performance graphql server library from the async-graphql open source. A security vulnerability exists in async-graphql versions prior to 7.0.10 that stems from the number of commands in an unrestricted field, which could lead to service disruption, resourc...
PT-2024-32674
Name of the Vulnerable Software and Affected Versions async-graphql versions prior to 7.0.10 Description The issue is related to the async-graphql library, a GraphQL server implemented in Rust, where it does not limit the number of directives for a field. This can lead to Service Disruption,...
account-db (0.1.0), anything (>=0.1.0, <=0.1.4) +106 more potentially affected by CVE-2021-45720 via lru (>=0.1.17, <=0.6.6)
lru CARGO version =0.1.17, =0.1.0, =0.1.1, =0.1.1, =0.1.0, =0.1.1, =0.0.1, =0.11.0, =0.3.0-beta.1, =0.1.9, =0.8.0-alpha1, =0.8.1 - cw-erc20 0.4.0 - cw-escrow 0.4.0 and more Source cves: CVE-2021-45720 Source advisory: GHSA-V362-2895-H9R2...
acheron (0.1.0), c2rust (>=0.10.0, <=0.15.1) +68 more potentially affected by CVE-2020-25791 via sized-chunks (>=0.1.3, <=0.5.3)
sized-chunks CARGO version =0.1.3, =0.10.0, =0.10.0, =0.33.0, =0.3.13, =0.6.0, =0.4.19, =0.1.0, =0.5.0, =0.1.0, =0.3.1 - cargo-local 0.1.1 - cargo-local-registry 0.2.1 and more Source cves: CVE-2020-25791 Source advisory: GHSA-9P9M-9XWW-QJCX...