14981 matches found
Unbound loop can brick contract and freeze miner payments
Lines of code Vulnerability details Impact The payees array in the MinerPayer.sol contract can grow to an unbounded size. That means it could grow so large that the MinerPayer.release function can't loop through them all without triggering an out of gas error. Updating the payees array in the...
Qualcomm Input Verification Error Vulnerability
A Qualcomm chip is a chip from Qualcomm Incorporated USA. A way to miniaturize circuits including primarily semiconductor devices, but also passive components, etc., and from time to time fabricated on the surface of semiconductor wafers. An input validation error vulnerability exists in the Mode...
PT-2025-8481
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description A potential array overflow issue has been identified in the Linux kernel, specifically in the bpf trampoline get progs function. The issue arises when the number of attached BPF TRAMP...
CVE-2022-29085
Dell Unity, Dell UnityVSA, and Dell Unity XT versions prior to 5.2.0.0.5.173 contain a plain-text password storage vulnerability when certain off-array tools are run on the system. The credentials of a user with high privileges are stored in plain text. A local malicious user with high privileges...
IBM Java 7.0 < 7.0.10.50 / 7.1 < 7.1.4.50 / 8.0 < 8.0.5.40 Multiple Vulnerabilities
The version of IBM Java installed on the remote host is prior to 7.0 7.0.10.50 / 7.1 7.1.4.50 / 8.0 8.0.5.40. It is, therefore, affected by multiple vulnerabilities as referenced in the IBM Security Update July 2019 advisory. - Multiple binaries in IBM SDK, Java Technology Edition 7, 7R, and 8 on...
njs Array Prototype Concat DoS
The vulnerability of the Array.prototype.concat function in the njs interpreter on the nginx server is related to the execution of the operation beyond the buffer boundaries in memory. Exploiting this vulnerability could allow a remote attacker to cause a service failure...
Oracle MySQL Cluster Data Node Improper Validation of Array Index Information Disclosure Vulnerability
This vulnerability allows remote attackers to disclose sensitive information on affected installations of Oracle MySQL Cluster. Authentication is not required to exploit this vulnerability. The specific flaw exists within the processing of Data Node jobs. The issue results from the lack of proper...
Oracle MySQL Cluster Data Node Improper Validation of Array Index Information Disclosure Vulnerability
This vulnerability allows remote attackers to disclose sensitive information on affected installations of Oracle MySQL Cluster. Authentication is not required to exploit this vulnerability. The specific flaw exists within the processing of Data Node jobs. The issue results from the lack of proper...
Oracle MySQL Cluster Data Node Improper Validation of Array Index Remote Code Execution Vulnerability
This vulnerability allows remote attackers to execute arbitrary code on affected installations of Oracle MySQL Cluster. Authentication is not required to exploit this vulnerability. The specific flaw exists within the processing of Data Node jobs. The issue results from the lack of proper...
Oracle MySQL Cluster Data Node Improper Validation of Array Index Information Disclosure Vulnerability
This vulnerability allows remote attackers to disclose sensitive information on affected installations of Oracle MySQL Cluster. Authentication is not required to exploit this vulnerability. The specific flaw exists within the processing of Data Node jobs. The issue results from the lack of proper...
RUSTSEC-2022-0017 `array!` macro is unsound when its length is impure constant
Affected versions of this crate did substitute the array length provided by an user at compile-time multiple times. When an impure constant expression is passed as an array length such as a result of an impure procedural macro, this can result in the initialization of an array with uninitialized...
`array!` macro is unsound when its length is impure constant
Affected versions of this crate did substitute the array length provided by an user at compile-time multiple times. When an impure constant expression is passed as an array length such as a result of an impure procedural macro, this can result in the initialization of an array with uninitialized...
mariadb: Integer overflow in sql_lex.cc integer leading to crash
An integer overflow vulnerability was found in MariaDB, where an invalid size of refpointerarray is allocated. This issue results in a denial of service...
GSD-2022-1001567 ASoC: codecs: va-macro: fix accessing array out of bounds for enum type
ASoC: codecs: va-macro: fix accessing array out of bounds for enum type This is an automated ID intended to aid in discovery of potential security vulnerabilities. The actual impact and attack plausibility have not yet been proven. This ID is fixed in Linux Kernel version v5.16.19 by commit...
GSD-2022-1001260 ASoC: codecs: wc938x: fix accessing array out of bounds for enum type
ASoC: codecs: wc938x: fix accessing array out of bounds for enum type This is an automated ID intended to aid in discovery of potential security vulnerabilities. The actual impact and attack plausibility have not yet been proven. This ID is fixed in Linux Kernel version v5.17.2 by commit...
GSD-2022-1001177 clk: visconti: prevent array overflow in visconti_clk_register_gates()
clk: visconti: prevent array overflow in visconticlkregistergates This is an automated ID intended to aid in discovery of potential security vulnerabilities. The actual impact and attack plausibility have not yet been proven. This ID is fixed in Linux Kernel version v5.17.2 by commit...
PT-2022-30734
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v4.9.311 Description The issue is related to a potential null return of kmalloc array in the drm/amdkfd component. The actual impact and attack plausibility have not yet been proven. Recommendations For Linux...
PT-2022-29910
Name of the Vulnerable Software and Affected Versions Linux Kernel versions v5.13 through v5.16.17 Description The issue is related to the drm/virtio component, specifically in the virtio gpu array put free function, where it does not check if objs is NULL. This could potentially lead to security...
PT-2022-29450
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v5.17.2 Description The issue is related to preventing array overflow in the visconti clk register gates function. The actual impact and attack plausibility have not yet been proven. Recommendations For Linux...
PT-2022-29704
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v5.16.19 Description A potential security issue exists where the page array is not freed when the watch queue is dismantled. The actual impact and attack plausibility have not yet been proven. Recommendations For...