14979 matches found
PT-2022-32165
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v4.19.247 Description The issue is related to an array-index-out-of-bounds in the pvr2 i2c core init function. The actual impact and attack plausibility have not yet been proven. Recommendations For Linux Kernel...
PT-2022-32273
Name of the Vulnerable Software and Affected Versions Linux Kernel versions v2.6.18 through v4.14.282 Description The issue is related to an array-index-out-of-bounds in the pvr2 i2c core init function. The actual impact and attack plausibility have not yet been proven. Recommendations For Linux...
PT-2022-31916
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v5.10.120 Description The issue concerns a potential array overflow in the bpf trampoline get progs function. The actual impact and attack plausibility have not yet been proven. Recommendations For Linux Kernel...
PT-2022-32065
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v5.4.198 Description The issue is related to an array-index-out-of-bounds in the pvr2 i2c core init function. The actual impact and attack plausibility have not yet been proven. Recommendations For Linux Kernel...
PT-2022-31869
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v5.10.121 Description The issue is related to an array-index-out-of-bounds in the pvr2 i2c core init function. The actual impact and attack plausibility have not yet been proven. Recommendations For Linux Kernel...
PT-2022-31444
Name of the Vulnerable Software and Affected Versions Linux Kernel versions v5.7 through v5.17.12 Description The issue concerns a potential array overflow in the bpf trampoline get progs function. The actual impact and attack plausibility have not yet been proven. Recommendations For Linux Kerne...
PT-2022-31708
Name of the Vulnerable Software and Affected Versions Linux Kernel versions prior to v5.15.46 Description The issue concerns an out-of-bounds array access in the Linux Kernel. It was introduced in version v5.14 and fixed in version v5.15.46. The actual impact and attack plausibility have not yet...
CVE-2021-40941
In Bento4 1.6.0-638, there is an allocator is out of memory in the function AP4Array::EnsureCapacity in Ap4Array.h:172, as demonstrated by GPAC. This can cause a denial of service DOS...
UBUNTU-CVE-2021-40941
In Bento4 1.6.0-638, there is an allocator is out of memory in the function AP4Array::EnsureCapacity in Ap4Array.h:172, as demonstrated by GPAC. This can cause a denial of service DOS...
Out-of-bound read data in function suggest_trie_walk() abusing array byts
Description Out-of-bound read data in function suggesttriewalk abusing array byts in line spellsuggest.c:1925 Tested version: v8.2.5166 commit f65cc665fa751bad3ffe75f58ce1251d6695949f HEAD - master, tag: v8.2.5166, origin/master, origin/HEAD Author: Bram Moolenaar Date: Sun Jun 26 18:17:50 2022...
PT-2022-11340
Name of the Vulnerable Software and Affected Versions Bento4 version 1.6.0-638 Description The issue is related to an allocator running out of memory in the AP4 Array::EnsureCapacity function, located in Ap4Array.h:172. This can cause a denial of service DOS, as demonstrated by GPAC...
removeAddress doesn't decrease the contracts.length
Lines of code Vulnerability details Impact The contracts length will always increase because the removeAddress function just deleting the value inside the array and never decrease the length by calling pop method. This can lead to Dos when calling functions that doing loop on contracts storage:...
Denial of Service by wrong BatchRequests.removeAddress logic
Lines of code Vulnerability details Impact The BatchRequests.removeAddress logic is wrong and it will produce a denial of service. Proof of Concept Removing the element from the array is done using the delete statement, but this is not the proper way to remove an entry from an array, it will just...
TWAP array can be artificially filled up with the most recent quote
Lines of code Vulnerability details A malicious user can run updateTWAV on each block, quickly replacing all four values of the twavObservations array with the most recent valuation. I.e. the time weighted averaging essence of the recorded price can be directly reduced to always be just most rece...
Ineffective TWAV Implementation
Lines of code Vulnerability details Background The current TWAV implementation consists of an array of 4 observations/valuations called twavObservations. Whenever, the new valuation is updated, the new cumulative valuation will be appended to the twavObservations array and the oldest...
NTFS File System Heap Buffer Overflow Privilege Escalation
The vulnerability of the ntfschecklogclientarray function in the NTFS file system relates to buffer overflows in dynamic memory. Exploiting this vulnerability allows an attacker to execute arbitrary code with elevated privileges using a specially created NTFS image file...
CVE-2022-31306
Nginx NJS v0.7.2 was discovered to contain a segmentation violation in the function njsarrayconverttoslowarray at src/njsarray.c...
Design/Logic Flaw
Nginx NJS v0.7.2 was discovered to contain a segmentation violation in the function njsarrayconverttoslowarray at src/njsarray.c...
Nginx resource management error vulnerabilities
Nginx is a lightweight web server/reverse proxy server and email IMAP/POP3 proxy server from Nginx, Inc. njs is one of the scripting language components that supports extended NGINX functionality. A security vulnerability exists in Nginx NJS version v0.7.2, which stems from a segmentation violati...
Spring Data MongoDB SpEL Expression Injection Vulnerability (CVE-2022-22980)
Updates 06-20 CVE-2022-22980 is published 06-20 Spring Data MongoDB 3.4.1 and 3.3.5 are available Table of Contents Overview Vulnerability Am I Impacted Status Suggested Workarounds Overview We would like to announce that we have released Spring Data MongoDB 3.4.1 and 3.3.5 to address the followi...