14978 matches found
CLSA-2022-1658856539 Fix CVE(s): CVE-2022-2289, CVE-2022-2304
SECURITY UPDATE: Accessing freed memory with diff put - debian/patches/CVE-2022-2289.patch: Bail out when diff pointer is no longer valid - CVE-2022-2289 SECURITY UPDATE: Spell dump may go beyond end of an array - debian/patches/CVE-2022-2304.patch: Limit the word length - CVE-2022-2304...
Stack overflow
An issue was discovered in mjs mJS: Restricted JavaScript engine, ES6 JavaScript version 6. There is stack buffer overflow in jsonparsearray in mjs.c...
PT-2022-10234
Name of the Vulnerable Software and Affected Versions mjs affected versions not specified Description An issue was discovered in mjs, a Restricted JavaScript engine, specifically in the ES6 version of JavaScript. The problem is a stack buffer overflow in the json parse array function located in...
Cesanta MJS buffer error vulnerability
Cesanta MJS is an embedded JavaScript engine for C/C++ from Cesanta Ireland. It is designed for microcontrollers with limited resources. The main design goals are a small footprint and simple C/C++ interoperability. A security vulnerability exists in Cesanta MJS mJS: Restricted JavaScript engine...
CVE-2022-35737
An array-bounds overflow vulnerability was discovered in SQLite. The vulnerability occurs when handling an overly large input passed as a string argument to some of the C-language APIs provided by SQLite. This flaw allows a remote attacker to pass specially crafted large input to the application...
PT-2022-5232
Name of the Vulnerable Software and Affected Versions SQLite versions 1.0.12 through 3.39.x before 3.39.2 Description The issue is related to an array-bounds overflow in the SQLite API library, which can be triggered by a remote attacker using a long sequence of string data processed by the print...
OESA-2022-1755 nodejs-jsonpointer security update
Simple JSON Addressing. Security Fixes: This affects the package jsonpointer before 5.0.0. A type confusion vulnerability can lead to a bypass of a previous Prototype Pollution fix when the pointer components are arrays.CVE-2021-23807...
Exploit for CVE-2022-30190
Follina-MSDT-Vulnerability-CVE-2022-30190- Detection and Remed...
Kafka: Timing Attack Vulnerability for Apache Kafka Connect and Clients
Some components in Apache Kafka use Arrays.equals to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been...
EulerOS Virtualization 2.10.0 : gnupg2 (EulerOS-SA-2022-2024)
According to the versions of the gnupg2 package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : - GnuPG 2.2.21 and 2.2.22 and Gpg4win 3.1.12 has an array overflow, leading to a crash or possibly unspecified other impact, when a...
EulerOS Virtualization 2.10.1 : gnupg2 (EulerOS-SA-2022-2052)
According to the versions of the gnupg2 package installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : - GnuPG 2.2.21 and 2.2.22 and Gpg4win 3.1.12 has an array overflow, leading to a crash or possibly unspecified other impact, when a...
EulerOS Virtualization 2.10.1 : kernel (EulerOS-SA-2022-2081)
According to the versions of the kernel packages installed, the EulerOS Virtualization installation on the remote host is affected by the following vulnerabilities : - In drivers/usb/gadget/udc/udc-xilinx.c in the Linux kernel before 5.16.12, the endpoint index is not validated and might be...
Huawei EulerOS: Security Advisory for gnupg2 (EulerOS-SA-2022-2024)
The remote host is missing an update for the Huawei EulerOS SPDX-FileCopyrightText: 2022 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
feenominators are set incorrectly through setFee function
Lines of code Vulnerability details Impact feenominators supposed to be updated using the array of indexes i not the current position of array length d Proof of Concept The function updates the fenominatorsx instead of feenominatorsix for uint256 x; x len; if dx MINFEENOMINATOR revert Exception18...
[slackware-security] xorg-server
New xorg-server packages are available for Slackware 15.0 and -current to fix security issues. Here are the details from the Slackware 15.0 ChangeLog: patches/packages/xorg-server-1.20.14-i586-3slack15.0.txz: Rebuilt. xkb: switch to array index loops to moving pointers. xkb: add request length...
kernel: dm integrity: fix memory corruption when tag_size is less than digest size
In the Linux kernel, the following vulnerability has been resolved: dm integrity: fix memory corruption when tagsize is less than digest size It is possible to set up dm-integrity in such a way that the "tagsize" parameter is less than the actual digest size. In this situation, a part of the dige...
JBPayoutRedemptionPaymentTerminal#processFees may run out of gas and revert due to long list of _heldFeesOf[_projectId]
Lines of code Vulnerability details Proof of Concept // Get a reference to the project's held fees. JBFee memory heldFees = heldFeesOfprojectId; // Delete the held fees. delete heldFeesOfprojectId; // Push array length in stack uint256 heldFeeLength = heldFees.length; // Process each fee. for...
CLSA-2022-1657182029 Fix CVE(s): CVE-2022-31626, CVE-2022-31625
SECURITY UPDATE: RCE via Uninitialized array in pgqueryparams - debian/patches/CVE-2022-31625.patch: don't free parameters which haven't initialized yet in ext/pgsql/pgsql.c, ext/pgsql/tests/bug81720.phpt. - CVE-2022-31625 SECURITY UPDATE: RCE via mysqlnd/pdo password buffer overflow -...
AtomicReferenceArray Class Concurrency DoS
The vulnerability of the AtomicReferenceArray class implementation in the Java Runtime Environment concurrency component is related to errors in object type handling. Exploiting this vulnerability can allow an attacker to cause service failures remotely...
CVE-2022-31603
NVIDIA DGX A100 contains a vulnerability in SBIOS in the IpSecDxe, where a user with high privileges and preconditioned IpSecDxe global data can exploit improper validation of an array index to cause code execution, which may lead to denial of service, data integrity impact, and information...