14974 matches found
ASB-A-238379819
a function called 'nlaparse', do not check the len of para, it will check nlatype which can be controlled by userspace with 'maxtype' in this case, it is GSCANMAX, then it access polciy array 'policytype', which OOB access happens...
PT-2025-49464
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description An integer overflow exists in the dfl feature ioctl set irq function when handling the multiplication of hdr.count and sizeofs32 on 32-bit systems. This calculation can overflow, leading...
Denial of service through string value parsing
Fuzz testing, by Ada Logics and sponsored by the CNCF, identified input to functions in the strvals package that can cause an out of memory panic. Out of memory panics cannot be recovered from. Applications that use functions from the strvals package in the Helm SDK can have a Denial of Service...
PHP pg_queryParams Code Execution
The vulnerability of the pgqueryParams function in the PHP programming language is related to the misuse of an uninitialized array. Exploiting this vulnerability allows a remote attacker to execute arbitrary code...
PT-2025-25871
Name of the Vulnerable Software and Affected Versions Linux kernel affected versions not specified Description A vulnerability in the Linux kernel has been identified, specifically in the gpio-fan driver. The issue arises from the driver's failure to check if the cooling state passed to gpio fan...
SUSE SLED15 / SLES15 / openSUSE 15 Security Update : raptor (SUSE-SU-2022:2896-1)
The remote SUSE Linux SLED15 / SLEDSAP15 / SLES15 / SLESSAP15 / openSUSE 15 host has packages installed that are affected by a vulnerability as referenced in the SUSE-SU-2022:2896-1 advisory. - CVE-2020-25713: Fixed an out of bounds access triggered via a malformed input file bsc1178903. Tenable...
Ubuntu: Security Advisory (USN-2023-1)
The remote host is missing an update for the SPDX-FileCopyrightText: 2022 Greenbone AG Some text descriptions might be excerpted from a referenced sources, and are Copyright C by the respective right holders. SPDX-License-Identifier: GPL-2.0-only ifdescription...
PT-2025-25911
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 5.19.0 Description The issue is related to the use of tnum range in array range checking for poke descriptors in the Linux kernel. A problem arises when a range of tnum range0, map-max entries - 1 has limited...
RHEL 8 : php:7.4 (RHSA-2022:6158)
The remote Redhat Enterprise Linux 8 host has packages installed that are affected by a vulnerability as referenced in the RHSA-2022:6158 advisory. PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Server. Security Fixes: php: uninitialized array in pgqueryparams leadi...
Moderate: Red Hat Security Advisory: php:7.4 security update
An update for the php:7.4 module is now available for Red Hat Enterprise Linux 8. Red Hat Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System CVSS base score, which gives a detailed severity rating, is available for each...
php: Uninitialized array in pg_query_params() leading to RCE
A vulnerability was found in PHP due to an uninitialized array in pgqueryparams function. When using the Postgres database extension, supplying invalid parameters to the parameterized query may lead to PHP attempting to free memory, using uninitialized data as pointers. This flaw allows a remote...
RLSA-2022:6158 Moderate: php:7.4 security update
PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Server. Security Fixes: php: uninitialized array in pgqueryparams leading to RCE CVE-2022-31625 For more details about the security issues, including the impact, a CVSS score, acknowledgments, and other related...
UBUNTU-CVE-2022-38475
An attacker could have written a value to the first element in a zero-length JavaScript array. Although the array was zero-length, the value was not written to an invalid memory address. This vulnerability affects Firefox 104...
Mozilla Firefox security vulnerabilities
Mozilla Thunderbird is the United States Mozilla Foundation's set of independent from the Mozilla Application Suite e-mail client software. The program supports IMAP and POP mail protocols as well as HTML mail format. A security vulnerability exists in versions prior to Mozilla Firefox 104, where...
PT-2022-4673
Name of the Vulnerable Software and Affected Versions Firefox versions prior to 104 Description The issue is related to insufficient input validation when handling array element values, allowing a remote attacker to bypass security restrictions. An attacker could write a value to the first elemen...
NJS Interpreter Privilege Escalation
The vulnerability of the njsarrayconverttoslowarray function src/njsarray.c in the njs interpreter of the nginx server involves an uncontrolled resource consumption. Exploiting this vulnerability can allow a remote attacker to increase their privileges...
CVE-2020-27793
An off-by-one overflow flaw was found in radare2 due to mismatched array length in corejava.c. This could allow an attacker to cause a crash, and perform a denail of service attack...
CVE-2020-27793
An off-by-one overflow flaw was found in radare2 due to mismatched array length in corejava.c. This could allow an attacker to cause a crash, and perform a denail of service attack...
UBUNTU-CVE-2020-27793
An off-by-one overflow flaw was found in radare2 due to mismatched array length in corejava.c. This could allow an attacker to cause a crash, and perform a denail of service attack...
Buffer overflow
An off-by-one overflow flaw was found in radare2 due to mismatched array length in corejava.c. This could allow an attacker to cause a crash, and perform a denail of service attack...